aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-09-08 23:28:15 +0800
committerdinoex <dinoex@FreeBSD.org>2013-09-08 23:28:15 +0800
commit21da9ed41aa591174481b37446fd9158efdb0c7d (patch)
tree8c40cc359cd7e6d7b41999b3785154a746d7ccc7
parent425f725ec6eb1a92645aca93c5f56d2bf6c71ed3 (diff)
downloadfreebsd-ports-gnome-21da9ed41aa591174481b37446fd9158efdb0c7d.tar.gz
freebsd-ports-gnome-21da9ed41aa591174481b37446fd9158efdb0c7d.tar.zst
freebsd-ports-gnome-21da9ed41aa591174481b37446fd9158efdb0c7d.zip
- update to 2.34.0
- new option ANN for edge bundling
-rw-r--r--graphics/graphviz/Makefile18
-rw-r--r--graphics/graphviz/distinfo4
-rw-r--r--graphics/graphviz/files/patch-config_perl.pl14
-rw-r--r--graphics/graphviz/files/patch-configure16
-rw-r--r--graphics/graphviz/pkg-plist2
5 files changed, 27 insertions, 27 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 05282ee14b69..bff208abf644 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= graphviz
-PORTVERSION= 2.32.0
+PORTVERSION= 2.34.0
CATEGORIES= graphics tk
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
@@ -61,12 +61,13 @@ PDOCS_HTML= doc/*.html doc/info/*.gif
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
-OPTIONS_DEFINE= XPM DIGCOLA IPSEPCOLA ICONV NLS PANGOCAIRO LIBRSVG2 POPPLER GTK2 GDK_PIXBUF GNOMEUI SMYRNA GVEDIT MING DEVIL GHOSTSCRIPT PERL PHP PYTHON RUBY LUA TCL GUILE TK NVTHREADS
+OPTIONS_DEFINE= XPM DIGCOLA IPSEPCOLA ICONV NLS PANGOCAIRO LIBRSVG2 POPPLER ANN GTK2 GDK_PIXBUF GNOMEUI SMYRNA GVEDIT MING DEVIL GHOSTSCRIPT PERL PHP PYTHON RUBY LUA TCL GUILE TK NVTHREADS
OPTIONS_DEFAULT?= XPM DIGCOLA IPSEPCOLA ICONV NLS PANGOCAIRO
NO_OPTIONS_SORT=yes
DIGCOLA_DESC= neato layout engine wiwth DIGCOLA features
IPSEPCOLA_DESC= neato layout engine wiwth IPSEPCOLA features
PANGOCAIRO_DESC=pangocairo support
+ANN_DESC= ANN edge bundling support
SMYRNA_DESC= SMYRNA graph viewer (requires GTK2)
GVEDIT_DESC= gvedit (requires qt)
GTK2_DESC= gtk2 plugin (requires PANGOCAIRO)
@@ -166,7 +167,7 @@ PLIST_SUB+= WITH_PANGOCAIRO="@comment "
CONFIGURE_ARGS+= --with-rsvg=yes
PLIST_SUB+= WITH_RSVG=""
USE_GNOME+= librsvg2
-USE_GL+= gl glu
+USE_GL+= gl glu glut
.if empty(PORT_OPTIONS:MPANGOCAIRO)
IGNORE= option PANGOCAIRO is required for option LIBRVG2
.endif
@@ -184,6 +185,17 @@ CONFIGURE_ARGS+= --without-poppler
PLIST_SUB+= WITH_POPPLER="@comment "
.endif
+.if ${PORT_OPTIONS:MANN}
+LIB_DEPENDS+= ann:${PORTSDIR}/math/ann
+CONFIGURE_ENV+= ANN_CFLAGS=-I${LOCALBASE}/include ANN_LIBS=-lann
+CONFIGURE_ARGS+= --with-ann=yes
+PLIST_SUB+= WITH_ANN=""
+MAN1+= mingle.1
+.else
+CONFIGURE_ARGS+= --without-ann
+PLIST_SUB+= WITH_ANN="@comment "
+.endif
+
.if ${PORT_OPTIONS:MGTK2}
CONFIGURE_ARGS+= --with-gtk
PLIST_SUB+= WITH_GTK=""
diff --git a/graphics/graphviz/distinfo b/graphics/graphviz/distinfo
index 48265ce4a043..9f2b3af7c33c 100644
--- a/graphics/graphviz/distinfo
+++ b/graphics/graphviz/distinfo
@@ -1,2 +1,2 @@
-SHA256 (graphviz-2.32.0.tar.gz) = d853b2313e08a1dd0cce20d9ff8051acfa9ec418b5ba2dc65c8f4ddb07a7a77a
-SIZE (graphviz-2.32.0.tar.gz) = 23756717
+SHA256 (graphviz-2.34.0.tar.gz) = d94abca5745aa4c5808ab56cd3d0ec9ed14fb76a5a88d39e1f234fa84d22d764
+SIZE (graphviz-2.34.0.tar.gz) = 23921350
diff --git a/graphics/graphviz/files/patch-config_perl.pl b/graphics/graphviz/files/patch-config_perl.pl
deleted file mode 100644
index ca1af27909cd..000000000000
--- a/graphics/graphviz/files/patch-config_perl.pl
+++ /dev/null
@@ -1,14 +0,0 @@
---- config/config_perl.pl.orig 2013-02-15 00:27:39.000000000 +1100
-+++ config/config_perl.pl 2013-06-18 11:18:34.000000000 +1100
-@@ -11,10 +11,9 @@
- print "-I$archlib/CORE";
- }
- if ($ARGV[0] eq "PERL_INSTALL_DIR") {
--
- my $d;
-
-- foreach $d qw(installvendorarch vendorarch installsitearch sitearch) {
-+ foreach $d ( qw(installvendorarch vendorarch installsitearch sitearch) ) {
- if (exists($Config{$d}) and defined($Config{$d}) and
- ($Config{$d} ne '') ) {
- print "$Config{$d}";
diff --git a/graphics/graphviz/files/patch-configure b/graphics/graphviz/files/patch-configure
index f88f8bbc795d..5a647c4fcf05 100644
--- a/graphics/graphviz/files/patch-configure
+++ b/graphics/graphviz/files/patch-configure
@@ -1,8 +1,8 @@
---- configure.orig 2013-02-14 14:30:22.000000000 +0100
-+++ configure 2013-06-28 08:33:36.000000000 +0200
-@@ -17696,6 +17696,9 @@
- *-apple-darwin* )
+--- configure.orig 2013-09-07 03:11:08.000000000 +0200
++++ configure 2013-09-08 14:44:48.000000000 +0200
+@@ -17820,6 +17820,9 @@
CFLAGS="${CFLAGS} -fno-common -Wall"
+ LDFLAGS="${LDFLAGS} -Wl,-headerpad_max_install_names"
;;
+ *alpha*-freebsd* )
+ CFLAGS="${CFLAGS} -Wstrict-prototypes -Wpointer-arith -Wall"
@@ -10,7 +10,7 @@
*-freebsd* )
CFLAGS="${CFLAGS} -Wstrict-prototypes -Wpointer-arith -Wall -ffast-math"
;;
-@@ -21518,7 +21521,9 @@
+@@ -21662,7 +21665,9 @@
LUA_INCLUDES=""
LUA_LIBS=""
@@ -21,9 +21,9 @@
if test -n "$lua_inc"; then
CFLAGS="$CFLAGS -I$lua_inc"
-@@ -21580,13 +21585,13 @@
+@@ -21724,13 +21729,13 @@
pkgconfig_lua_found=`$PKGCONFIG --exists lua$l 2>/dev/null`
- if test "x$?" == "x0" ; then
+ if test "x$?" = "x0" ; then
LUA_VERSION=`$PKGCONFIG --modversion lua$l`
- LUA_INCLUDES="$LUA_CFLAGS "`$PKGCONFIG --cflags lua$l`
+ LUA_INCLUDES="$LUA_CFLAGS "`$PKGCONFIG --cflags-only-I lua$l`
@@ -31,7 +31,7 @@
LUA_INSTALL_DIR="/usr/lib$LIBPOSTFIX/lua/`$PKGCONFIG --variable=V lua`"
pkgconfig_lualib_found=`$PKGCONFIG --exists lualib$l 2>/dev/null`
- if test "x$?" == "x0"; then
+ if test "x$?" = "x0"; then
- LUA_INCLUDES="$LUA_CFLAGS "`$PKGCONFIG --cflags lualib$l`
+ LUA_INCLUDES="$LUA_CFLAGS "`$PKGCONFIG --cflags-only-I lualib$l`
LUA_LIBS="$LUA_LFLAGS "`$PKGCONFIG --libs lualib$l`
diff --git a/graphics/graphviz/pkg-plist b/graphics/graphviz/pkg-plist
index e7b27b34c10a..772929ff9cdf 100644
--- a/graphics/graphviz/pkg-plist
+++ b/graphics/graphviz/pkg-plist
@@ -26,6 +26,7 @@ bin/gxl2gv
bin/gxl2dot
%%WITH_XPM%%bin/lefty
%%WITH_XPM%%bin/lneato
+%%WITH_ANN%%bin/mingle
bin/mm2gv
bin/neato
bin/nop
@@ -388,6 +389,7 @@ libdata/pkgconfig/libxdot.pc
%%PORTDOCS%%%%DOCSDIR%%/pdf/leftyguide.pdf
%%PORTDOCS%%%%DOCSDIR%%/pdf/libguide.pdf
%%PORTDOCS%%%%DOCSDIR%%/pdf/lneato.1.pdf
+%%PORTDOCS%%%%DOCSDIR%%/pdf/mingle.1.pdf
%%PORTDOCS%%%%DOCSDIR%%/pdf/mm2gv.1.pdf
%%PORTDOCS%%%%DOCSDIR%%/pdf/neato.1.pdf
%%PORTDOCS%%%%DOCSDIR%%/pdf/neatoguide.pdf