aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2017-10-19 06:48:43 +0800
committerdbaio <dbaio@FreeBSD.org>2017-10-19 06:48:43 +0800
commit2277918dc37ae24da9f921baf5b0bf3bf98fa972 (patch)
tree18bb533cab5ba0523fea0bdb6c4ecb549e8103f8
parent2dda8e3d20b50cfe76ec9a0795b9640dc32df300 (diff)
downloadfreebsd-ports-gnome-2277918dc37ae24da9f921baf5b0bf3bf98fa972.tar.gz
freebsd-ports-gnome-2277918dc37ae24da9f921baf5b0bf3bf98fa972.tar.zst
freebsd-ports-gnome-2277918dc37ae24da9f921baf5b0bf3bf98fa972.zip
New port mail/py-afew: Initial tagging script for notmuch mail
Its basic task is to provide automatic tagging each time new mail is registered with notmuch. In a classic setup, you might call it after 'notmuch new' in an offlineimap post sync hook. It can do basic thing such as adding tags based on email headers or maildir folders, handling killed threads and spam. In move mode, afew will move mails between maildir folders according to configurable rules that can contain arbitrary notmuch queries to match against any searchable attributes. WWW: https://github.com/afewmail/afew PR: 222629 Submitted by: Sebastian Schwarz <seschwar@gmail.com> Reviewed by: mat, koobs Differential Revision: D12520
-rw-r--r--mail/Makefile1
-rw-r--r--mail/py-afew/Makefile42
-rw-r--r--mail/py-afew/distinfo3
-rw-r--r--mail/py-afew/pkg-descr14
4 files changed, 60 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 5388a8aa2a06..7a5ac260d6ee 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -527,6 +527,7 @@
SUBDIR += proxsmtp
SUBDIR += py-Products.MailHost
SUBDIR += py-Products.SecureMailHost
+ SUBDIR += py-afew
SUBDIR += py-aiosmtpd
SUBDIR += py-apolicy
SUBDIR += py-authres
diff --git a/mail/py-afew/Makefile b/mail/py-afew/Makefile
new file mode 100644
index 000000000000..27cc60735b76
--- /dev/null
+++ b/mail/py-afew/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= afew
+DISTVERSION= 1.2.0
+CATEGORIES= mail python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= seschwar@gmail.com
+COMMENT= Initial tagging script for notmuch mail
+
+LICENSE= ISCL
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet \
+ ${PYTHON_PKGNAMEPREFIX}notmuch>=0:mail/py-notmuch \
+ notmuch:mail/notmuch
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT= MANPAGES
+
+MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx
+MANPAGES_PLIST_FILES= man/man1/afew.1.gz
+
+NO_ARCH= yes
+
+post-build-MANPAGES-on:
+ ${MAKE} -C ${WRKSRC}/docs man
+
+post-install-MANPAGES-on:
+ ${INSTALL_MAN} ${WRKSRC}/docs/build/man/afew.1 ${STAGEDIR}${PREFIX}/man/man1/
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}subprocess32>=0:devel/py-subprocess32
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/py-afew/distinfo b/mail/py-afew/distinfo
new file mode 100644
index 000000000000..9a68b30a4769
--- /dev/null
+++ b/mail/py-afew/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505037424
+SHA256 (afew-1.2.0.tar.gz) = b94cef31f2c740ffa3100dcbb7839d015973a49cdeadde295dd1f751da3a3c88
+SIZE (afew-1.2.0.tar.gz) = 31831
diff --git a/mail/py-afew/pkg-descr b/mail/py-afew/pkg-descr
new file mode 100644
index 000000000000..57f0de8d86a8
--- /dev/null
+++ b/mail/py-afew/pkg-descr
@@ -0,0 +1,14 @@
+This is an initial tagging script for notmuch mail.
+
+Its basic task is to provide automatic tagging each time new
+mail is registered with notmuch. In a classic setup, you might
+call it after 'notmuch new' in an offlineimap post sync hook.
+
+It can do basic thing such as adding tags based on email headers
+or maildir folders, handling killed threads and spam.
+
+In move mode, afew will move mails between maildir folders
+according to configurable rules that can contain arbitrary
+notmuch queries to match against any searchable attributes.
+
+WWW: https://github.com/afewmail/afew