aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2017-04-22 00:23:17 +0800
committermiwi <miwi@FreeBSD.org>2017-04-22 00:23:17 +0800
commit35e4e88f5c02951cdc418913eabed0f203ea9e61 (patch)
tree0a5a0f1163fc5b8411637cd86a5d1c54f84ae261
parent3357d5aa906f5ee11f401ffdf8ec01015d7e28c9 (diff)
downloadfreebsd-ports-gnome-35e4e88f5c02951cdc418913eabed0f203ea9e61.tar.gz
freebsd-ports-gnome-35e4e88f5c02951cdc418913eabed0f203ea9e61.tar.zst
freebsd-ports-gnome-35e4e88f5c02951cdc418913eabed0f203ea9e61.zip
- Fix shebangs
-rw-r--r--benchmarks/phoronix-test-suite/Makefile19
-rw-r--r--deskutils/gnome-tweak-tool/Makefile5
-rw-r--r--devel/py-Products.PlacelessTranslationService/Makefile5
-rw-r--r--devel/py-notifier/Makefile4
-rw-r--r--devel/py-rq/Makefile4
-rw-r--r--irc/py-fishcrypt/Makefile4
-rw-r--r--net-im/telepathy-butterfly/Makefile6
-rw-r--r--net-im/telepathy-butterfly/files/patch-telepathy-butterfly9
-rw-r--r--sysutils/py-ranger/Makefile3
-rw-r--r--www/pyblosxom/Makefile4
10 files changed, 40 insertions, 23 deletions
diff --git a/benchmarks/phoronix-test-suite/Makefile b/benchmarks/phoronix-test-suite/Makefile
index 042fd8f44276..14375afc2902 100644
--- a/benchmarks/phoronix-test-suite/Makefile
+++ b/benchmarks/phoronix-test-suite/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phoronix-test-suite
PORTVERSION= 6.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks
MASTER_SITES= http://www.phoronix-test-suite.com/releases/
@@ -13,12 +13,23 @@ COMMENT= Phoronix Benchmarking Suite
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= php:cli,build
+USES= php:cli,build python shebangfix
USE_GCC= any
-USE_PHP= ctype curl dom filter gd hash json openssl pcntl posix session \
- simplexml sockets sqlite3 zip zlib
+USE_PHP= ctype curl dom filter gd hash json openssl pcntl posix \
+ session simplexml sockets sqlite3 zip zlib
NO_BUILD= yes
WRKSRC= ${WRKDIR}/phoronix-test-suite
+SHEBANG_FILES= deploy/juju/trusty/pts/hooks/start \
+ deploy/juju/trusty/pts/hooks/upgrade-charm \
+ deploy/juju/trusty/pts/hooks/stop \
+ deploy/juju/trusty/pts/hooks/phoronix-common \
+ deploy/juju/trusty/pts/hooks/install \
+ deploy/juju/trusty/pts/hooks/config-changed \
+ deploy/juju/trusty/pts/actions/memory \
+ deploy/juju/trusty/pts/actions/benchmark \
+ deploy/juju/trusty/pts/actions/custom \
+ deploy/juju/trusty/pts/actions/smoke \
+ deploy/juju/trusty/pts/scripts/parse
RUN_DEPENDS+= fpdf>0:print/fpdf
RUN_DEPENDS+= cmake:devel/cmake
diff --git a/deskutils/gnome-tweak-tool/Makefile b/deskutils/gnome-tweak-tool/Makefile
index 0b574689e6ab..16fcd39181d7 100644
--- a/deskutils/gnome-tweak-tool/Makefile
+++ b/deskutils/gnome-tweak-tool/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnome-tweak-tool
PORTVERSION= 3.18.1
+PORTREVISION= 1
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
@@ -14,11 +15,13 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome pathfix pkgconfig python:2 tar:xz
+USES= gettext gmake gnome pathfix pkgconfig python:2 \
+ shebangfix tar:xz
USE_GNOME= gtk30 pygobject3 intlhack
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+SHEBANG_FILES= gnome-tweak-tool
.include <bsd.port.mk>
diff --git a/devel/py-Products.PlacelessTranslationService/Makefile b/devel/py-Products.PlacelessTranslationService/Makefile
index cac8992b5712..93ea30c2d6ee 100644
--- a/devel/py-Products.PlacelessTranslationService/Makefile
+++ b/devel/py-Products.PlacelessTranslationService/Makefile
@@ -2,7 +2,7 @@
PORTNAME= Products.PlacelessTranslationService
PORTVERSION= 2.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python zope
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -26,7 +26,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-gettext>0:textproc/py-python-gettext
${PYTHON_PKGNAMEPREFIX}ExtensionClass>=0:devel/py-ExtensionClass \
zodb${PYTHON_PKGNAMESUFFIX}>=0:databases/zodb3
-USES= python zip
+USES= python shebangfix zip
USE_PYTHON= autoplist distutils
+SHEBANG_FILES= Products/PlacelessTranslationService/bin/convertToLocales.py
.include <bsd.port.mk>
diff --git a/devel/py-notifier/Makefile b/devel/py-notifier/Makefile
index 9fa674533243..5c17a299e519 100644
--- a/devel/py-notifier/Makefile
+++ b/devel/py-notifier/Makefile
@@ -3,6 +3,7 @@
PORTNAME= notifier
PORTVERSION= 0.5.8
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.bitkipper.net/bytes/pynotifier/source/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,8 @@ COMMENT= Generic notifier/event scheduler abstraction
LICENSE= LGPL20
-USES= python
+USES= python shebangfix
+SHEBANG_FILES= examples/*.py
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= pynotifier
diff --git a/devel/py-rq/Makefile b/devel/py-rq/Makefile
index 6bc663125fe5..1b7f1ed9005a 100644
--- a/devel/py-rq/Makefile
+++ b/devel/py-rq/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rq
PORTVERSION= 0.5.6
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +16,8 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}redis>=2.7:databases/py-redis \
${PYTHON_PKGNAMEPREFIX}click>=4.1:devel/py-click
-USES= python
+USES= python shebangfix
USE_PYTHON= autoplist distutils
+SHEBANG_FILES= rq/scripts/rqgenload.py
.include <bsd.port.mk>
diff --git a/irc/py-fishcrypt/Makefile b/irc/py-fishcrypt/Makefile
index 692d4806d92d..5fe24000b4aa 100644
--- a/irc/py-fishcrypt/Makefile
+++ b/irc/py-fishcrypt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fishcrypt
DISTVERSION= 5.31
+PORTREVISION= 1
CATEGORIES= irc security
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DIST_SUBDIR= python
@@ -18,7 +19,8 @@ GH_ACCOUNT= fladd
GH_PROJECT= py-${PORTNAME}
GH_TAGNAME= 43554b1a
-USES= dos2unix python:run
+USES= dos2unix python:run shebangfix
+SHEBANG_FILES= fishcrypt.py
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/net-im/telepathy-butterfly/Makefile b/net-im/telepathy-butterfly/Makefile
index 3b422663152f..3e494aff32d2 100644
--- a/net-im/telepathy-butterfly/Makefile
+++ b/net-im/telepathy-butterfly/Makefile
@@ -3,7 +3,7 @@
PORTNAME= telepathy-butterfly
PORTVERSION= 0.5.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,6 +18,8 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/papyon/__init__.py:net-im/papyon \
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${PREFIX}
-USES= gmake python:2
+USES= gmake python:2 shebangfix
+SHEBANG_FILES= telepathy-butterfly
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/net-im/telepathy-butterfly/files/patch-telepathy-butterfly b/net-im/telepathy-butterfly/files/patch-telepathy-butterfly
deleted file mode 100644
index aac134b87fcd..000000000000
--- a/net-im/telepathy-butterfly/files/patch-telepathy-butterfly
+++ /dev/null
@@ -1,9 +0,0 @@
---- telepathy-butterfly.orig 2008-03-30 10:35:08.000000000 -0400
-+++ telepathy-butterfly 2008-03-30 10:35:17.000000000 -0400
-@@ -1,4 +1,4 @@
--#!/usr/bin/python
-+#!/usr/bin/env python
- #
- # telepathy-butterfly - an MSN connection manager for Telepathy
-
-
diff --git a/sysutils/py-ranger/Makefile b/sysutils/py-ranger/Makefile
index 931b260dc404..8b1502d93476 100644
--- a/sysutils/py-ranger/Makefile
+++ b/sysutils/py-ranger/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ranger
PORTVERSION= 1.8.1
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= http://ranger.nongnu.org/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ COMMENT= Ranger is a file manager with VI key bindings
LICENSE= GPLv3
USES= python shebangfix
-SHEBANG_FILES= doc/tools/convert_papermode_to_metadata.py
+SHEBANG_FILES= doc/tools/*.py
python_OLD_CMD= /bin/python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/www/pyblosxom/Makefile b/www/pyblosxom/Makefile
index 499108d8ad3a..80f2a44f85a1 100644
--- a/www/pyblosxom/Makefile
+++ b/www/pyblosxom/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pyblosxom
DISTVERSION= 1.5.3
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= http://pyblosxom.github.io/download/
@@ -11,8 +12,9 @@ COMMENT= Lightweight weblog system
LICENSE= MIT
-USES= python:2
+USES= python:2 shebangfix
USE_PYTHON= distutils
+SHEBANG_FILES= Pyblosxom/data/pyblosxom.cgi
OPTIONS_DEFINE= DOCS