aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2019-07-08 22:22:51 +0800
committermat <mat@FreeBSD.org>2019-07-08 22:22:51 +0800
commit631ebebd272c5baa754b1436fef3692d97e734a1 (patch)
treea3ca892f280655ef0a6673fc3383353b2aa445fb
parentb6db133c8ee8827fcc02aa9bd28d99936ba2270f (diff)
downloadfreebsd-ports-gnome-631ebebd272c5baa754b1436fef3692d97e734a1.tar.gz
freebsd-ports-gnome-631ebebd272c5baa754b1436fef3692d97e734a1.tar.zst
freebsd-ports-gnome-631ebebd272c5baa754b1436fef3692d97e734a1.zip
Update to latest commit.
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-configure8
4 files changed, 16 insertions, 16 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 3bc0614412c2..5647758f9689 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -41,13 +41,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.15.0a0.2019.06.28
+ISCVERSION= 9.15.0a0.2019.07.04
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= 4c0e9d0bdff6b663c3119ba237c71bc642bf72c8
+GL_COMMIT= 2f9ae942965a5fe99b6e258dc577ff3424ff500e
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 3b5b9508972e..8914adffd9db 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1561996676
-SHA256 (isc-projects-bind9-4c0e9d0bdff6b663c3119ba237c71bc642bf72c8_GL0.tar.gz) = 7e8dcc7ab874b4b20389f5d3162d491cddb8a88a6cc7008803e28bba575ea923
-SIZE (isc-projects-bind9-4c0e9d0bdff6b663c3119ba237c71bc642bf72c8_GL0.tar.gz) = 6348609
+TIMESTAMP = 1562593026
+SHA256 (isc-projects-bind9-2f9ae942965a5fe99b6e258dc577ff3424ff500e_GL0.tar.gz) = 17366d78a7a2f38c8a5d9c3fba7b7791c3c74a1eafd751b3c378b270747413de
+SIZE (isc-projects-bind9-2f9ae942965a5fe99b6e258dc577ff3424ff500e_GL0.tar.gz) = 6332040
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 19139f502104..4c420ccf7070 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2019-06-25 10:23:15 UTC
+--- bin/named/config.c.orig 2019-07-04 16:38:26 UTC
+++ bin/named/config.c
-@@ -172,6 +172,7 @@ options {\n\
+@@ -177,6 +177,7 @@ options {\n\
notify-source *;\n\
notify-source-v6 *;\n\
nsec3-test-zone no;\n\
@@ -8,7 +8,7 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2019-06-25 10:23:15 UTC
+--- bin/named/server.c.orig 2019-07-04 16:38:26 UTC
+++ bin/named/server.c
@@ -4225,6 +4225,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -22,7 +22,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2019-06-25 10:23:15 UTC
+--- lib/dns/include/dns/view.h.orig 2019-07-04 16:38:26 UTC
+++ lib/dns/include/dns/view.h
@@ -152,6 +152,7 @@ struct dns_view {
bool requestnsid;
@@ -32,7 +32,7 @@
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2019-06-25 10:23:15 UTC
+--- lib/dns/resolver.c.orig 2019-07-04 16:38:26 UTC
+++ lib/dns/resolver.c
@@ -6048,6 +6048,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
}
@@ -47,9 +47,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2019-06-25 10:23:15 UTC
+--- lib/isccfg/namedconf.c.orig 2019-07-04 16:38:26 UTC
+++ lib/isccfg/namedconf.c
-@@ -1910,6 +1910,7 @@ view_clauses[] = {
+@@ -1911,6 +1911,7 @@ view_clauses[] = {
#endif
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 218a7274304c..e27c8c46c635 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2019-06-28 12:33:29 UTC
+--- configure.orig 2019-07-04 16:38:26 UTC
+++ configure
-@@ -17446,27 +17446,9 @@ done
+@@ -17204,27 +17204,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -17509,47 +17491,7 @@ $as_echo "no" >&6; } ;;
+@@ -17267,47 +17249,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22772,7 +22714,7 @@ $as_echo "" >&6; }
+@@ -22530,7 +22472,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).