aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2009-06-21 03:06:24 +0800
committerbeat <beat@FreeBSD.org>2009-06-21 03:06:24 +0800
commit7aa1735619a5567869b66c0eced3f4288daab9cc (patch)
tree0c01bd5f69b90440e9ab1d3aff6ef0693a97a719
parentd00101d289cc14ced11fc10622fefc493f127195 (diff)
downloadfreebsd-ports-gnome-7aa1735619a5567869b66c0eced3f4288daab9cc.tar.gz
freebsd-ports-gnome-7aa1735619a5567869b66c0eced3f4288daab9cc.tar.zst
freebsd-ports-gnome-7aa1735619a5567869b66c0eced3f4288daab9cc.zip
POD::Abstract provides a means to load a POD (or POD compatible)
document without direct reference to it's syntax, and perform manipulations on the abstract syntax tree. This can be used to support additional features for POD, to format output, to compile into alternative formats, etc. While Pod looks like a simple format, the specification calls for a number of special cases to be handled, and that makes any software that works on Pod as text more complex than it needs to be. In addition to this, Pod does not lend itself to a natural structured model. This makes it difficult to manipulate without damaging the validity of the document. Pod::Abstract solves these problems by loading the document into a structured tree, and providing consistent traversal, searching, manpulation and re-serialisation. Pod related utilities are easy to write using Pod::Abstract. WWW: http://search.cpan.org/dist/Pod-Abstract/ PR: ports/135181 Submitted by: Cezary Morga <cm AT therek.net>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Pod-Abstract/Makefile42
-rw-r--r--textproc/p5-Pod-Abstract/distinfo3
-rw-r--r--textproc/p5-Pod-Abstract/pkg-descr20
-rw-r--r--textproc/p5-Pod-Abstract/pkg-plist25
5 files changed, 91 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6681ffb6d7c3..5778f703e891 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -526,6 +526,7 @@
SUBDIR += p5-Plucene-Analysis-CJKAnalyzer
SUBDIR += p5-Plucene-Plugin-Analyzer-SnowballAnalyzer
SUBDIR += p5-Plucene-Simple
+ SUBDIR += p5-Pod-Abstract
SUBDIR += p5-Pod-Constants
SUBDIR += p5-Pod-DocBook
SUBDIR += p5-Pod-Escapes
diff --git a/textproc/p5-Pod-Abstract/Makefile b/textproc/p5-Pod-Abstract/Makefile
new file mode 100644
index 000000000000..f263a6b93ac9
--- /dev/null
+++ b/textproc/p5-Pod-Abstract/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Pod-Abstract
+# Date created: June 2nd 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Abstract
+PORTVERSION= 0.16
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Abstract document tree for Perl POD documents
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= paf.1
+MAN3= Pod::Abstract.3 \
+ Pod::Abstract::BuildNode.3 \
+ Pod::Abstract::Filter.3 \
+ Pod::Abstract::Filter::add_podcmds.3 \
+ Pod::Abstract::Filter::clear_podcmds.3 \
+ Pod::Abstract::Filter::cut.3 \
+ Pod::Abstract::Filter::find.3 \
+ Pod::Abstract::Filter::number_sections.3 \
+ Pod::Abstract::Filter::overlay.3 \
+ Pod::Abstract::Filter::sort.3 \
+ Pod::Abstract::Filter::summary.3 \
+ Pod::Abstract::Filter::uncut.3 \
+ Pod::Abstract::Filter::unoverlay.3 \
+ Pod::Abstract::Node.3 \
+ Pod::Abstract::Parser.3 \
+ Pod::Abstract::Path.3 \
+ Pod::Abstract::Serial.3 \
+ Pod::Abstract::Tree.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Abstract/distinfo b/textproc/p5-Pod-Abstract/distinfo
new file mode 100644
index 000000000000..f2b612e19e27
--- /dev/null
+++ b/textproc/p5-Pod-Abstract/distinfo
@@ -0,0 +1,3 @@
+MD5 (Pod-Abstract-0.16.tar.gz) = 023d5fd27a24342ef4839f37d6e7188b
+SHA256 (Pod-Abstract-0.16.tar.gz) = cac5bcde643df0edd07b9e3edc9fbef85db0bb4bba9b9b8ae6491e43704f9629
+SIZE (Pod-Abstract-0.16.tar.gz) = 24102
diff --git a/textproc/p5-Pod-Abstract/pkg-descr b/textproc/p5-Pod-Abstract/pkg-descr
new file mode 100644
index 000000000000..7d53a018996e
--- /dev/null
+++ b/textproc/p5-Pod-Abstract/pkg-descr
@@ -0,0 +1,20 @@
+POD::Abstract provides a means to load a POD (or POD compatible)
+document without direct reference to it's syntax, and perform
+manipulations on the abstract syntax tree.
+
+This can be used to support additional features for POD, to format
+output, to compile into alternative formats, etc.
+
+While Pod looks like a simple format, the specification calls for
+a number of special cases to be handled, and that makes any software
+that works on Pod as text more complex than it needs to be. In
+addition to this, Pod does not lend itself to a natural structured
+model. This makes it difficult to manipulate without damaging the
+validity of the document.
+
+Pod::Abstract solves these problems by loading the document into a
+structured tree, and providing consistent traversal, searching,
+manpulation and re-serialisation. Pod related utilities are easy
+to write using Pod::Abstract.
+
+WWW: http://search.cpan.org/dist/Pod-Abstract/
diff --git a/textproc/p5-Pod-Abstract/pkg-plist b/textproc/p5-Pod-Abstract/pkg-plist
new file mode 100644
index 000000000000..2b7129690a64
--- /dev/null
+++ b/textproc/p5-Pod-Abstract/pkg-plist
@@ -0,0 +1,25 @@
+bin/paf
+%%SITE_PERL%%/Pod/Abstract.pm
+%%SITE_PERL%%/Pod/Abstract/BuildNode.pm
+%%SITE_PERL%%/Pod/Abstract/Filter.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/add_podcmds.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/clear_podcmds.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/cut.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/find.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/number_sections.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/overlay.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/sort.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/summary.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/uncut.pm
+%%SITE_PERL%%/Pod/Abstract/Filter/unoverlay.pm
+%%SITE_PERL%%/Pod/Abstract/Node.pm
+%%SITE_PERL%%/Pod/Abstract/Parser.pm
+%%SITE_PERL%%/Pod/Abstract/Path.pm
+%%SITE_PERL%%/Pod/Abstract/Serial.pm
+%%SITE_PERL%%/Pod/Abstract/Tree.pm
+%%SITE_PERL%%/mach/auto/Pod/Abstract/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Pod/Abstract
+@dirrmtry %%SITE_PERL%%/mach/auto/Pod
+@dirrmtry %%SITE_PERL%%/Pod/Abstract/Filter
+@dirrmtry %%SITE_PERL%%/Pod/Abstract
+@dirrmtry %%SITE_PERL%%/Pod