aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2015-02-13 04:48:26 +0800
committersbruno <sbruno@FreeBSD.org>2015-02-13 04:48:26 +0800
commit7ec0c68a62be7d86a79b28dd5a5fa08246032e8b (patch)
tree0a36051517ace60d727d8d53f19b2fb58d90112f
parent1e1604d929fc2d77ccb26d95f826a99af9e4da23 (diff)
downloadfreebsd-ports-gnome-7ec0c68a62be7d86a79b28dd5a5fa08246032e8b.tar.gz
freebsd-ports-gnome-7ec0c68a62be7d86a79b28dd5a5fa08246032e8b.tar.zst
freebsd-ports-gnome-7ec0c68a62be7d86a79b28dd5a5fa08246032e8b.zip
This patch makes the port respect CFLAGS, CPPFLAGS, LDFLAGS and LIBS. Fixes builds with
external toolchains (qemu enabled poudriere jails). PR: 196968 Submitted by: tijl Approved by: maintainer timeout
-rw-r--r--deskutils/akamaru/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/deskutils/akamaru/Makefile b/deskutils/akamaru/Makefile
index beefe51e3618..81915e62045e 100644
--- a/deskutils/akamaru/Makefile
+++ b/deskutils/akamaru/Makefile
@@ -3,7 +3,7 @@
PORTNAME= akamaru
PORTVERSION= 0.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= deskutils gnome
MASTER_SITES= http://people.freedesktop.org/~krh/
DISTNAME= ${PORTNAME}
@@ -19,6 +19,12 @@ GCONF_SCHEMAS= kiba.schemas
SUB_FILES= pkg-message
post-patch:
+ @${REINPLACE_CMD} \
+ -e '/^CFLAGS =/s|-g| ${CFLAGS} |' \
+ -e '/^CPPFLAGS =/s|$$| ${CPPFLAGS}|' \
+ -e '/^LDFLAGS =/s|-g| ${LDFLAGS} |' \
+ -e '/^LDLIBS =/s|$$| ${LIBS} -lm|' \
+ ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
${WRKSRC}/populate-dock.sh