aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-22 17:37:56 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-22 17:37:56 +0800
commit93da91a57fd1e8a1dc83875d6f56c159100b8d81 (patch)
treebfebc9f8335c899916a614750193aaf91b9146fa
parent872e8ab6b8417cf8d69f2838858957a773610e9d (diff)
downloadfreebsd-ports-gnome-93da91a57fd1e8a1dc83875d6f56c159100b8d81.tar.gz
freebsd-ports-gnome-93da91a57fd1e8a1dc83875d6f56c159100b8d81.tar.zst
freebsd-ports-gnome-93da91a57fd1e8a1dc83875d6f56c159100b8d81.zip
Add metacity 2.3.377, a window manager for the adult in you. Metacity is going
to replace Sawfish in GNOME2 desktop. PR: 38397 Submitted by: Garrett Rooney <rooneg@electricjellyfish.net>
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/metacity/Makefile37
-rw-r--r--x11-wm/metacity/distinfo1
-rw-r--r--x11-wm/metacity/files/patch-configure13
-rw-r--r--x11-wm/metacity/pkg-comment1
-rw-r--r--x11-wm/metacity/pkg-descr3
-rw-r--r--x11-wm/metacity/pkg-plist114
7 files changed, 170 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index a5c92da2ba62..f8e63c7c6852 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -51,6 +51,7 @@
SUBDIR += libdockapp
SUBDIR += libepplet
SUBDIR += lwm
+ SUBDIR += metacity
SUBDIR += mlvwm
SUBDIR += mosfet-liquid
SUBDIR += olvwm
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
new file mode 100644
index 000000000000..2a5d6718ea11
--- /dev/null
+++ b/x11-wm/metacity/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: metacity
+# Date created: 21 May 2002
+# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= metacity
+PORTVERSION= 2.3.377
+CATEGORIES= x11-wm
+MASTER_SITES= http://people.redhat.com/~hp/metacity/
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ gconf-2:${PORTSDIR}/devel/gconf2
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --disable-gtk-doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/x11-wm/metacity/distinfo b/x11-wm/metacity/distinfo
new file mode 100644
index 000000000000..03587648f483
--- /dev/null
+++ b/x11-wm/metacity/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/metacity-2.3.377.tar.gz) = f9efb975f8f0f4b40c88931f3fe5940a
diff --git a/x11-wm/metacity/files/patch-configure b/x11-wm/metacity/files/patch-configure
new file mode 100644
index 000000000000..bbd8c0a87560
--- /dev/null
+++ b/x11-wm/metacity/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/05/22 09:20:39 1.1
++++ configure 2002/05/22 09:20:59
+@@ -6411,6 +6411,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-wm/metacity/pkg-comment b/x11-wm/metacity/pkg-comment
new file mode 100644
index 000000000000..2b1334579866
--- /dev/null
+++ b/x11-wm/metacity/pkg-comment
@@ -0,0 +1 @@
+A window manager for the adult in you
diff --git a/x11-wm/metacity/pkg-descr b/x11-wm/metacity/pkg-descr
new file mode 100644
index 000000000000..c81b83d98a80
--- /dev/null
+++ b/x11-wm/metacity/pkg-descr
@@ -0,0 +1,3 @@
+A window manager for the adult in you.
+
+WWW: http://people.redhat.com/~hp/metacity/
diff --git a/x11-wm/metacity/pkg-plist b/x11-wm/metacity/pkg-plist
new file mode 100644
index 000000000000..d248e446e187
--- /dev/null
+++ b/x11-wm/metacity/pkg-plist
@@ -0,0 +1,114 @@
+bin/metacity
+bin/metacity-message
+bin/metacity-theme-viewer
+bin/metacity-window-demo
+etc/gconf/gconf.xml.defaults/apps/metacity/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/metacity/general/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/metacity/global_keybindings/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/metacity/window_keybindings/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/metacity/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/metacity/general/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/metacity/global_keybindings/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/metacity/window_keybindings/%gconf.xml
+etc/gconf/schemas/metacity.schemas
+libexec/metacity-dialog
+share/gnome/metacity/icons/metacity-window-demo.png
+share/gnome/metacity/themes/Atlanta/metacity-theme-1.xml
+share/gnome/metacity/themes/Bright/metacity-theme-1.xml
+share/gnome/metacity/themes/Crux/active-bottom-left-border.png
+share/gnome/metacity/themes/Crux/active-bottom-left-corner.png
+share/gnome/metacity/themes/Crux/active-bottom-mid-left-border.png
+share/gnome/metacity/themes/Crux/active-bottom-mid-right-border.png
+share/gnome/metacity/themes/Crux/active-bottom-right-border.png
+share/gnome/metacity/themes/Crux/active-bottom-right-corner.png
+share/gnome/metacity/themes/Crux/active-button-prelight.png
+share/gnome/metacity/themes/Crux/active-button-pressed.png
+share/gnome/metacity/themes/Crux/active-button.png
+share/gnome/metacity/themes/Crux/active-close-button.png
+share/gnome/metacity/themes/Crux/active-left-border.png
+share/gnome/metacity/themes/Crux/active-left-top-border-shaded.png
+share/gnome/metacity/themes/Crux/active-left-top-border.png
+share/gnome/metacity/themes/Crux/active-maximize-button.png
+share/gnome/metacity/themes/Crux/active-menu-button-prelight.png
+share/gnome/metacity/themes/Crux/active-menu-button-pressed.png
+share/gnome/metacity/themes/Crux/active-menu-button.png
+share/gnome/metacity/themes/Crux/active-minimize-button.png
+share/gnome/metacity/themes/Crux/active-right-border.png
+share/gnome/metacity/themes/Crux/active-right-top-border-shaded.png
+share/gnome/metacity/themes/Crux/active-right-top-border.png
+share/gnome/metacity/themes/Crux/active-top-center-left.png
+share/gnome/metacity/themes/Crux/active-top-center-mid-left.png
+share/gnome/metacity/themes/Crux/active-top-center-mid-right.png
+share/gnome/metacity/themes/Crux/active-top-center-right.png
+share/gnome/metacity/themes/Crux/active-top-left-border.png
+share/gnome/metacity/themes/Crux/active-top-right-border.png
+share/gnome/metacity/themes/Crux/inactive-bottom-left-border.png
+share/gnome/metacity/themes/Crux/inactive-bottom-left-corner.png
+share/gnome/metacity/themes/Crux/inactive-bottom-mid-border.png
+share/gnome/metacity/themes/Crux/inactive-bottom-right-border.png
+share/gnome/metacity/themes/Crux/inactive-bottom-right-corner.png
+share/gnome/metacity/themes/Crux/inactive-button-prelight.png
+share/gnome/metacity/themes/Crux/inactive-button-pressed.png
+share/gnome/metacity/themes/Crux/inactive-button.png
+share/gnome/metacity/themes/Crux/inactive-close-button.png
+share/gnome/metacity/themes/Crux/inactive-left-border.png
+share/gnome/metacity/themes/Crux/inactive-left-top-border-shaded.png
+share/gnome/metacity/themes/Crux/inactive-left-top-border.png
+share/gnome/metacity/themes/Crux/inactive-maximize-button.png
+share/gnome/metacity/themes/Crux/inactive-menu-button-prelight.png
+share/gnome/metacity/themes/Crux/inactive-menu-button-pressed.png
+share/gnome/metacity/themes/Crux/inactive-menu-button.png
+share/gnome/metacity/themes/Crux/inactive-minimize-button.png
+share/gnome/metacity/themes/Crux/inactive-right-border.png
+share/gnome/metacity/themes/Crux/inactive-right-top-border-shaded.png
+share/gnome/metacity/themes/Crux/inactive-right-top-border.png
+share/gnome/metacity/themes/Crux/inactive-top-center-left.png
+share/gnome/metacity/themes/Crux/inactive-top-center-mid.png
+share/gnome/metacity/themes/Crux/inactive-top-center-right.png
+share/gnome/metacity/themes/Crux/inactive-top-left-border.png
+share/gnome/metacity/themes/Crux/inactive-top-right-border.png
+share/gnome/metacity/themes/Crux/metacity-theme-1.xml
+share/gnome/metacity/themes/Esco/metacity-theme-1.xml
+share/gnome/metacity/themes/Gorilla/active-button.png
+share/gnome/metacity/themes/Gorilla/active-close-button.png
+share/gnome/metacity/themes/Gorilla/active-maximize-button.png
+share/gnome/metacity/themes/Gorilla/active-menu-button.png
+share/gnome/metacity/themes/Gorilla/active-minimize-button.png
+share/gnome/metacity/themes/Gorilla/inactive-close-button.png
+share/gnome/metacity/themes/Gorilla/inactive-maximize-button.png
+share/gnome/metacity/themes/Gorilla/inactive-menu-button.png
+share/gnome/metacity/themes/Gorilla/inactive-minimize-button.png
+share/gnome/metacity/themes/Gorilla/metacity-theme-1.xml
+share/gnome/wm-properties/metacity.desktop
+share/locale/da/LC_MESSAGES/metacity.mo
+share/locale/es/LC_MESSAGES/metacity.mo
+share/locale/gl/LC_MESSAGES/metacity.mo
+share/locale/ja/LC_MESSAGES/metacity.mo
+share/locale/ko/LC_MESSAGES/metacity.mo
+share/locale/lv/LC_MESSAGES/metacity.mo
+share/locale/ms/LC_MESSAGES/metacity.mo
+share/locale/no/LC_MESSAGES/metacity.mo
+share/locale/pl/LC_MESSAGES/metacity.mo
+share/locale/pt/LC_MESSAGES/metacity.mo
+share/locale/ru/LC_MESSAGES/metacity.mo
+share/locale/sk/LC_MESSAGES/metacity.mo
+share/locale/sv/LC_MESSAGES/metacity.mo
+share/locale/tr/LC_MESSAGES/metacity.mo
+share/locale/uk/LC_MESSAGES/metacity.mo
+@dirrm share/gnome/wm-properties
+@dirrm share/gnome/metacity/themes/Gorilla
+@dirrm share/gnome/metacity/themes/Esco
+@dirrm share/gnome/metacity/themes/Crux
+@dirrm share/gnome/metacity/themes/Bright
+@dirrm share/gnome/metacity/themes/Atlanta
+@dirrm share/gnome/metacity/themes
+@dirrm share/gnome/metacity/icons
+@dirrm share/gnome/metacity
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/metacity/window_keybindings
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/metacity/global_keybindings
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/metacity/general
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/metacity
+@dirrm etc/gconf/gconf.xml.defaults/apps/metacity/window_keybindings
+@dirrm etc/gconf/gconf.xml.defaults/apps/metacity/global_keybindings
+@dirrm etc/gconf/gconf.xml.defaults/apps/metacity/general
+@dirrm etc/gconf/gconf.xml.defaults/apps/metacity