aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-08 07:40:23 +0800
committermarino <marino@FreeBSD.org>2013-10-08 07:40:23 +0800
commita2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5 (patch)
treee61a78f0169c5b6d3db742a3a79532ae3afa9fab
parent75f2f17686803372411d7a488c3afc47442146cf (diff)
downloadfreebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.tar.gz
freebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.tar.zst
freebsd-ports-gnome-a2dc285c0ea59d2c14a2d9ea6899ed7a210ba5d5.zip
Explicitly link libraries on 10 unmaintained ports
The following ports will not build with a binutils 2.22+ linker built with standard options. This has been obvious with DPorts, but difficult to see on FreeBSD. However, setting the ports compiler as a recent gcc (e.g lang/gcc48) is an excellent way to detect the unspecified but needed libraries as these recent GCC compilers use the latest binutils linkers. These patches were tested on FreeBSD 8.4 and DragonFly 3.5
-rw-r--r--games/stepmania-devel/Makefile2
-rw-r--r--games/xteddy/Makefile2
-rw-r--r--graphics/fv/Makefile2
-rw-r--r--graphics/kludge3d/Makefile2
-rw-r--r--graphics/pornview/Makefile2
-rw-r--r--japanese/kanjipad/Makefile1
-rw-r--r--lang/lafontaine/Makefile1
-rw-r--r--science/gdis/Makefile1
-rw-r--r--shells/viewglob/Makefile1
-rw-r--r--sysutils/ldapenter/Makefile1
10 files changed, 10 insertions, 5 deletions
diff --git a/games/stepmania-devel/Makefile b/games/stepmania-devel/Makefile
index d0a78bb029fd..1eecb806b29d 100644
--- a/games/stepmania-devel/Makefile
+++ b/games/stepmania-devel/Makefile
@@ -38,7 +38,7 @@ SHEBANG_FILES= Utils/*.pl \
extern/zlib/zlib2ansi
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lX11 -lpthread
NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/games/xteddy/Makefile b/games/xteddy/Makefile
index 5f29af21e9ee..0b311676c606 100644
--- a/games/xteddy/Makefile
+++ b/games/xteddy/Makefile
@@ -16,7 +16,7 @@ USE_EFL= imlib2
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib lXext
MAN6= xteddy.6
PLIST_FILES= bin/xteddy bin/xteddy_test bin/xtoys \
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index dd31405bc6f6..eb85bec57c14 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -24,7 +24,7 @@ ALL_TARGET= ${PORTNAME}
CXXFLAGS+= $$(pkg-config --cflags libpng15) \
-I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= $$(pkg-config --libs libpng15) \
- -L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm ${PTHREAD_LIBS}
+ -L${LOCALBASE}/lib -lglut -lGLU -lGL -lbz2 -lm -lz ${PTHREAD_LIBS}
PORTDOCS= AUTHORS ChangeLog README
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/kludge3d/Makefile b/graphics/kludge3d/Makefile
index 3aadbd8862d5..e755bf14c91c 100644
--- a/graphics/kludge3d/Makefile
+++ b/graphics/kludge3d/Makefile
@@ -25,7 +25,7 @@ PLIST_FILES= bin/kludge3d
CPPFLAGS+= -I${LOCALBASE}/include \
-I${PYTHON_INCLUDEDIR} ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
- -L${PYTHON_LIBDIR}/config ${PTHREAD_LIBS}
+ -L${PYTHON_LIBDIR}/config -lm ${PTHREAD_LIBS}
NO_STAGE= yes
post-patch:
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index 5cfa44f521d6..9e3450d7e13d 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -21,7 +21,7 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gtk2
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lm
OPTIONS_DEFINE= LIBXINE MPLAYER NLS
OPTIONS_DEFAULT= LIBXINE
diff --git a/japanese/kanjipad/Makefile b/japanese/kanjipad/Makefile
index 616d585cc757..41fc72b006fa 100644
--- a/japanese/kanjipad/Makefile
+++ b/japanese/kanjipad/Makefile
@@ -14,6 +14,7 @@ USES= perl5 gmake pkgconfig
USE_GNOME= gtk20
MAKE_ARGS= OPTIMIZE="${CFLAGS}" PREFIX="${PREFIX}" \
GTKINC="`pkg-config --cflags gtk+-2.0`"
+LDFLAGS+= -lm
PORTDOCS= README
PLIST_FILES= bin/kanjipad bin/kpengine %%DATADIR%%/jdata.dat
diff --git a/lang/lafontaine/Makefile b/lang/lafontaine/Makefile
index c582b1eb7042..735c172e6a49 100644
--- a/lang/lafontaine/Makefile
+++ b/lang/lafontaine/Makefile
@@ -17,6 +17,7 @@ USES= pathfix gmake pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
USE_CSTD= gnu89
+LDFLAGS+= -lm
NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/science/gdis/Makefile b/science/gdis/Makefile
index 19e86b2ec517..757828f63e78 100644
--- a/science/gdis/Makefile
+++ b/science/gdis/Makefile
@@ -19,6 +19,7 @@ USE_GL= glu
USE_GNOME= gtk20
USES= gmake pkgconfig
MAKEFILE= GNUmakefile
+LDFLAGS+= -lm
PORTDOCS= CHANGELOG README TODO
PLIST_FILES= bin/gdis %%DATADIR%%/gdis.elements %%DATADIR%%/gdis.library \
diff --git a/shells/viewglob/Makefile b/shells/viewglob/Makefile
index 9b68f86ad19f..056d543061c0 100644
--- a/shells/viewglob/Makefile
+++ b/shells/viewglob/Makefile
@@ -17,6 +17,7 @@ USES= pkgconfig
USE_XORG= x11
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+LDFLAGS+= -lm
MAN1= vgd.1 vgseer.1 viewglob.1
diff --git a/sysutils/ldapenter/Makefile b/sysutils/ldapenter/Makefile
index e7b879b81911..6142bce0011b 100644
--- a/sysutils/ldapenter/Makefile
+++ b/sysutils/ldapenter/Makefile
@@ -14,6 +14,7 @@ LICENSE= BSD
MAKEFILE= BSDmakefile
USE_BZIP2= yes
USE_OPENLDAP= 24
+LDFLAGS+= -L${LOCALBASE}/lib -llber-2.4
MANCOMPRESSED= yes
MAN1= ldapform.1 ldapedit.1