aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-09-24 16:24:20 +0800
committerijliao <ijliao@FreeBSD.org>2002-09-24 16:24:20 +0800
commitab45d7b301ff07fae5006606f49a896ef7657acd (patch)
treef2108c540fade50bbe584182c9e8757b135d1dfb
parentdcd8a6d4c1137dbd8da04855857a37c9844a1553 (diff)
downloadfreebsd-ports-gnome-ab45d7b301ff07fae5006606f49a896ef7657acd.tar.gz
freebsd-ports-gnome-ab45d7b301ff07fae5006606f49a896ef7657acd.tar.zst
freebsd-ports-gnome-ab45d7b301ff07fae5006606f49a896ef7657acd.zip
re-add p5-NetAddr-IP-Find
Approved by: knu
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-NetAddr-IP-Find/Makefile25
-rw-r--r--textproc/p5-NetAddr-IP-Find/distinfo1
-rw-r--r--textproc/p5-NetAddr-IP-Find/pkg-comment1
-rw-r--r--textproc/p5-NetAddr-IP-Find/pkg-descr7
-rw-r--r--textproc/p5-NetAddr-IP-Find/pkg-plist7
6 files changed, 42 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index abc802e1db87..e809145487d1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -165,6 +165,7 @@
SUBDIR += p5-Lingua-Preferred
SUBDIR += p5-MARC
SUBDIR += p5-NetAdd-IP-Find
+ SUBDIR += p5-NetAddr-IP-Find
SUBDIR += p5-Number-Format
SUBDIR += p5-Orchard-Perl
SUBDIR += p5-PDF-API2
diff --git a/textproc/p5-NetAddr-IP-Find/Makefile b/textproc/p5-NetAddr-IP-Find/Makefile
new file mode 100644
index 000000000000..cb2d60d898e9
--- /dev/null
+++ b/textproc/p5-NetAddr-IP-Find/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-NetAddr-IP-Find
+# Date created: May 14th 2002
+# Whom: Alex Kapranoff <kappa@freebsd.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NetAddr-IP-Find
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= NetAddr
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kappa@freebsd.org.ua
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/NetAddr/IP.pm:${PORTSDIR}/net/p5-NetAddr-IP
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= NetAddr::IP::Find.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-NetAddr-IP-Find/distinfo b/textproc/p5-NetAddr-IP-Find/distinfo
new file mode 100644
index 000000000000..71dce9ee1ad7
--- /dev/null
+++ b/textproc/p5-NetAddr-IP-Find/distinfo
@@ -0,0 +1 @@
+MD5 (NetAddr-IP-Find-0.02.tar.gz) = 2ccc8f7986543eefd935961e033fdf2f
diff --git a/textproc/p5-NetAddr-IP-Find/pkg-comment b/textproc/p5-NetAddr-IP-Find/pkg-comment
new file mode 100644
index 000000000000..21962414169c
--- /dev/null
+++ b/textproc/p5-NetAddr-IP-Find/pkg-comment
@@ -0,0 +1 @@
+Iterates over all IP addresses in a text similar to Email::Find
diff --git a/textproc/p5-NetAddr-IP-Find/pkg-descr b/textproc/p5-NetAddr-IP-Find/pkg-descr
new file mode 100644
index 000000000000..59e6ef929894
--- /dev/null
+++ b/textproc/p5-NetAddr-IP-Find/pkg-descr
@@ -0,0 +1,7 @@
+This is a module for finding IP addresses in plain text.
+
+NetAddr::IP::Find exports one function, find_ipaddrs(). It
+works very similar to URI::Find's find_uris() or
+Email::Find's find_emails().
+
+$num_ipaddrs_found = find_ipaddrs($text, \&callback);
diff --git a/textproc/p5-NetAddr-IP-Find/pkg-plist b/textproc/p5-NetAddr-IP-Find/pkg-plist
new file mode 100644
index 000000000000..fde4508d2bce
--- /dev/null
+++ b/textproc/p5-NetAddr-IP-Find/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/NetAddr/IP/Find.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/NetAddr/IP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/NetAddr 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/NetAddr/IP/Find/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/NetAddr/IP/Find
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/NetAddr/IP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/NetAddr 2>/dev/null || true