summaryrefslogtreecommitdiffstats
path: root/guix
diff options
context:
space:
mode:
Diffstat (limited to 'guix')
-rw-r--r--guix/PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/guix/PKGBUILD b/guix/PKGBUILD
index 233bc31..1da6f5c 100644
--- a/guix/PKGBUILD
+++ b/guix/PKGBUILD
@@ -2,32 +2,31 @@
# Modified from guix-git 20130119 PKGBUILD
pkgname=guix
-pkgver=0.7
+pkgver=0.8
pkgrel=1
pkgdesc="GNU guix is a purely functional package manager"
arch=('x86_64' 'i686')
url="https://www.gnu.org/software/guix/"
license=('GPL')
depends=('guile>=2.0.5' 'sqlite>=3.6.19' 'bzip2' 'libgcrypt')
-makedepends=()
+optdepends=('emacs: to enable Emacs Interface')
source=(
"ftp://alpha.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz"
"guix.service")
md5sums=(
-'c9d174a27fc55889c1f1b005875120ae'
+'415f2a915db749ee28c3991032ab240a'
'4e088207919bdefff13a9d452f79467b')
build() {
current_arch="`uname -m`"
cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr --localstatedir=/var \
- --disable-rpath --with-system=${current_arch}-linux
+ ./configure --prefix=/usr --localstatedir=/var --disable-rpath
make
}
check() {
cd ${srcdir}/${pkgname}-${pkgver}
- make -k -j1 check
+ make check
}
package() {