summaryrefslogtreecommitdiffstats
path: root/mingw-w64-gtk3/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mingw-w64-gtk3/PKGBUILD')
-rw-r--r--mingw-w64-gtk3/PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/mingw-w64-gtk3/PKGBUILD b/mingw-w64-gtk3/PKGBUILD
index d630492..7f820e8 100644
--- a/mingw-w64-gtk3/PKGBUILD
+++ b/mingw-w64-gtk3/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lantw44 at gmail dot com
pkgname=mingw-w64-gtk3
-pkgver=3.12.2
+pkgver=3.14.0
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (v3) (mingw-w64)"
arch=(any)
@@ -13,29 +13,32 @@ makedepends+=(autoconf automake libtool)
# autotools are required because several Makefile.am are modified
depends=(
'mingw-w64-crt'
-'mingw-w64-atk>=2.7.5'
-'mingw-w64-pango>=1.32.4'
-'mingw-w64-glib2>=2.39.5'
+'mingw-w64-atk>=2.12.0'
+'mingw-w64-pango>=1.36.7'
+'mingw-w64-glib2>=2.41.2'
'mingw-w64-cairo>=1.12.0'
-'mingw-w64-gdk-pixbuf2>=2.27.1')
+'mingw-w64-gdk-pixbuf2>=2.30.0')
options=(!strip !buildflags staticlibs)
source=(
"http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
-"0004-BURN-THE-.DEF.patch"
+"gtk3-commit-62254c.patch"
+"0001-Bug-731013-cross-compilation-broken-when-building-ex.patch"
"0005-Remove-gobject-introspection.patch")
-# The second source file is downloaded from Fedora Project
+# The second and the third patch are downloaded from Fedora Project
-sha256sums=('61d74eea74231b1ea4b53084a9d6fc9917ab0e1d71b69d92cbf60a4b4fb385d0'
- 'b35ecacab70680391e06af85893b7aa8612f0812ded35395b6e93f49e8eab92b'
+sha256sums=('68d6b57d15c16808d0045e96b303f3dd439cc22a9c06fdffb07025cd713a82bc'
+ '1c8812f68446d509e019b3f26863348f2cfc469dbb8866bbdfa3213e55a7c433'
+ 'd2825227188cf60740540086cd71c56f8e5c6d9c9b9ad7c0869e6746ad0caebe'
'ae632ad20c87032c326dbb1cda086e33a5078909f89174b2ba232be1b48c32a3')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/gtk+-${pkgver}"
- patch -Np1 < "../0004-BURN-THE-.DEF.patch"
+ patch -Np1 -R < "../gtk3-commit-62254c.patch"
+ patch -Np1 < "../0001-Bug-731013-cross-compilation-broken-when-building-ex.patch"
patch -Np1 < "../0005-Remove-gobject-introspection.patch"
autoreconf -i
for _arch in ${_architectures}; do