pkgname=mingw-w64-gtk2 pkgver=2.24.19 pkgrel=3 pkgdesc="GTK+ is a multi-platform toolkit (v2) (mingw-w64)" arch=(any) url="http://www.gtk.org" license=("LGPL") makedepends=(mingw-w64-gcc mingw-w64-pkg-config gtk-update-icon-cache) depends=( 'mingw-w64-crt' 'mingw-w64-atk' 'mingw-w64-pango' 'mingw-w64-glib2>=2.28.0' 'mingw-w64-cairo' 'mingw-w64-gdk-pixbuf2') options=(!libtool !strip !buildflags) source=( "http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz" "gtk-dont-define-initguid.patch") # The second source file is downloaded from Fedora Project md5sums=("490236abeb0d9351b2a34e9aca70e1de" "4038939df90f80ea6923d67afff28e03") _architectures="i686-w64-mingw32 x86_64-w64-mingw32" build() { cd "${srcdir}/gtk+-${pkgver}" patch -Np0 < '../gtk-dont-define-initguid.patch' for _arch in ${_architectures}; do export CFLAGS="-O2 -mms-bitfields" export CXXFLAGS="${CFLAGS}" unset LDFLAGS mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" msg "Building for ${_arch}" msg "Copying the source directory" cp -pr "$srcdir/gtk+-$pkgver/"* "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" if [ $_arch = "x86_64-w64-mingw32" ]; then rm "gtk/gtk.def" fi msg "Starting configure and make" ./configure \ --prefix=/usr/${_arch} \ --build=$CHOST \ --host=${_arch} \ --with-gdktarget=win32 \ --disable-modules \ --disable-cups \ --disable-papi \ --enable-static \ --enable-shared \ --disable-glibtest make done } package() { for _arch in ${_architectures}; do cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" make -j1 DESTDIR="$pkgdir" install find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' -o -name '*.manifest' | xargs -rtl1 rm find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g rm -r "$pkgdir/usr/${_arch}/"{etc,share} done } tion> FreeBSD Ports (https://github.com/freebsd/freebsd-ports)
aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/rubygem-gtk2
Commit message (Expand)AuthorAgeFilesLines
* Update to 3.2.1Sunpoet Po-Chuan Hsieh2017-11-222-4/+4
* Update to 3.2.0Sunpoet Po-Chuan Hsieh2017-11-102-4/+4
* Update to 3.1.9Sunpoet Po-Chuan Hsieh2017-10-202-4/+4
* Update to 3.1.8Sunpoet Po-Chuan Hsieh2017-07-163-5/+5
* Update to 3.1.7Sunpoet Po-Chuan Hsieh2017-07-152-4/+4
* Update to 3.1.6Sunpoet Po-Chuan Hsieh2017-07-092-4/+4
* Update to 3.1.4Sunpoet Po-Chuan Hsieh2017-05-312-4/+4
* Update to 3.1.3Sunpoet Po-Chuan Hsieh2017-04-293-8/+8
* x11/rubygem-gnome2: update to 3.1.1Steve Wills2017-03-112-4/+4
* x11/rubygem-gnome2: update to 3.1.0Steve Wills2017-01-022-3/+4
* Convert USES=gem:autoplist to USES=gem since autoplist is defaultSteve Wills2016-04-281-1/+1
* create USES=gem and update rubygem- ports to use itSteve Wills2016-04-281-2/+1
* - Update to 3.0.8Sunpoet Po-Chuan Hsieh2016-04-122-4/+3
* Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.Mathieu Arnold2016-04-011-3/+3
* Remove source and intermediate build output from intalled rubygem- portsSteve Wills2016-02-022-0/+12