# Maintainer: lantw44 at gmail dot com pkgname=mingw-w64-gtk3 pkgver=3.10.0 pkgrel=2 pkgdesc="GTK+ is a multi-platform toolkit (v3) (mingw-w64)" arch=(any) url="http://www.gtk.org" license=("LGPL") makedepends=(mingw-w64-gcc mingw-w64-pkg-config gtk-update-icon-cache python2) # python2 is required to run gdbus-codegen makedepends+=(autoconf automake libtool) # autotools are required because several Makefile.am are modified depends=( 'mingw-w64-crt' 'mingw-w64-atk>=2.7.5' 'mingw-w64-pango>=1.32.4' 'mingw-w64-glib2>=2.37.5' 'mingw-w64-cairo>=1.12.0' 'mingw-w64-gdk-pixbuf2>=2.27.1') options=(!libtool !strip !buildflags) source=( "http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz" "0004-BURN-THE-.DEF.patch") # The second source file is downloaded from Fedora Project md5sums=('f5148a330886b906ba0eb7842409d93f' '369582585e60eab9fa5c9aa22a68e41c') _architectures="i686-w64-mingw32 x86_64-w64-mingw32" build() { cd "${srcdir}/gtk+-${pkgver}" patch -Np1 < "../0004-BURN-THE-.DEF.patch" autoreconf -i for _arch in ${_architectures}; do unset LDFLAGS export CFLAGS="-O2 -mms-bitfields" export CXXFLAGS="${CFLAGS}" export PKG_CONFIG="${_arch}-pkg-config" export PKG_CONFIG_FOR_BUILD="pkg-config" mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" msg "Starting configure and make" ${srcdir}/gtk+-${pkgver}/configure \ --prefix=/usr/${_arch} \ --build=$CHOST \ --host=${_arch} \ --enable-win32-backend \ --enable-gtk2-dependency \ --enable-static \ --enable-shared \ --disable-cups make done } package() { for _arch in ${_architectures}; do cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}" make -j1 DESTDIR="$pkgdir" install find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' -o -name '*.manifest' | xargs -rtl1 rm find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g rm -r "$pkgdir/usr/${_arch}/etc" rm -r "$pkgdir/usr/${_arch}/share/man" done } Q1'>2020Q1 FreeBSD Ports (https://github.com/freebsd/freebsd-ports)
aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/rubygem-gtk2
Commit message (Expand)AuthorAgeFilesLines
* Update to 3.2.1Sunpoet Po-Chuan Hsieh2017-11-222-4/+4
* Update to 3.2.0Sunpoet Po-Chuan Hsieh2017-11-102-4/+4
* Update to 3.1.9Sunpoet Po-Chuan Hsieh2017-10-202-4/+4
* Update to 3.1.8Sunpoet Po-Chuan Hsieh2017-07-163-5/+5
* Update to 3.1.7Sunpoet Po-Chuan Hsieh2017-07-152-4/+4
* Update to 3.1.6Sunpoet Po-Chuan Hsieh2017-07-092-4/+4
* Update to 3.1.4Sunpoet Po-Chuan Hsieh2017-05-312-4/+4
* Update to 3.1.3Sunpoet Po-Chuan Hsieh2017-04-293-8/+8
* x11/rubygem-gnome2: update to 3.1.1Steve Wills2017-03-112-4/+4
* x11/rubygem-gnome2: update to 3.1.0Steve Wills2017-01-022-3/+4
* Convert USES=gem:autoplist to USES=gem since autoplist is defaultSteve Wills2016-04-281-1/+1
* create USES=gem and update rubygem- ports to use itSteve Wills2016-04-281-2/+1
* - Update to 3.0.8Sunpoet Po-Chuan Hsieh2016-04-122-4/+3
* Remove ${PORTSDIR}/ from dependencies, categories v, w, x, y, and z.Mathieu Arnold2016-04-011-3/+3
* Remove source and intermediate build output from intalled rubygem- portsSteve Wills2016-02-022-0/+12
* - Update to 3.0.7Sunpoet Po-Chuan Hsieh2016-01-172-5/+4
* - Update to 2.2.5Sunpoet Po-Chuan Hsieh2015-05-042-3/+6
* x11/rubygem-gnome2: update to 2.2.3Steve Wills2014-11-122-3/+3