aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Li <git@vishwin.info>2018-12-31 04:34:20 +0800
committerCharlie Li <git@vishwin.info>2020-05-08 13:41:05 +0800
commit5b9953bc748658943a05b0971fb03d10760efaa4 (patch)
treee60506f0d25c4b97349028ea6ee48c21803b8e52
parent163c9a7557f19bbf47b86403bb94ced9d91cef3e (diff)
downloadfreebsd-ports-gnome-5b9953bc748658943a05b0971fb03d10760efaa4.tar.gz
freebsd-ports-gnome-5b9953bc748658943a05b0971fb03d10760efaa4.tar.zst
freebsd-ports-gnome-5b9953bc748658943a05b0971fb03d10760efaa4.zip
x11/xapps: pass testport and other items
Consumers need both python versions, so split the pygobject3 bits to a slave port. Adhere to our hier(7) by moving directories without touching meson. Add DOCS option
-rw-r--r--x11/xapps/Makefile60
-rw-r--r--x11/xapps/distinfo6
-rw-r--r--x11/xapps/pkg-descr7
-rw-r--r--x11/xapps/pkg-plist32
4 files changed, 80 insertions, 25 deletions
diff --git a/x11/xapps/Makefile b/x11/xapps/Makefile
index 3101ca73662a..026d932a4a2b 100644
--- a/x11/xapps/Makefile
+++ b/x11/xapps/Makefile
@@ -1,39 +1,61 @@
-# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
PORTNAME= xapps
PORTVERSION= 1.6.10
PORTREVISION= 1
-CATEGORIES= x11
+CATEGORIES= x11 gnome
+DIST_SUBDIR= gnome
-MAINTAINER= x11@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
COMMENT= Cross-desktop libraries and common resources
LICENSE= LGPL3
+LICENSE_FILE?= ${WRKSRC}/COPYING.LESSER
-BUILD_DEPENDS= vapigen:lang/vala
-LIB_DEPENDS= libgnomekbdui.so:x11/libgnomekbd
+PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
+
+USES?= gettext-tools:build gnome meson pkgconfig python:3.5+ \
+ shebangfix
-USES= gettext gnome meson pkgconfig python:build shebangfix xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-USE_GNOME= cairo gdkpixbuf2 gtk30
-USE_LDCONFIG= yes
-USE_XORG= x11
+
+SLAVE_PORT?= no
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= DOCS
+
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
+
+.if ${SLAVE_PORT} == "no"
+BUILD_DEPENDS= vapigen:lang/vala
+LIB_DEPENDS= libxklavier.so:x11/libxklavier
+RUN_DEPENDS= bash:shells/bash
+
+SHEBANG_FILES= files libxapp schemas status-applets test-scripts
+
+USES+= xorg
+
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 introspection intltool \
+ libgnomekbd
+
GLIB_SCHEMAS= org.x.apps.gschema.xml
INSTALLS_ICONS= yes
-SHEBANG_FILES= libxapp/g-codegen.py libxapp/install_generated_header.py \
- makedoc schemas/meson_install_schemas.py
-post-extract:
-# Do not install auxiliary scripts and adjust icons installation path
- @${RM} -r ${WRKSRC}/files/usr/bin
- @${MKDIR} ${WRKSRC}/files${PREFIX}
- @${MV} ${WRKSRC}/files/usr/share ${WRKSRC}/files${PREFIX}
+USE_XORG= x11
+
+USE_LDCONFIG= yes
post-patch:
-# Do not build non-essential optional components for the moment
- @${REINPLACE_CMD} -E '/pygobject|status-applets/d' \
- ${WRKSRC}/meson.build
+ # pygobject split to x11/py-xapps, as consumers (which may
+ # or may not be in ports) can use either python version
+ @${REINPLACE_CMD} -e "/subdir('pygobject')/d" ${WRKSRC}/meson.build
+ # Adhere to our hier(7).
+ @${MKDIR} ${WRKSRC}/files${PREFIX}
+. for d in bin share
+ @${MV} ${WRKSRC}/files/usr/${d} ${WRKSRC}/files${PREFIX}
+. endfor
+.endif
.include <bsd.port.mk>
diff --git a/x11/xapps/distinfo b/x11/xapps/distinfo
index 8a33484d10ed..a671f752184b 100644
--- a/x11/xapps/distinfo
+++ b/x11/xapps/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1578590051
-SHA256 (linuxmint-xapps-1.6.10_GH0.tar.gz) = 4dd228a2165f1077f18d6fb3152bb77d365ffbb8ad883ed4dd9137886dd21377
-SIZE (linuxmint-xapps-1.6.10_GH0.tar.gz) = 158446
+TIMESTAMP = 1580416208
+SHA256 (gnome/linuxmint-xapps-1.6.10_GH0.tar.gz) = 4dd228a2165f1077f18d6fb3152bb77d365ffbb8ad883ed4dd9137886dd21377
+SIZE (gnome/linuxmint-xapps-1.6.10_GH0.tar.gz) = 158446
diff --git a/x11/xapps/pkg-descr b/x11/xapps/pkg-descr
index aa382880a12e..ab5294957477 100644
--- a/x11/xapps/pkg-descr
+++ b/x11/xapps/pkg-descr
@@ -1,4 +1,5 @@
-This project gathers the components which are common to multiple desktop
-environments and required to implement cross-DE solutions.
+This project gathers the components which are common to multiple
+desktop environments and required to implement cross-DE solutions.
+Consists of xapp-common and libxapp.
-WWW: https://github.com/linuxmint/xapps
+WWW: http://developer.linuxmint.com/projects/xapps.html
diff --git a/x11/xapps/pkg-plist b/x11/xapps/pkg-plist
index 818ce60d6333..9a8f5eaef1c6 100644
--- a/x11/xapps/pkg-plist
+++ b/x11/xapps/pkg-plist
@@ -1,3 +1,6 @@
+bin/pastebin
+bin/upload-system-info
+bin/xfce4-set-wallpaper
include/xapp/libxapp/xapp-gtk-window.h
include/xapp/libxapp/xapp-icon-chooser-button.h
include/xapp/libxapp/xapp-icon-chooser-dialog.h
@@ -13,8 +16,36 @@ lib/libxapp.so
lib/libxapp.so.1
lib/libxapp.so.1.6.10
libdata/pkgconfig/xapp.pc
+libexec/xapps/applet_constants.py
+libexec/xapps/mate-xapp-status-applet.py
+share/dbus-1/services/org.mate.panel.applet.MateXAppStatusAppletFactory.service
share/gir-1.0/XApp-1.0.gir
share/glade/catalogs/xapp-glade-catalog.xml
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppGtkWindow.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppIconChooserButton.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppIconChooserDialog.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppKbdLayoutController.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppMonitorBlanker.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppPreferencesWindow.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStackSidebar.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStatusIcon.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStatusIconInterfaceSkeleton.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppStatusIconMonitor.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/annotation-glossary.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/api-index-full.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/deprecated-api-index.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/home.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/index.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/left.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/libxapp.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/libxapp/object-tree.html
+%%PORTDOCS%%share/gtk-doc/html/libxapp/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/right.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/style.css
+%%PORTDOCS%%share/gtk-doc/html/libxapp/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libxapp/up.png
share/icons/hicolor/scalable/actions/add-files-to-archive-symbolic.svg
share/icons/hicolor/scalable/actions/category-search-symbolic.svg
share/icons/hicolor/scalable/actions/extract-archive-symbolic.svg
@@ -87,5 +118,6 @@ share/locale/uk/LC_MESSAGES/xapp.mo
share/locale/uz/LC_MESSAGES/xapp.mo
share/locale/zh_CN/LC_MESSAGES/xapp.mo
share/locale/zh_TW/LC_MESSAGES/xapp.mo
+share/mate-panel/applets/org.x.MateXAppStatusApplet.mate-panel-applet
share/vala/vapi/xapp.deps
share/vala/vapi/xapp.vapi