aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Li <git@vishwin.info>2020-05-08 23:36:27 +0800
committerCharlie Li <git@vishwin.info>2020-05-08 23:36:27 +0800
commitd6776fe45220850ff7d383b73fea98b31263e1bb (patch)
tree011ae291a948f4d99b54f433ddd739de718b4033
parentd5f311ed5c000f6517a1948225b977d1766164b8 (diff)
downloadfreebsd-ports-gnome-d6776fe45220850ff7d383b73fea98b31263e1bb.tar.gz
freebsd-ports-gnome-d6776fe45220850ff7d383b73fea98b31263e1bb.tar.zst
freebsd-ports-gnome-d6776fe45220850ff7d383b73fea98b31263e1bb.zip
x11/xapps: update to 1.8.2
Roll x11/py-xapps back, as upstream removed Python 2 support
-rw-r--r--x11/py-xapps/Makefile30
-rw-r--r--x11/py-xapps/files/patch-meson.build37
-rw-r--r--x11/xapps/Makefile50
-rw-r--r--x11/xapps/distinfo6
-rw-r--r--x11/xapps/pkg-plist5
5 files changed, 25 insertions, 103 deletions
diff --git a/x11/py-xapps/Makefile b/x11/py-xapps/Makefile
deleted file mode 100644
index 1296b1000c7f..000000000000
--- a/x11/py-xapps/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# $FreeBSD$
-
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-LICENSE_FILE= ${WRKSRC}/../COPYING.LESSER
-
-RUN_DEPENDS= xapps==${PORTVERSION}:x11/xapps
-
-USES= gnome meson pkgconfig python
-
-USE_GNOME= pygobject3
-
-USE_PYTHON= concurrent flavors
-
-MASTERDIR= ${.CURDIR}/../xapps
-PATCHDIR= ${.CURDIR}/files
-PLIST= ${.CURDIR}/pkg-plist
-PLIST_FILES= ${PYTHONPREFIX_SITELIBDIR}/gi/overrides/XApp.py
-WRKSRC_SUBDIR= pygobject
-
-SLAVE_PORT= yes
-
-OPTIONS_EXCLUDE= DOCS
-
-NO_ARCH= yes
-
-post-patch:
- @${REINPLACE_CMD} -e "s|exec|\'${PYTHON_CMD}\'|" ${WRKSRC}/meson.build
-
-.include "${MASTERDIR}/Makefile"
diff --git a/x11/py-xapps/files/patch-meson.build b/x11/py-xapps/files/patch-meson.build
deleted file mode 100644
index d5f7b96106b0..000000000000
--- a/x11/py-xapps/files/patch-meson.build
+++ /dev/null
@@ -1,37 +0,0 @@
-Since this was originally a subdirectory build file, the normally-required
-project() call for root build files does not exist. Add a dummy one
-for this port.
-
-Since each port flavour only installs for one Python installation
-at a time, remove the foreach loop. To simplify the logic, the exec
-variable itself will be REINPLACEd by a string literal to the real
-PYTHON_CMD.
-
---- meson.build.orig 2018-12-11 14:21:46 UTC
-+++ meson.build
-@@ -1,16 +1,16 @@
-+project('xapp')
-+
- pygobject = dependency('pygobject-3.0',
- version: '>=2.9.0',
- required: true,
- )
-
--foreach exec : ['python2', 'python3']
-- r = run_command(exec, '-c', 'import gi;print(gi._overridesdir)')
-+r = run_command(exec, '-c', 'import gi;print(gi._overridesdir)')
-
-- if r.returncode() == 0
-- override_dir = r.stdout().strip()
-- install_data(['XApp.py'],
-- install_dir: override_dir
-- )
-- endif
--endforeach
-+if r.returncode() == 0
-+ override_dir = r.stdout().strip()
-+ install_data(['XApp.py'],
-+ install_dir: override_dir
-+ )
-+endif
-
diff --git a/x11/xapps/Makefile b/x11/xapps/Makefile
index 026d932a4a2b..d2750241032f 100644
--- a/x11/xapps/Makefile
+++ b/x11/xapps/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xapps
-PORTVERSION= 1.6.10
-PORTREVISION= 1
+PORTVERSION= 1.8.2
CATEGORIES= x11 gnome
DIST_SUBDIR= gnome
@@ -12,33 +11,23 @@ COMMENT= Cross-desktop libraries and common resources
LICENSE= LGPL3
LICENSE_FILE?= ${WRKSRC}/COPYING.LESSER
-PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
+BUILD_DEPENDS= vapigen:lang/vala
+LIB_DEPENDS= libxklavier.so:x11/libxklavier \
+ libdbusmenu-gtk3.so:devel/libdbusmenu
+RUN_DEPENDS= bash:shells/bash
-USES?= gettext-tools:build gnome meson pkgconfig python:3.5+ \
- shebangfix
+USES= gettext-tools:build gnome meson pkgconfig python:3.5+ \
+ shebangfix xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-SLAVE_PORT?= no
-
-OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT= DOCS
-
-DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
-DOCS_MESON_TRUE= docs
-
-.if ${SLAVE_PORT} == "no"
-BUILD_DEPENDS= vapigen:lang/vala
-LIB_DEPENDS= libxklavier.so:x11/libxklavier
-RUN_DEPENDS= bash:shells/bash
-
-SHEBANG_FILES= files libxapp schemas status-applets test-scripts
-
-USES+= xorg
+SHEBANG_FILES= libxapp meson-scripts schemas scripts status-applets \
+ test-scripts
+BINARY_ALIAS= python3=${PYTHON_CMD}
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 introspection intltool \
- libgnomekbd
+ libgnomekbd pygobject3
GLIB_SCHEMAS= org.x.apps.gschema.xml
INSTALLS_ICONS= yes
@@ -47,15 +36,12 @@ USE_XORG= x11
USE_LDCONFIG= yes
-post-patch:
- # pygobject split to x11/py-xapps, as consumers (which may
- # or may not be in ports) can use either python version
- @${REINPLACE_CMD} -e "/subdir('pygobject')/d" ${WRKSRC}/meson.build
- # Adhere to our hier(7).
- @${MKDIR} ${WRKSRC}/files${PREFIX}
-. for d in bin share
- @${MV} ${WRKSRC}/files/usr/${d} ${WRKSRC}/files${PREFIX}
-. endfor
-.endif
+PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= DOCS
+
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
.include <bsd.port.mk>
diff --git a/x11/xapps/distinfo b/x11/xapps/distinfo
index a671f752184b..49452df2a098 100644
--- a/x11/xapps/distinfo
+++ b/x11/xapps/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580416208
-SHA256 (gnome/linuxmint-xapps-1.6.10_GH0.tar.gz) = 4dd228a2165f1077f18d6fb3152bb77d365ffbb8ad883ed4dd9137886dd21377
-SIZE (gnome/linuxmint-xapps-1.6.10_GH0.tar.gz) = 158446
+TIMESTAMP = 1588948052
+SHA256 (gnome/linuxmint-xapps-1.8.2_GH0.tar.gz) = 3b99f7a595d6fd82b1a2065e3315a827427da2d76a7f384eee61b526573f3702
+SIZE (gnome/linuxmint-xapps-1.8.2_GH0.tar.gz) = 175561
diff --git a/x11/xapps/pkg-plist b/x11/xapps/pkg-plist
index 9a8f5eaef1c6..11aa5205b2cd 100644
--- a/x11/xapps/pkg-plist
+++ b/x11/xapps/pkg-plist
@@ -14,11 +14,14 @@ include/xapp/libxapp/xapp-statusicon-interface.h
lib/girepository-1.0/XApp-1.0.typelib
lib/libxapp.so
lib/libxapp.so.1
-lib/libxapp.so.1.6.10
+lib/libxapp.so.1.8.2
+%%PYTHON_SITELIBDIR%%/gi/overrides/XApp.py
libdata/pkgconfig/xapp.pc
libexec/xapps/applet_constants.py
libexec/xapps/mate-xapp-status-applet.py
+libexec/xapps/sn-watcher/xapp-sn-watcher
share/dbus-1/services/org.mate.panel.applet.MateXAppStatusAppletFactory.service
+share/dbus-1/services/org.x.StatusNotifierWatcher.service
share/gir-1.0/XApp-1.0.gir
share/glade/catalogs/xapp-glade-catalog.xml
%%PORTDOCS%%share/gtk-doc/html/libxapp/XAppGtkWindow.html