aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharlie Li <git@vishwin.info>2020-05-08 20:38:24 +0800
committerCharlie Li <git@vishwin.info>2020-05-08 20:38:24 +0800
commitfe77326b656865e148087ac2597e1c46a6b5617a (patch)
tree23cc601b1b2ed70ff61870d2e981fa6ac93c4ee8
parentccf430f1abc1183e3b3a1fb3ead96660ee818772 (diff)
downloadfreebsd-ports-gnome-fe77326b656865e148087ac2597e1c46a6b5617a.tar.gz
freebsd-ports-gnome-fe77326b656865e148087ac2597e1c46a6b5617a.tar.zst
freebsd-ports-gnome-fe77326b656865e148087ac2597e1c46a6b5617a.zip
New port: misc/timezonemap
-rw-r--r--misc/Makefile1
-rw-r--r--misc/timezonemap/Makefile32
-rw-r--r--misc/timezonemap/distinfo3
-rw-r--r--misc/timezonemap/pkg-descr5
-rw-r--r--misc/timezonemap/pkg-plist17
5 files changed, 58 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index beef4969735f..635e7afe6020 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -489,6 +489,7 @@
SUBDIR += termatrix
SUBDIR += teseq
SUBDIR += thefuck
+ SUBDIR += timezonemap
SUBDIR += tkcron
SUBDIR += tkinfo
SUBDIR += tkregexp
diff --git a/misc/timezonemap/Makefile b/misc/timezonemap/Makefile
new file mode 100644
index 000000000000..4045767c5998
--- /dev/null
+++ b/misc/timezonemap/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= timezonemap
+DISTVERSION= 0.4.5.1
+CATEGORIES= misc gnome
+
+MAINTAINER= gnome@freebsd.org
+COMMENT= Gtk3 timezone map widget, forked from gnome which forked from Ubiquity
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common
+LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
+ libsoup-2.4.so:devel/libsoup
+
+USES= autoreconf:build gmake gnome libtool pkgconfig
+
+USE_GNOME= cairo gdkpixbuf2 gtk30 introspection:build librsvg2
+
+USE_GITHUB= yes
+GH_ACCOUNT= dashea
+
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+pre-configure:
+ @cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} autogen.sh
+
+.include <bsd.port.mk>
diff --git a/misc/timezonemap/distinfo b/misc/timezonemap/distinfo
new file mode 100644
index 000000000000..0fa532195c71
--- /dev/null
+++ b/misc/timezonemap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579519579
+SHA256 (dashea-timezonemap-0.4.5.1_GH0.tar.gz) = 4e46ef325c488bed73fd758275866f467f2e2d0c375fb3fbd7b149a7869b74be
+SIZE (dashea-timezonemap-0.4.5.1_GH0.tar.gz) = 2535764
diff --git a/misc/timezonemap/pkg-descr b/misc/timezonemap/pkg-descr
new file mode 100644
index 000000000000..0ffdfe12f776
--- /dev/null
+++ b/misc/timezonemap/pkg-descr
@@ -0,0 +1,5 @@
+This static library is a copied version of the code in GNOME 3.0's
+control center panel 'datetime', which itself is a version of
+Ubiquity's map ported to C.
+
+WWW: https://github.com/dashea/timezonemap
diff --git a/misc/timezonemap/pkg-plist b/misc/timezonemap/pkg-plist
new file mode 100644
index 000000000000..72c7e129c594
--- /dev/null
+++ b/misc/timezonemap/pkg-plist
@@ -0,0 +1,17 @@
+include/timezonemap/timezonemap/cc-timezone-location.h
+include/timezonemap/timezonemap/cc-timezone-map.h
+include/timezonemap/timezonemap/timezone-completion.h
+include/timezonemap/timezonemap/tz.h
+lib/girepository-1.0/TimezoneMap-1.0.typelib
+lib/libtimezonemap.so
+lib/libtimezonemap.so.1
+lib/libtimezonemap.so.1.0.0
+libdata/pkgconfig/timezonemap.pc
+share/gir-1.0/TimezoneMap-1.0.gir
+share/glade/catalogs/TimezoneMap.xml
+share/libtimezonemap/admin1Codes.txt
+share/libtimezonemap/backward
+share/libtimezonemap/citiesInfo.txt
+share/libtimezonemap/countryInfo.txt
+share/libtimezonemap/pin.png
+share/libtimezonemap/time_zones_countryInfo-orig.svg