aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2020-02-27 20:01:04 +0800
committertobik <tobik@FreeBSD.org>2020-02-27 20:01:04 +0800
commit866d51f94a76cb4fc55a57dba24e31d7675e1e9e (patch)
treeab4164bbdb8db7be20b1a8e368da73501d42419d
parent5882e864b4d7090e4fac863ce41abc47034bdc58 (diff)
downloadfreebsd-ports-gnome-866d51f94a76cb4fc55a57dba24e31d7675e1e9e.tar.gz
freebsd-ports-gnome-866d51f94a76cb4fc55a57dba24e31d7675e1e9e.tar.zst
freebsd-ports-gnome-866d51f94a76cb4fc55a57dba24e31d7675e1e9e.zip
www/stagit: Update to 0.9.3
- While here clean things up a little Changes: https://codemadness.org/git/stagit/log.html
-rw-r--r--www/stagit/Makefile26
-rw-r--r--www/stagit/distinfo6
-rw-r--r--www/stagit/pkg-plist4
3 files changed, 18 insertions, 18 deletions
diff --git a/www/stagit/Makefile b/www/stagit/Makefile
index 98ae9e922023..b5f54c4ccbb2 100644
--- a/www/stagit/Makefile
+++ b/www/stagit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= stagit
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.3
CATEGORIES= www
MASTER_SITES= https://codemadness.org/releases/stagit/
@@ -14,27 +14,27 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgit2.so:devel/libgit2
-USES= localbase:ldflags
USE_CSTD= c99
-
-MAKE_ARGS= CC="${CC}" \
- CFLAGS="${CFLAGS}" \
- COMPATOBJ="" \
- LDFLAGS="${LDFLAGS} -lgit2"
+MAKE_ARGS= COMPATOBJ="" \
+ LIBGIT_INC="-I${LOCALBASE}/include" \
+ LIBGIT_LIB="-L${LOCALBASE}/lib -lgit2"
OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${PREFIX}/man/man1
- ${INSTALL_PROGRAM} ${WRKSRC}/stagit ${WRKSRC}/stagit-index ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/stagit.1 ${WRKSRC}/stagit-index.1 ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/stagit ${WRKSRC}/stagit-index \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/stagit.1 ${WRKSRC}/stagit-index.1 \
+ ${STAGEDIR}${PREFIX}/share/man/man1
do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
do-install-EXAMPLES-on:
-.for f in example_create.sh example_post-receive.sh favicon.png logo.png style.css
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${EXAMPLESDIR}
-.endfor
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} example_create.sh example_post-receive.sh \
+ favicon.png logo.png style.css ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/www/stagit/distinfo b/www/stagit/distinfo
index dadc49b4e42a..941113a45205 100644
--- a/www/stagit/distinfo
+++ b/www/stagit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1556253511
-SHA256 (stagit-0.9.2.tar.gz) = 721cd7cfac479008e803eff5afd0c95ff9dbc640450afa5b844be82d8dfe0cba
-SIZE (stagit-0.9.2.tar.gz) = 18525
+TIMESTAMP = 1582534033
+SHA256 (stagit-0.9.3.tar.gz) = db89b41c6d3803b2562d56fee0d939360fc887902f17aaf27dff774df0402da3
+SIZE (stagit-0.9.3.tar.gz) = 18464
diff --git a/www/stagit/pkg-plist b/www/stagit/pkg-plist
index 41a3b9139a93..328d356a31b9 100644
--- a/www/stagit/pkg-plist
+++ b/www/stagit/pkg-plist
@@ -1,10 +1,10 @@
bin/stagit
bin/stagit-index
-man/man1/stagit-index.1.gz
-man/man1/stagit.1.gz
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_create.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example_post-receive.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/favicon.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/logo.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/style.css
+share/man/man1/stagit-index.1.gz
+share/man/man1/stagit.1.gz