aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradridg <adridg@FreeBSD.org>2020-02-22 22:52:25 +0800
committeradridg <adridg@FreeBSD.org>2020-02-22 22:52:25 +0800
commit3ecb2383cccc09788108a34c54dd7c8d49eb2229 (patch)
treea41e755d717d00c67471e67a21c3c62639281607
parentfa81a298e65f453177bab48bef8d286099281842 (diff)
downloadfreebsd-ports-gnome-3ecb2383cccc09788108a34c54dd7c8d49eb2229.tar.gz
freebsd-ports-gnome-3ecb2383cccc09788108a34c54dd7c8d49eb2229.tar.zst
freebsd-ports-gnome-3ecb2383cccc09788108a34c54dd7c8d49eb2229.zip
New port: www/kdsoap
KD Soap is a Qt-based client-side and server-side SOAP component. This is soon to be a dependency for KDE software, and is needed on the KDE-FreeBSD CI already (to test the stuff that will have this as a dependency). I'm not 100% convinced about this Makefile: the software is released through GitHub, but a plain "USE_GITHUB=yes" doesn't work, and can't fetch the sources. The fetch attempt goes => Attempting to fetch https://github.com/KDAB/KDSoap/releases/download/kdsoap-1.9.0/KDAB-KDSoap-1.9.0_GH0.tar.gz which fails; chasing the automatic GH download links from the releases on KDSoap's GH page leads me to https://codeload.github.com/KDAB/KDSoap/tar.gz/kdsoap-1.9.0 while the release manager of KDSoap attaches a tarball (and GPG signature) separately. So that's why there's a bit of "pretend" GH use and an explicit MASTER_SITES in this port.
-rw-r--r--www/Makefile1
-rw-r--r--www/kdsoap/Makefile32
-rw-r--r--www/kdsoap/distinfo3
-rw-r--r--www/kdsoap/pkg-descr7
-rw-r--r--www/kdsoap/pkg-plist69
5 files changed, 112 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6c18c1175fc0..1e9656f6f86e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -272,6 +272,7 @@
SUBDIR += kannel
SUBDIR += kannel-sqlbox
SUBDIR += kcgi
+ SUBDIR += kdsoap
SUBDIR += kf5-kdewebkit
SUBDIR += kf5-khtml
SUBDIR += kf5-kjs
diff --git a/www/kdsoap/Makefile b/www/kdsoap/Makefile
new file mode 100644
index 000000000000..3aa62dbce9f5
--- /dev/null
+++ b/www/kdsoap/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= kdsoap
+DISTVERSION= 1.9.0
+CATEGORIES= www
+# It's on GitHub, but KDAB uploads tidy release tarballs,
+# so do NOT USE_GITHUB, but do write out the variables.
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${PORTNAME}-${DISTVERSION}/
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= C++/Qt SOAP framework
+
+# The software is partly under (LGPL21 | GPL2 | GPL3 ), and partly
+# under AGPLv3. We choose LGPL21 and AGPLv3, since that's easiest
+# to express in a ports Makefile.
+LICENSE= LGPL21 AGPLv3
+LICENSE_COMB= multi
+LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE.LGPL.txt
+LICENSE_FILE_AGPLv3= ${WRKSRC}/LICENSE.AGPL3-modified.txt
+
+USES= cmake compiler:c++11-lang localbase qt:5
+USE_LDCONFIG= yes
+USE_QT= qmake_build buildtools_build linguisttools_build \
+ core network widgets xml
+
+# No USE_GITHUB, but pretty close
+GH_ACCOUNT= KDAB
+GH_PROJECT= KDSoap
+
+PLIST_SUB= SOVER=${DISTVERSION}
+
+.include <bsd.port.mk>
diff --git a/www/kdsoap/distinfo b/www/kdsoap/distinfo
new file mode 100644
index 000000000000..b7cca0cd3ccf
--- /dev/null
+++ b/www/kdsoap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582320482
+SHA256 (kdsoap-1.9.0.tar.gz) = e3b9626d5cb08f41a709fa35031ce17bfdd075b7387baf14ecf8a9ca10994828
+SIZE (kdsoap-1.9.0.tar.gz) = 1480479
diff --git a/www/kdsoap/pkg-descr b/www/kdsoap/pkg-descr
new file mode 100644
index 000000000000..2c08cd967b55
--- /dev/null
+++ b/www/kdsoap/pkg-descr
@@ -0,0 +1,7 @@
+KD Soap is a Qt-based client-side and server-side SOAP component.
+
+It can be used to create client applications for web services and also provides the means to create web services without the need for any further component such as a dedicated web server.
+
+KD Soap targets C++ programmers who use Qt in their applications.
+
+WWW: https://github.com/KDAB/KDSoap
diff --git a/www/kdsoap/pkg-plist b/www/kdsoap/pkg-plist
new file mode 100644
index 000000000000..9ad75abbea65
--- /dev/null
+++ b/www/kdsoap/pkg-plist
@@ -0,0 +1,69 @@
+bin/kdwsdl2cpp
+include/KDSoapClient/KDDateTime
+include/KDSoapClient/KDDateTime.h
+include/KDSoapClient/KDQName
+include/KDSoapClient/KDQName.h
+include/KDSoapClient/KDSoap
+include/KDSoapClient/KDSoap.h
+include/KDSoapClient/KDSoapAuthentication
+include/KDSoapClient/KDSoapAuthentication.h
+include/KDSoapClient/KDSoapClient
+include/KDSoapClient/KDSoapClientInterface
+include/KDSoapClient/KDSoapClientInterface.h
+include/KDSoapClient/KDSoapEndpointReference
+include/KDSoapClient/KDSoapEndpointReference.h
+include/KDSoapClient/KDSoapFaultException
+include/KDSoapClient/KDSoapFaultException.h
+include/KDSoapClient/KDSoapGlobal
+include/KDSoapClient/KDSoapGlobal.h
+include/KDSoapClient/KDSoapHeaders
+include/KDSoapClient/KDSoapJob
+include/KDSoapClient/KDSoapJob.h
+include/KDSoapClient/KDSoapMessage
+include/KDSoapClient/KDSoapMessage.h
+include/KDSoapClient/KDSoapMessageAddressingProperties
+include/KDSoapClient/KDSoapMessageAddressingProperties.h
+include/KDSoapClient/KDSoapNamespaceManager
+include/KDSoapClient/KDSoapNamespaceManager.h
+include/KDSoapClient/KDSoapPendingCall
+include/KDSoapClient/KDSoapPendingCall.h
+include/KDSoapClient/KDSoapPendingCallWatcher
+include/KDSoapClient/KDSoapPendingCallWatcher.h
+include/KDSoapClient/KDSoapSslHandler
+include/KDSoapClient/KDSoapSslHandler.h
+include/KDSoapClient/KDSoapUdpClient
+include/KDSoapClient/KDSoapUdpClient.h
+include/KDSoapClient/KDSoapValue
+include/KDSoapClient/KDSoapValue.h
+include/KDSoapClient/KDSoapValueList
+include/KDSoapServer/KDSoapDelayedResponseHandle
+include/KDSoapServer/KDSoapDelayedResponseHandle.h
+include/KDSoapServer/KDSoapServer
+include/KDSoapServer/KDSoapServer.h
+include/KDSoapServer/KDSoapServerAuthInterface
+include/KDSoapServer/KDSoapServerAuthInterface.h
+include/KDSoapServer/KDSoapServerCustomVerbRequestInterface
+include/KDSoapServer/KDSoapServerCustomVerbRequestInterface.h
+include/KDSoapServer/KDSoapServerGlobal
+include/KDSoapServer/KDSoapServerGlobal.h
+include/KDSoapServer/KDSoapServerObjectInterface
+include/KDSoapServer/KDSoapServerObjectInterface.h
+include/KDSoapServer/KDSoapServerRawXMLInterface
+include/KDSoapServer/KDSoapServerRawXMLInterface.h
+include/KDSoapServer/KDSoapThreadPool
+include/KDSoapServer/KDSoapThreadPool.h
+lib/cmake/KDSoap/KDSoapConfig.cmake
+lib/cmake/KDSoap/KDSoapConfigVersion.cmake
+lib/cmake/KDSoap/KDSoapMacros.cmake
+lib/cmake/KDSoap/KDSoapTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KDSoap/KDSoapTargets.cmake
+lib/libkdsoap-server.so
+lib/libkdsoap-server.so.%%SOVER%%
+lib/libkdsoap.so
+lib/libkdsoap.so.%%SOVER%%
+share/doc/KDSoap/LICENSE.GPL.txt
+share/doc/KDSoap/LICENSE.txt
+share/doc/KDSoap/README.txt
+share/doc/KDSoap/kdsoap.pri
+share/doc/KDSoap/kdwsdl2cpp.pri
+share/mkspecs/features/kdsoap.prf