aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2020-02-27 17:05:43 +0800
committerdanfe <danfe@FreeBSD.org>2020-02-27 17:05:43 +0800
commit6cd2c7c3ff9846dcd233b1368f76b62a75d0334b (patch)
tree7c101d4ade65679d6b8b230a26224e3c9c679974
parent7046d4deaeed8d932d0e93914ad90aa81a9c928c (diff)
downloadfreebsd-ports-gnome-6cd2c7c3ff9846dcd233b1368f76b62a75d0334b.tar.gz
freebsd-ports-gnome-6cd2c7c3ff9846dcd233b1368f76b62a75d0334b.tar.zst
freebsd-ports-gnome-6cd2c7c3ff9846dcd233b1368f76b62a75d0334b.zip
Provide an option to build `dwggrep' utility with regex support and make
it enabled by default since `devel/pcre2' is rather common dependency. Because previously built packages could link to PCRE2 libraries without this dependency being recorded, bump port revision.
-rw-r--r--cad/libredwg/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/cad/libredwg/Makefile b/cad/libredwg/Makefile
index 667857fca687..41bc9c6ecfaf 100644
--- a/cad/libredwg/Makefile
+++ b/cad/libredwg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libredwg
PORTVERSION= 0.10.1
+PORTREVISION= 1
CATEGORIES= cad devel
MASTER_SITES= GNU
@@ -20,14 +21,18 @@ TEST_TARGET= check
INFO= LibreDWG
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-OPTIONS_DEFINE= DOCS PSLIB PYTHON
-OPTIONS_DEFAULT= PSLIB
+OPTIONS_DEFINE= DOCS PCRE PSLIB PYTHON
+OPTIONS_DEFAULT= PCRE PSLIB
+PCRE_DESC= Regular expressions support in dwggrep
PSLIB_DESC= PostScript export support (dwg2ps)
+PCRE_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
+PCRE_USES= localbase
+PCRE_CONFIGURE_ENV_OFF= ac_cv_lib_pcre2_8_pcre2_config_8=no
+
PSLIB_LIB_DEPENDS= libps.so:print/pslib
-# XXX: shall `localbase' be put on global USES, it would require explicit
-# PSLIB_CONFIGURE_ENV_OFF= ac_cv_lib_ps_PS_open_file=no
PSLIB_USES= localbase
+PSLIB_CONFIGURE_ENV_OFF= ac_cv_lib_ps_PS_open_file=no
PSLIB_PLIST_FILES= bin/dwg2ps man/man1/dwg2ps.1.gz
PYTHON_CONFIGURE_OFF= --disable-python