aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2020-02-25 05:37:16 +0800
committerflo <flo@FreeBSD.org>2020-02-25 05:37:16 +0800
commite96617e5c9ca0b841777e998628643c75418013f (patch)
tree0956c8e4efc6b83102b3533f782b6179416c42fc
parent0b1222be17d64997211f00f64f81b7930f500a17 (diff)
downloadfreebsd-ports-gnome-e96617e5c9ca0b841777e998628643c75418013f.tar.gz
freebsd-ports-gnome-e96617e5c9ca0b841777e998628643c75418013f.tar.zst
freebsd-ports-gnome-e96617e5c9ca0b841777e998628643c75418013f.zip
Resurrect LimeSurvey and update to 3.22.7
-rw-r--r--MOVED1
-rw-r--r--www/Makefile1
-rw-r--r--www/limesurvey/Makefile74
-rw-r--r--www/limesurvey/distinfo3
-rw-r--r--www/limesurvey/files/pkg-message.in21
-rw-r--r--www/limesurvey/pkg-descr21
6 files changed, 120 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 428d9eae98e5..0ebddd8263d8 100644
--- a/MOVED
+++ b/MOVED
@@ -10916,7 +10916,6 @@ www/pecl-yaf2|www/pecl-yaf|2018-12-30|Has expired: Works only with EOL php 5.6
www/redaxo||2018-12-30|Has expired: Works only with EOL php 5.6
www/dotproject||2018-12-30|Has expired: Works only with EOL php 5.6
www/sitebar||2018-12-30|Has expired: Works only with EOL php 5.6
-www/limesurvey||2018-12-30|Has expired: Works only with EOL php 5.6
www/mahara||2018-12-30|Has expired: Works only with EOL php 5.6
www/mysar||2018-12-30|Has expired: Works only with EOL php 5.6
www/oscommerce||2018-12-30|Has expired: Works only with EOL php 5.6
diff --git a/www/Makefile b/www/Makefile
index f64f9ae0379e..3158a59ff9cc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -299,6 +299,7 @@
SUBDIR += lightsquid
SUBDIR += lighttpd
SUBDIR += lighttpd-mod_h264_streaming
+ SUBDIR += limesurvey
SUBDIR += linkcheck
SUBDIR += linklint
SUBDIR += links
diff --git a/www/limesurvey/Makefile b/www/limesurvey/Makefile
new file mode 100644
index 000000000000..22e7e7cf8179
--- /dev/null
+++ b/www/limesurvey/Makefile
@@ -0,0 +1,74 @@
+# Created by: janos.mohacsi@bsd.hu
+# $FreeBSD$
+
+PORTNAME= limesurvey
+PORTVERSION= 3.22.7
+CATEGORIES= www
+MASTER_SITES= http://download.limesurvey.org/lts-releases/
+DISTNAME= ${PORTNAME}${PORTVERSION}+200225
+
+MAINTAINER= flo@FreeBSD.org
+COMMENT= PHP-based survey building and runing system
+
+LICENSE= GPLv2
+
+USES= cpe php:web tar:bz2
+
+OPTIONS_DEFINE= GD LDAP PGSQL
+OPTIONS_DEFAULT= GD
+
+PGSQL_DESC= Use PostgreSQL (instead of MySQL)
+GD_DESC= Install PHP gd extension
+LDAP_DESC= Install PHP LDAP extension
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP= pdo_pgsql
+.else
+# server is not necessary on this host.
+USE_PHP= pdo_mysql
+.endif
+.if ${PORT_OPTIONS:MGD}
+USE_PHP+= gd
+.endif
+.if ${PORT_OPTIONS:MLDAP}
+USE_PHP+= ldap
+.endif
+USE_PHP+= ctype dom hash iconv json mbstring openssl pcre session \
+ simplexml xmlwriter zip
+
+WWWDOCROOT?= www
+PHPSURVEYORURL?= ${PORTNAME}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+SUB_FILES= pkg-message
+SUB_LIST= PHPSURVEYORDIR="${PHPSURVEYORDIR}" \
+ PHPSURVEYORURL="${PHPSURVEYORURL}"
+
+PHPSURVEYORDIR= ${WWWDOCROOT}/${PHPSURVEYORURL}
+
+do-install:
+ ${MKDIR} "${STAGEDIR}${WWWDIR}"
+ @cd "${WRKSRC}" && ${COPYTREE_SHARE} . "${STAGEDIR}${WWWDIR}"
+ ${MKDIR} "${STAGEDIR}${WWWDIR}"/tmp
+ ${CHMOD} 755 "${STAGEDIR}${WWWDIR}"/tmp
+ ${CHMOD} 755 "${STAGEDIR}${WWWDIR}"/upload
+ ${CHMOD} -R go-w "${STAGEDIR}${WWWDIR}"/admin
+
+post-install:
+ @${ECHO_CMD} "@group ${WWWGRP}" >> ${TMPPLIST}
+ @${FIND} -s -d ${STAGEDIR}${WWWDIR}/admin -type f -print | \
+ ${SED} -e "s#${STAGEDIR}${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${STAGEDIR}${WWWDIR}/admin -type d -print | \
+ ${SED} -E -e "s#${STAGEDIR}${PREFIX}/#@dir #g" >> ${TMPPLIST}
+ @${ECHO_CMD} "@owner ${WWWOWN}" >> ${TMPPLIST}
+ @${FIND} -s -d ${STAGEDIR}${WWWDIR} ! -path "${STAGEDIR}${WWWDIR}/admin/*" -type f -print | \
+ ${SED} -e "s#${STAGEDIR}${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${STAGEDIR}${WWWDIR} -type d ! -path "${STAGEDIR}${WWWDIR}/admin*" -print | \
+ ${SED} -E -e "s#${STAGEDIR}${PREFIX}/#@dir #g" >> ${TMPPLIST}
+ @${ECHO_CMD} "@owner" >> ${TMPPLIST}
+ @${ECHO_CMD} "@group" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/limesurvey/distinfo b/www/limesurvey/distinfo
new file mode 100644
index 000000000000..5b90f998e766
--- /dev/null
+++ b/www/limesurvey/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582572355
+SHA256 (limesurvey3.22.7+200225.tar.bz2) = 8bf18fca09d2a1b9b5319c7157a4b69ee7f85badb757bee5f6f23247b95035f1
+SIZE (limesurvey3.22.7+200225.tar.bz2) = 64294437
diff --git a/www/limesurvey/files/pkg-message.in b/www/limesurvey/files/pkg-message.in
new file mode 100644
index 000000000000..9e3695772689
--- /dev/null
+++ b/www/limesurvey/files/pkg-message.in
@@ -0,0 +1,21 @@
+[
+{ type: install
+ message: <<EOM
+----------------------------------------------------------------------------
+limesurvey has been installed, but is not quite ready to be used yet!
+
+You have to ensure that you have a mysql server installed and configured.
+Further information on these installation procedures may
+be found in:
+
+ %%PREFIX%%/%%PHPSURVEYORDIR%%/docs/manual.html
+
+Once these steps have been taken, you may connect to the following URL to
+configure your installation of limesurvey:
+
+ http://localhost/%%PHPSURVEYORURL%%/
+
+----------------------------------------------------------------------------
+EOM
+}
+]
diff --git a/www/limesurvey/pkg-descr b/www/limesurvey/pkg-descr
new file mode 100644
index 000000000000..3c6a232f5403
--- /dev/null
+++ b/www/limesurvey/pkg-descr
@@ -0,0 +1,21 @@
+From the website:
+
+What is PHP Surveyor?
+
+PHP Surveyor is a set of PHP scripts that interact with MySQL to develop
+surveys, publish surveys and collect responses to surveys. Once a survey
+has been created it can be published as an online survey (displayed as
+single questions, group by group or all in one page) or you can use a
+dataentry system for administration of paper-based versions of the survey.
+PHP Surveyor can produced 'branching' surveys (set conditions on whether
+individual questions will display), can vary the look and feel of your
+survey through a templating system, and can provide basic statistical
+analysis of your survey results.
+
+PHP Surveyor includes the capacity to generate individualised 'tokens', so
+if you have a list of people you want to invite to participate in a survey
+you can issue each one with a token, and they will be able to access the
+survey using that token. This allows for quite good quality control of
+your surveys.
+
+WWW: http://www.limesurvey.org/