aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:00 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 21:33:39 +0800
commit660f00d463578f84f6f444b21570fdb01420daf3 (patch)
tree608775764ded78ef8adf097da92749e69fc0343b
parent5ecf25f4833efcfc2c428e347d1bc40ccd98705e (diff)
downloadfreebsd-ports-gnome-660f00d463578f84f6f444b21570fdb01420daf3.tar.gz
freebsd-ports-gnome-660f00d463578f84f6f444b21570fdb01420daf3.tar.zst
freebsd-ports-gnome-660f00d463578f84f6f444b21570fdb01420daf3.zip
Use WANT_PGSQL instead of hard-coded RUN_DEPENDS
Note that postgresql-client was already brought in via USES=pgsql. Therefore the equivalent WANT_PGSQL is "lib server". Approved by: portmgr (blanket)
-rw-r--r--databases/postgis23/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/databases/postgis23/Makefile b/databases/postgis23/Makefile
index 0031ce245713..51441dbb0b5c 100644
--- a/databases/postgis23/Makefile
+++ b/databases/postgis23/Makefile
@@ -16,8 +16,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libproj.so:graphics/proj \
libgeos.so:graphics/geos \
libjson-c.so:devel/json-c
-RUN_DEPENDS= postmaster:databases/postgresql${PGSQL_VER_NODOT}-server
-
CONFLICTS= postgis20-2.0.* postgis-2.1.* postgis-22*
USES= gettext gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
@@ -29,6 +27,7 @@ SHEBANG_FILES= extensions/address_standardizer/*.pl raster/test/regress/*.pl \
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_PERL5= build
+WANT_PGSQL= lib server
OPTIONS_DEFINE= LOADERGUI RASTER TOPOLOGY SFCGAL ADDRSTD
OPTIONS_DEFAULT= TOPOLOGY ADDRSTD