aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-19 02:55:49 +0800
committerantoine <antoine@FreeBSD.org>2014-02-19 02:55:49 +0800
commit6d87357c00f8d36caad8ff900c4e553f5ecee03c (patch)
tree39ca9308a19d6487e26008da18f64d5c0ebea79d
parent2d702611ba9bc97bab902e84e79795a6c66a4fad (diff)
downloadfreebsd-ports-gnome-6d87357c00f8d36caad8ff900c4e553f5ecee03c.tar.gz
freebsd-ports-gnome-6d87357c00f8d36caad8ff900c4e553f5ecee03c.tar.zst
freebsd-ports-gnome-6d87357c00f8d36caad8ff900c4e553f5ecee03c.zip
Stage support
-rw-r--r--devel/distorm/Makefile23
-rw-r--r--devel/py-distorm/Makefile1
2 files changed, 11 insertions, 13 deletions
diff --git a/devel/distorm/Makefile b/devel/distorm/Makefile
index 5c5116c8578f..e0ae5fc0deaa 100644
--- a/devel/distorm/Makefile
+++ b/devel/distorm/Makefile
@@ -22,19 +22,19 @@ COMMENT?= Fast x86 and x86-64 disassembler library
LICENSE= GPLv3
-USE_DOS2UNIX= yes
+USES= dos2unix
USE_XZ = yes
.if defined(PYTHON_SLAVEPORT)
USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= distorm3
-PYDISTUTILS_PKGVERSION = 3
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= distorm3
+PYDISTUTILS_PKGVERSION= 3
PLIST_DIRS= %%PYTHON_SITELIBDIR%%/distorm3
-PLIST_FILES = bin/dislib.py \
+PLIST_FILES= bin/dislib.py \
%%PYTHON_SITELIBDIR%%/distorm3/sample.py \
%%PYTHON_SITELIBDIR%%/distorm3/__init__.py \
%%PYTHON_SITELIBDIR%%/distorm3/libdistorm3.so \
@@ -55,7 +55,6 @@ PLIST_FILES= bin/disasm \
lib/libdistorm3.so.1
.endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -73,7 +72,7 @@ post-patch:
@${REINPLACE_CMD} -e "\|extra_compile_args=|s| '-O2',||" ${WRKSRC}/setup.py
post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/dislib.py ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/dislib.py ${STAGEDIR}${PREFIX}/bin
.else
do-build:
@@ -89,11 +88,11 @@ check regression-test test: build
@cd ${BUILD_WRKSRC}; ./disasm disasm
do-install:
- @(cd ${BUILD_WRKSRC}; ${INSTALL_LIB} libdistorm3.a ${PREFIX}/lib; \
- ${INSTALL_LIB} libdistorm3.so ${PREFIX}/lib/libdistorm3.so.1; \
- ${LN} -sf libdistorm3.so.1 ${PREFIX}/lib/libdistorm3.so; \
- ${INSTALL_PROGRAM} disasm ${PREFIX}/bin)
- @${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include
+ @(cd ${BUILD_WRKSRC}; ${INSTALL_LIB} libdistorm3.a ${STAGEDIR}${PREFIX}/lib; \
+ ${INSTALL_LIB} libdistorm3.so ${STAGEDIR}${PREFIX}/lib/libdistorm3.so.1; \
+ ${LN} -sf libdistorm3.so.1 ${STAGEDIR}${PREFIX}/lib/libdistorm3.so; \
+ ${INSTALL_PROGRAM} disasm ${STAGEDIR}${PREFIX}/bin)
+ @${INSTALL_DATA} ${WRKSRC}/include/*.h ${STAGEDIR}${PREFIX}/include
.endif
.include <bsd.port.post.mk>
diff --git a/devel/py-distorm/Makefile b/devel/py-distorm/Makefile
index 17a452f0ffd1..b9734da85619 100644
--- a/devel/py-distorm/Makefile
+++ b/devel/py-distorm/Makefile
@@ -9,5 +9,4 @@ PORTREVISION= 0
PYTHON_SLAVEPORT= yes
MASTERDIR= ${.CURDIR}/../distorm
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
longer part of leafnode, the author changedbrian2000-01-311-3/+1 * Upgrade to dejasearch 1.7.2kris2000-01-302-5/+4 * Update to version 6.5.5.steve2000-01-3015-87/+349 * Fix ${PREFIX} substitution problemtom2000-01-291-3/+3 * Upgrade to inn 2.2.2torstenb2000-01-294-4/+4 * Update port to 0.7.3jedgar2000-01-284-6/+6 * Update port to 0.7.2jedgar2000-01-266-8/+10 * Fix pkg/MESSAGE version numbering problem. Also, upgrade to thetom2000-01-253-11/+19 * Update to version 4.3.6.steve2000-01-246-250/+129 * Fixup the pgpverify patch and make the y2k path more robust.steve2000-01-242-4/+7 * Update to 1.4.2.obrien2000-01-242-5/+5 * "As installed by the news/aub port, it will only recognize EOL by the \nobrien2000-01-161-3/+12 * Update port to 0.7.1jedgar2000-01-144-6/+6 * Update to 1.5.12.2 and add a y2k patchcpiazza2000-01-125-7/+427 * Move the only master site that has one of the distfilescpiazza2000-01-121-2/+2 * Update port to 0.7.0jedgar2000-01-116-48/+22 * Don't include bsd.port.pre.mk twice. This usually is caused by firstasami2000-01-082-2/+2 * Upgrade to version 1.9.7brian1999-12-303-8/+5 * Update to version 0.9.6.2.steve1999-12-302-4/+4 * Update to newest STABLE versionandreas1999-12-264-5/+17 * Unbreak by fixing problems caused by gawk(1).steve1999-12-252-1/+7 * remove --prefix=${PREFIX} when GNU_CONFIGURE=yes and other minor cleanupsmharo1999-12-251-2/+2 * Update to version 2.9.steve1999-12-244-5/+5 * Add MASTER_SITES 'obsolete' directory to MASTER_SITES tojedgar1999-12-232-2/+4 * Remove jraynard as MAINTAINER, since he no longer has an account.fenner1999-12-231-2/+0 * Update to 0.6.7jedgar1999-12-228-8/+62 * Checksum changed on MASTER_SITE.steve1999-12-112-2/+2 * Add a patch to allow the user to specify the port number for the newscpiazza1999-12-061-0/+56 * Update to version 0.6.5cpiazza1999-12-054-6/+6 * Upgrade to "Polish", the 1.4.1 release.obrien1999-12-033-18/+17 * Update to version 0.6.4cpiazza1999-12-016-12/+10 * Cleanup all files on deinstallation of this port.steve1999-11-271-6/+22 * Mark broken for anything except 2.x because our system awk (3.0.3) causessteve1999-11-272-2/+16 * Update to reflect the new configuration of the cnews port.steve1999-11-271-1/+25 * Update to version 0.6.3.jim1999-11-188-6/+18 * Upgrade to suck-4.2.2jseger1999-11-172-3/+3 * Upgrade to "No Labels", the 1.4.0 release.obrien1999-11-142-3/+2 * Update to version 0.6.2.jim1999-11-036-8/+10 * prefix -> localbasemharo1999-10-271-1/+1 * y2k patchmharo1999-10-271-0/+11 * Update to version 0.61cpiazza1999-10-216-6/+12 * Update to 0.6.0nakai1999-10-154-8/+8 * Use PKG_PREFIX in pkg/INSTALL instead of PREFIX so this will installsteve1999-10-112-3/+3 * Update ifmail to 2.15dan1999-10-093-169/+110 * Move USE_BZIP2 down to where it belongs so portlint no longerjim1999-10-031-1/+1 * Update to version 1.2.3cpiazza1999-10-027-32/+65 * Upgrade to "Nine While Nine" the 19990927 version.obrien1999-09-283-9/+9 * Update to version 0.5.2cpiazza1999-09-286-6/+10 * Update leafnode+ port to 2.8dan1999-09-273-18/+18 * Updated to version 0.5.0jim1999-09-194-10/+10 * Enforce random pkg/COMMENT rules, including the one that states Emacshoek1999-09-182-2/+2 * Typo ("$(CHOWN}" -> "${CHOWN}"). Fix "version required" comment andasami1999-09-111-10/+10 * /var/spool/news doesn't exist by default, so create it in pre-install.asami1999-09-112-0/+6 * Upgrade to INN 2.2.1.torstenb1999-09-106-10/+20 * Update MASTER_SITEScpiazza1999-09-102-2/+2 * Update to version 0.4.9.jim1999-09-084-6/+6 * Rework configuration, add a MASTER_SITE, and honor PREFIX.steve1999-09-074-168/+209 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-3115-19/+19 * $Id$ -> $FreeBSD$peter1999-08-3044-44/+44 * Activate pan.jim1999-08-301-1/+2 * Import of pan.jim1999-08-3010-0/+96 * Remove preceeding pkgname from some of the comments having one.hoek1999-08-302-2/+2 * sed -> ${SED}mharo1999-08-281-2/+2 * ln -> ${LN}mharo1999-08-283-6/+6 * echo -> ${ECHO} or ${ECHO_MSG} and in some cases, move echo stuffmharo1999-08-283-7/+7 * grep -> ${GREP}mharo1999-08-231-2/+2 * awk -> ${AWK}mharo1999-08-232-5/+5 * chown -> ${CHOWN}mharo1999-08-231-9/+9 * chmod -> ${CHMOD}mharo1999-08-236-18/+18 * Get the sources of the inn-stable port from the download sectionandreas1999-08-221-2/+3 * Update one of the MASTER_SITEScpiazza1999-08-141-2/+2 * Change the second MASTER_SITEcpiazza1999-08-141-2/+2 * Update to the 1.4.19990805 "Preacher Man" version.obrien1999-08-072-4/+4 * "foo" and "bar" are not valid categories. :)asami1999-08-051-2/+2 * Activate bgrabcpiazza1999-08-021-1/+2 * Import of bgrab.cpiazza1999-08-027-0/+75 * Upgrade to dejasearch 1.6.3kris1999-07-274-15/+9 * Update inn-stable to latest version inn-STABLE_2_2-1999-07-24_03-02andreas1999-07-252-3/+3 * Upgrade to suck-4.2.1jseger1999-07-222-4/+4 * Adjust do-install target to match reality (${MACHINE_ARCH} now part ofasami1999-07-191-3/+3 * Update to 0.9.5.7cpiazza1999-07-172-4/+5 * Unified the writing of working directories.sada1999-07-062-4/+6 * Change maintainer's email address.cpiazza1999-07-051-3/+3 * No need to use -p since ${MKDIR} == 'mkdir -p'.steve1999-07-051-2/+2 * A bit of portlint cleaning and fix a few style nits.steve1999-07-051-28/+36