aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:20 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 21:33:41 +0800
commit73dd05eec3de82fafa4db4a738762ac1d6dc2e6f (patch)
tree2d6034d17e64db98d511a54a616b850a8d273316
parent0d222ee07ac0d19fccf07951d221d3aa2092b5d2 (diff)
downloadfreebsd-ports-gnome-73dd05eec3de82fafa4db4a738762ac1d6dc2e6f.tar.gz
freebsd-ports-gnome-73dd05eec3de82fafa4db4a738762ac1d6dc2e6f.tar.zst
freebsd-ports-gnome-73dd05eec3de82fafa4db4a738762ac1d6dc2e6f.zip
Update to 1.10.10
- Add LICENSE_FILE - Strip shared library - Update pkg-descr - Change WWW to PyPI - Take maintainership Changes: https://github.com/GrahamDumpleton/wrapt/blob/develop/docs/changes.rst
-rw-r--r--devel/py-wrapt/Makefile8
-rw-r--r--devel/py-wrapt/distinfo6
-rw-r--r--devel/py-wrapt/pkg-descr14
3 files changed, 19 insertions, 9 deletions
diff --git a/devel/py-wrapt/Makefile b/devel/py-wrapt/Makefile
index c2a2793e4427..9c768f69b025 100644
--- a/devel/py-wrapt/Makefile
+++ b/devel/py-wrapt/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= wrapt
-PORTVERSION= 1.10.8
+PORTVERSION= 1.10.10
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,8 +10,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Decorators, wrappers and monkey patching
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python
USE_PYTHON= autoplist distutils
+USES= python
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/wrapt/_wrappers.so
.include <bsd.port.mk>
diff --git a/devel/py-wrapt/distinfo b/devel/py-wrapt/distinfo
index 3fe11d9d9f5e..b757bf53a762 100644
--- a/devel/py-wrapt/distinfo
+++ b/devel/py-wrapt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1466486348
-SHA256 (wrapt-1.10.8.tar.gz) = 4ea17e814e39883c6cf1bb9b0835d316b2f69f0f0882ffe7dad1ede66ba82c73
-SIZE (wrapt-1.10.8.tar.gz) = 25183
+TIMESTAMP = 1491416518
+SHA256 (wrapt-1.10.10.tar.gz) = 42160c91b77f1bc64a955890038e02f2f72986c01d462d53cb6cb039b995cdd9
+SIZE (wrapt-1.10.10.tar.gz) = 27257
diff --git a/devel/py-wrapt/pkg-descr b/devel/py-wrapt/pkg-descr
index a173f46346ed..2a1ab2a54d40 100644
--- a/devel/py-wrapt/pkg-descr
+++ b/devel/py-wrapt/pkg-descr
@@ -1,5 +1,11 @@
-The aim of the wrapt module is to provide a transparent object proxy for
-Python, which can be used as the basis for the construction of function
-wrappers and decorator functions.
+The aim of the wrapt module is to provide a transparent object proxy for Python,
+which can be used as the basis for the construction of function wrappers and
+decorator functions.
-WWW: https://github.com/GrahamDumpleton/wrapt
+The wrapt module focuses very much on correctness. It therefore goes way beyond
+existing mechanisms such as functools.wraps() to ensure that decorators preserve
+introspectability, signatures, type checking abilities etc. The decorators that
+can be constructed using this module will work in far more scenarios than
+typical decorators and provide more predictable and consistent behaviour.
+
+WWW: https://pypi.python.org/pypi/wrapt