aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-06 03:59:10 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 21:33:40 +0800
commitee9a19360e1a892b2be65a142998c4d2701b79ba (patch)
tree07bb7cf2ee0168a45af444b8b7ca6a8cf5ac4416
parent7f98d6b0390867604881a9f864c0cefe6459753b (diff)
downloadfreebsd-ports-gnome-ee9a19360e1a892b2be65a142998c4d2701b79ba.tar.gz
freebsd-ports-gnome-ee9a19360e1a892b2be65a142998c4d2701b79ba.tar.zst
freebsd-ports-gnome-ee9a19360e1a892b2be65a142998c4d2701b79ba.zip
Convert to options helper and test framework
Approved by: portmgr (blanket)
-rw-r--r--net/rsync/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 2b4a260cb759..f0ec030e4df9 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -29,6 +29,7 @@ USE_RC_SUBR= rsyncd
SUB_LIST= NAME=rsyncd
INSTALL_TARGET= install-strip
+TEST_TARGET= check
CONFIGURE_ARGS= --disable-debug --enable-ipv6 \
--with-rsyncd-conf=${ETCDIR}/rsyncd.conf
@@ -79,9 +80,14 @@ POPT_PORT_CONFIGURE_OFF= --with-included-popt
SSH_CONFIGURE_ON= --with-rsh=ssh
SSH_CONFIGURE_OFF= --with-rsh=rsh
-.include <bsd.port.options.mk>
+ACL_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+ATIMES_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+FLAGS_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+ICONV_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+RENAMED_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
+TIMELIMIT_DISTFILES= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
-.if ${PORT_OPTIONS:MICONV} || ${PORT_OPTIONS:MFLAGS} || ${PORT_OPTIONS:MACL} || make(makesum) || ${PORT_OPTIONS:MTIMELIMIT} || ${PORT_OPTIONS:MATIMES} || ${PORT_OPTIONS:MRENAMED}
+.if make(makesum)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
.endif
@@ -102,7 +108,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-test: build
- @(cd ${WRKSRC} && ${MAKE_CMD} check)
-
.include <bsd.port.post.mk>