aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-21 04:36:39 +0800
committerbapt <bapt@FreeBSD.org>2014-10-21 04:36:39 +0800
commitf12c9bfe6d57fd719a90e01adb0237eb14af2eee (patch)
treef534e97eaee62f9883b7ad6d32b2fd6437427d0e
parentdb17d4c21cece3bcdd67fc49ed78fe05e444d2d3 (diff)
downloadfreebsd-ports-gnome-f12c9bfe6d57fd719a90e01adb0237eb14af2eee.tar.gz
freebsd-ports-gnome-f12c9bfe6d57fd719a90e01adb0237eb14af2eee.tar.zst
freebsd-ports-gnome-f12c9bfe6d57fd719a90e01adb0237eb14af2eee.zip
Remove unused and broken new-plist target
Modify the automatic plist to not generate the @dirrm
-rw-r--r--Mk/bsd.linux-rpm.mk15
1 files changed, 1 insertions, 14 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index f4d84a26a5a4..8ee50e5a93ce 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -189,10 +189,7 @@ pre-install: linux-rpm-generate-plist
. if !target(linux-rpm-generate-plist)
linux-rpm-generate-plist:
cd ${WRKSRC} && \
- ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST} && \
- ${FIND} * ! -path "stage*" -type d | ${SORT} | ${SED} -e 's|^|@dirrm |' > ${PLIST}.dirs
- @${GREP} '^@dirrm' ${PORTSDIR}/emulators/linux_base-${_LINUX_BASE_SUFFIX}/pkg-plist | ${SED} 's:^@dirrmtry:@dirrm:g' | ${SORT} > ${PLIST}.shared-dirs
- @${COMM} -1 -3 ${PLIST}.shared-dirs ${PLIST}.dirs | ${SORT} -r >> ${PLIST}
+ ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST}
. endif
. endif
@@ -209,14 +206,4 @@ do-install:
cd ${WRKSRC} && ${FIND} * ! -path "stage*" -type d -exec ${MKDIR} "${STAGEDIR}${PREFIX}/{}" \;
cd ${WRKSRC} && ${FIND} * ! -path "stage/*" ! -type d | ${CPIO} -pm -R root:wheel ${STAGEDIR}${PREFIX}
. endif
-
-. if !target(new-plist)
-new-plist: build
- @${RM} -f ${PLIST}.new
- @cd ${WRKSRC} && \
- ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST}.new; \
- ${FIND} -d * ! -path "stage*" -type d | ${SED} -e 's|^|@dirrm |' >> ${PLIST}.new; \
- done
-. endif
-
.endif