aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2011-01-11 03:01:02 +0800
committeraz <az@FreeBSD.org>2011-01-11 03:01:02 +0800
commit00a346059834535598a8b7d3022648c9e89036be (patch)
tree76cd53d2d08f1ccdd150be43e547bf6c28b84ac5
parentae614b92ebf4095603c58446dfc76282e57fba8b (diff)
downloadfreebsd-ports-gnome-00a346059834535598a8b7d3022648c9e89036be.tar.gz
freebsd-ports-gnome-00a346059834535598a8b7d3022648c9e89036be.tar.zst
freebsd-ports-gnome-00a346059834535598a8b7d3022648c9e89036be.zip
- Fix usage of @dirrmtry macro
PR: ports/153854 Submitted by: az Approved by: maintainer
-rw-r--r--audio/freeswitch-sounds/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/audio/freeswitch-sounds/Makefile b/audio/freeswitch-sounds/Makefile
index f770ff5572ec..4a32b5ae9987 100644
--- a/audio/freeswitch-sounds/Makefile
+++ b/audio/freeswitch-sounds/Makefile
@@ -109,8 +109,8 @@ pre-install:
${ECHO} .freeswitch-sounds >> ${PLIST}; \
${SED} -i "" -e "s:^:share/${BASE_PORTNAME}/sounds/:" ${PLIST}; \
${FIND} * -type d ! -empty | ${SORT} -r | ${SED} -e "s:^:@dirrm share/${BASE_PORTNAME}/sounds/:" | ${GREP} / >> ${PLIST}; \
- ${ECHO} "@dirrmtry share/${BASE_PORTNAME}/sounds 2> /dev/null || /usr/bin/true" >> ${PLIST}; \
- ${ECHO} "@dirrmtry share/${BASE_PORTNAME} 2> /dev/null || /usr/bin/true" >> ${PLIST};
+ ${ECHO} "@dirrmtry share/${BASE_PORTNAME}/sounds" >> ${PLIST}; \
+ ${ECHO} "@dirrmtry share/${BASE_PORTNAME}" >> ${PLIST};
${CHMOD} -R 0755 ${WRKDIR}/tmp/
do-install: