aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-08-31 19:57:23 +0800
committerskv <skv@FreeBSD.org>2005-08-31 19:57:23 +0800
commit011076dc376476bc78b84e1ffbc1eda06ba960ec (patch)
tree48ef00984550cb1e26af4caf469ffd4ea33e265d
parentd7f8ef3741fb5a0adf5cf33eb53abcac2856b7f1 (diff)
downloadfreebsd-ports-gnome-011076dc376476bc78b84e1ffbc1eda06ba960ec.tar.gz
freebsd-ports-gnome-011076dc376476bc78b84e1ffbc1eda06ba960ec.tar.zst
freebsd-ports-gnome-011076dc376476bc78b84e1ffbc1eda06ba960ec.zip
Add p5-Readonly 1.03, facility for creating read-only scalars, arrays,
hashes.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Readonly/Makefile35
-rw-r--r--devel/p5-Readonly/distinfo4
-rw-r--r--devel/p5-Readonly/pkg-descr6
-rw-r--r--devel/p5-Readonly/pkg-plist8
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5e8e0b93c141..f4e7a79b4e3c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1053,6 +1053,7 @@
SUBDIR += p5-Rcs-Agent
SUBDIR += p5-ReadLine-Gnu
SUBDIR += p5-ReadLine-Perl
+ SUBDIR += p5-Readonly
SUBDIR += p5-Regexp-Assemble
SUBDIR += p5-Regexp-Shellish
SUBDIR += p5-Religion
diff --git a/devel/p5-Readonly/Makefile b/devel/p5-Readonly/Makefile
new file mode 100644
index 000000000000..47c9a8312bf4
--- /dev/null
+++ b/devel/p5-Readonly/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Readonly
+# Date created: 31 August 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Readonly
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/R/RO/ROODE
+PKGNAMEPREFIX= p5-
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-XS-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Facility for creating read-only scalars, arrays, hashes
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= DIR="${PORTNAME}-XS-${PORTVERSION}"
+
+MAN3= Readonly.3 Readonly::XS.3
+
+post-patch:
+ ${MV} ${WRKDIR}/${PORTNAME}-XS-${PORTVERSION} ${WRKSRC}
+ ${RM} ${WRKSRC}/*.pl
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Perl 5.8 or newer required. Install lang/perl5.8 and try again.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Readonly/distinfo b/devel/p5-Readonly/distinfo
new file mode 100644
index 000000000000..22fe8ce390a0
--- /dev/null
+++ b/devel/p5-Readonly/distinfo
@@ -0,0 +1,4 @@
+MD5 (Readonly-1.03.tar.gz) = 0acef3a995ac9ecf575f66a726d638f4
+SIZE (Readonly-1.03.tar.gz) = 13677
+MD5 (Readonly-XS-1.03.tar.gz) = 18742d473da99aa6e02261b55e008e3a
+SIZE (Readonly-XS-1.03.tar.gz) = 9032
diff --git a/devel/p5-Readonly/pkg-descr b/devel/p5-Readonly/pkg-descr
new file mode 100644
index 000000000000..2eca807ec9a3
--- /dev/null
+++ b/devel/p5-Readonly/pkg-descr
@@ -0,0 +1,6 @@
+This is a facility for creating non-modifiable variables. This is
+useful for configuration files, headers, etc. It can also be useful as
+a development and debugging tool, for catching updates to variables that
+should not be changed.
+
+WWW: http://search.cpan.org/dist/Readonly/
diff --git a/devel/p5-Readonly/pkg-plist b/devel/p5-Readonly/pkg-plist
new file mode 100644
index 000000000000..591d1bcf6495
--- /dev/null
+++ b/devel/p5-Readonly/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Readonly.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Readonly/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Readonly
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly/XS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Readonly