aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-10-21 21:39:05 +0800
committeralepulver <alepulver@FreeBSD.org>2006-10-21 21:39:05 +0800
commit01a67a4157f41b3b2d029b27779755264bd4b667 (patch)
tree3668ea07cbe491dd90682dc92a223e986af78e93
parent8970edb0efa07442372bf0bc8ee8b544e21ee7d4 (diff)
downloadfreebsd-ports-gnome-01a67a4157f41b3b2d029b27779755264bd4b667.tar.gz
freebsd-ports-gnome-01a67a4157f41b3b2d029b27779755264bd4b667.tar.zst
freebsd-ports-gnome-01a67a4157f41b3b2d029b27779755264bd4b667.zip
- Fix pkg-install and pkg-deinstall scripts to properly handle /boot.config
and /etc/ttys. - Remove BROKEN, DEPRECATED and EXPIRATION_DATE. PR: ports/104312 Submitted by: Frank J. Laszlo <laszlof@vonostingroup.com> Approved by: portmgr (erwin)
-rw-r--r--sysutils/comconsole/Makefile6
-rw-r--r--sysutils/comconsole/pkg-deinstall27
-rw-r--r--sysutils/comconsole/pkg-install27
3 files changed, 5 insertions, 55 deletions
diff --git a/sysutils/comconsole/Makefile b/sysutils/comconsole/Makefile
index 5dffcc06ccca..5d202f33c506 100644
--- a/sysutils/comconsole/Makefile
+++ b/sysutils/comconsole/Makefile
@@ -9,15 +9,11 @@ PORTNAME= comconsole
PORTVERSION= 0.1
CATEGORIES= sysutils
MASTER_SITES= #
-DISTFILES=
+DISTFILES= #
MAINTAINER= ports@FreeBSD.org
COMMENT= Setup your PC to use serial port COM1 as its console device
-BROKEN= Modifies files in / and does not undo upon deinstall
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/sysutils/comconsole/pkg-deinstall b/sysutils/comconsole/pkg-deinstall
index c8e021d4a689..f6f3e58682bb 100644
--- a/sysutils/comconsole/pkg-deinstall
+++ b/sysutils/comconsole/pkg-deinstall
@@ -1,29 +1,6 @@
#!/bin/sh
[ "x$1" = "x" ] && exit 1
-if [ "x$2" = "xPOST-INSTALL" ]; then
- cat <<'EOF' >/boot.config
--P
-EOF
- mv -f /etc/ttys /etc/ttys.last
- awk -f - /etc/ttys.last <<'EOF' >/etc/ttys
-/^console/ {
- print "console \"/usr/libexec/getty std.9600\" vt100 on secure"
- next
-}
-{
- print
-}
-EOF
-fi
if [ "x$2" = "xDEINSTALL" ]; then
- mv -f /etc/ttys /etc/ttys.last
- awk -f - /etc/ttys.last <<'EOF' >/etc/ttys
-/^console/ {
- print "console none unknown off secure"
- next
-}
-{
- print
-}
-EOF
+ sed -i '' "s|^console.*|console none unknown off secure|" /etc/ttys
+ rm -f /boot.config
fi
diff --git a/sysutils/comconsole/pkg-install b/sysutils/comconsole/pkg-install
index c8e021d4a689..c45c5b04411d 100644
--- a/sysutils/comconsole/pkg-install
+++ b/sysutils/comconsole/pkg-install
@@ -1,29 +1,6 @@
#!/bin/sh
[ "x$1" = "x" ] && exit 1
if [ "x$2" = "xPOST-INSTALL" ]; then
- cat <<'EOF' >/boot.config
--P
-EOF
- mv -f /etc/ttys /etc/ttys.last
- awk -f - /etc/ttys.last <<'EOF' >/etc/ttys
-/^console/ {
- print "console \"/usr/libexec/getty std.9600\" vt100 on secure"
- next
-}
-{
- print
-}
-EOF
-fi
-if [ "x$2" = "xDEINSTALL" ]; then
- mv -f /etc/ttys /etc/ttys.last
- awk -f - /etc/ttys.last <<'EOF' >/etc/ttys
-/^console/ {
- print "console none unknown off secure"
- next
-}
-{
- print
-}
-EOF
+ echo "-P" > /boot.config
+ sed -i '' "s|^console.*|console \"/usr/libexec/getty std.9600\" vt100 on secure|" /etc/ttys
fi