aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-02-25 02:25:13 +0800
committerclsung <clsung@FreeBSD.org>2007-02-25 02:25:13 +0800
commit020a3626b63feb758a81f1f8c52bc82afc5a59a8 (patch)
tree84beda83dc625e33ec6e150f42fd837a30ec5125
parentda331757a2fe7b290e7b8111185e8ae20b5aefcd (diff)
downloadfreebsd-ports-gnome-020a3626b63feb758a81f1f8c52bc82afc5a59a8.tar.gz
freebsd-ports-gnome-020a3626b63feb758a81f1f8c52bc82afc5a59a8.tar.zst
freebsd-ports-gnome-020a3626b63feb758a81f1f8c52bc82afc5a59a8.zip
Add p5-PHP-Serialization 0.27, converting the output of PHP serialize()
into the Perl. PR: ports/109452 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-PHP-Serialization/Makefile28
-rw-r--r--devel/p5-PHP-Serialization/distinfo3
-rw-r--r--devel/p5-PHP-Serialization/pkg-descr9
-rw-r--r--devel/p5-PHP-Serialization/pkg-plist6
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ebf22393b6d4..3704d90bc171 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1303,6 +1303,7 @@
SUBDIR += p5-PAR-Dist
SUBDIR += p5-PAR-Packer
SUBDIR += p5-PCSC-Card
+ SUBDIR += p5-PHP-Serialization
SUBDIR += p5-POE
SUBDIR += p5-POE-API-Hooks
SUBDIR += p5-POE-API-Peek
diff --git a/devel/p5-PHP-Serialization/Makefile b/devel/p5-PHP-Serialization/Makefile
new file mode 100644
index 000000000000..e6c3a5c8bf1c
--- /dev/null
+++ b/devel/p5-PHP-Serialization/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-PHP-Serialization
+# Date created: 2007-02-23
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP-Serialization
+PORTVERSION= 0.27
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= PHP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Converting the output of PHP serialize() into the Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= PHP::Serialization.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-PHP-Serialization/distinfo b/devel/p5-PHP-Serialization/distinfo
new file mode 100644
index 000000000000..88b40bad24ef
--- /dev/null
+++ b/devel/p5-PHP-Serialization/distinfo
@@ -0,0 +1,3 @@
+MD5 (PHP-Serialization-0.27.tar.gz) = 2fb3f63071c5c2119b4eebe39b329684
+SHA256 (PHP-Serialization-0.27.tar.gz) = 3c740ba78649dc47929b41156e2cfc839d9136eca102db1422cf9f74252b0211
+SIZE (PHP-Serialization-0.27.tar.gz) = 4169
diff --git a/devel/p5-PHP-Serialization/pkg-descr b/devel/p5-PHP-Serialization/pkg-descr
new file mode 100644
index 000000000000..620ce3e46c39
--- /dev/null
+++ b/devel/p5-PHP-Serialization/pkg-descr
@@ -0,0 +1,9 @@
+Provides a simple, quick means of serializing perl memory structures
+(including object data!) into a format that PHP can deserialize() and
+access, and vice versa.
+
+NOTE: Converts PHP arrays into Perl Arrays when the PHP array used
+exclusively numeric indexes, and into Perl Hashes then the PHP array
+did not.
+
+WWW: http://search.cpan.org/dist/PHP-Serialization/
diff --git a/devel/p5-PHP-Serialization/pkg-plist b/devel/p5-PHP-Serialization/pkg-plist
new file mode 100644
index 000000000000..395271c476c6
--- /dev/null
+++ b/devel/p5-PHP-Serialization/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PHP/Serialization/.packlist
+%%SITE_PERL%%/PHP/Serialization.pm
+@dirrmtry %%SITE_PERL%%/PHP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PHP/Serialization
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PHP