aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-04 05:52:44 +0800
committertrevor <trevor@FreeBSD.org>2003-11-04 05:52:44 +0800
commit0288d47ca7fe7e307d6baaaf62e9ce59a1c5e89a (patch)
treec622c3fb14946030b288c1ecebc69a3e8d39abc4
parentcdb41d84fe3a2e352fdbd98107e9d1be37e80497 (diff)
downloadfreebsd-ports-gnome-0288d47ca7fe7e307d6baaaf62e9ce59a1c5e89a.tar.gz
freebsd-ports-gnome-0288d47ca7fe7e307d6baaaf62e9ce59a1c5e89a.tar.zst
freebsd-ports-gnome-0288d47ca7fe7e307d6baaaf62e9ce59a1c5e89a.zip
Fix a problem in post-patch.
noticed by: kris
-rw-r--r--audio/spiralsynth/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/audio/spiralsynth/Makefile b/audio/spiralsynth/Makefile
index 5b590feed21e..afc5f52629e9 100644
--- a/audio/spiralsynth/Makefile
+++ b/audio/spiralsynth/Makefile
@@ -16,8 +16,6 @@ COMMENT= MIDI-capable synthesizer for X
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
-BROKEN= "Does not patch on 4.x, does not compile on 5.x (bad C++ code); will be removed after Feb 2"
-
GNU_CONFIGURE= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
@@ -35,7 +33,8 @@ post-patch:
s|CFLAGS =|CFLAGS +=|g ; \
s|CXXFLAGS=|CXXFLAGS+=|g ; \
s|-lm|${PTHREAD_LIBS} -lm|g ; \
- s|/usr/X11R6|${X11BASE}|g' < ${ii}.orig > ${ii}
+ s|/usr/X11R6|${X11BASE}|g' < ${WRKSRC}/${ii}.orig \
+ > ${WRKSRC}/${ii}
.endfor
# Use as a plugin to SpiralLoops 2.0.0 results in "Can't open audio driver."
.if defined(PLUGIN)