aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-30 13:37:56 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-30 13:37:56 +0800
commit033714fa6fc5f1274c20cc82411bc63b7f59a3e7 (patch)
tree64699892902207be013d4af3684c8817dbb91deb
parentb95bd5d0b1206f9cdbe7e3c7f7feb97a51867c49 (diff)
downloadfreebsd-ports-gnome-033714fa6fc5f1274c20cc82411bc63b7f59a3e7.tar.gz
freebsd-ports-gnome-033714fa6fc5f1274c20cc82411bc63b7f59a3e7.tar.zst
freebsd-ports-gnome-033714fa6fc5f1274c20cc82411bc63b7f59a3e7.zip
- Add stage support
- Add DOCS option - Convert LIB_DEPENDS to new syntax
-rw-r--r--games/biorythm/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/games/biorythm/Makefile b/games/biorythm/Makefile
index 8962f5b5f05e..bddc17d5b5d9 100644
--- a/games/biorythm/Makefile
+++ b/games/biorythm/Makefile
@@ -9,14 +9,14 @@ MASTER_SITES= http://shh.thathost.com/pub-unix/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple biorhythm calculation program
-LIB_DEPENDS= shhmsg.1:${PORTSDIR}/devel/libshhmsg \
- shhopt.1:${PORTSDIR}/devel/libshhopt
+LIB_DEPENDS= libshhmsg.so:${PORTSDIR}/devel/libshhmsg \
+ libshhopt.so:${PORTSDIR}/devel/libshhopt
-MAN6= ${PORTNAME}.6
PORTDOCS= ChangeLog README
-PLIST_FILES= bin/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME} man/man6/${PORTNAME}.6.gz
+
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/VERSION/s|[[:space:]]"$$|\\n"| ; \
/COMPILED_DATE/d' ${WRKSRC}/biorythm.c
@@ -27,13 +27,11 @@ do-build:
-o ${PORTNAME} -L${LOCALBASE}/lib -lshhmsg -lshhopt -lm
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${MAN6PREFIX}/man/man6
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ChangeLog README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>