aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-07-15 07:18:18 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-07-15 07:18:18 +0800
commit03bccaca7495375252c5505f9a21f69cbb6e6a77 (patch)
treeb8839c78290f78670478c151325aafc3d526ba0b
parentac4a85bcf097e53e32cb070778fb90e037a73fc3 (diff)
downloadfreebsd-ports-gnome-03bccaca7495375252c5505f9a21f69cbb6e6a77.tar.gz
freebsd-ports-gnome-03bccaca7495375252c5505f9a21f69cbb6e6a77.tar.zst
freebsd-ports-gnome-03bccaca7495375252c5505f9a21f69cbb6e6a77.zip
This is an interface into HTML::SuperForm through the Template Toolkit. When
created without arguments (i.e. [% USE form = HTML.SuperForm %]), the Template's stash is searched for an Apache object or a CGI object to pass to HTML::SuperForm's constructor. When created with arguments (i.e. [% USE form = HTML.SuperForm(arg) %]), the arguments are passed to HTML::SuperForm's constructor. A dep for www/p5-Gantry Reported by: Cezary Morga <cm@therek.net>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Template-Plugin-HTML-SuperForm/Makefile26
-rw-r--r--textproc/p5-Template-Plugin-HTML-SuperForm/distinfo3
-rw-r--r--textproc/p5-Template-Plugin-HTML-SuperForm/pkg-descr7
-rw-r--r--textproc/p5-Template-Plugin-HTML-SuperForm/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d8f4c9ef745a..2f816398a1f4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -598,6 +598,7 @@
SUBDIR += p5-Template-Declare
SUBDIR += p5-Template-Extract
SUBDIR += p5-Template-Magic
+ SUBDIR += p5-Template-Plugin-HTML-SuperForm
SUBDIR += p5-Template-Plugin-Lingua-EN-Inflect
SUBDIR += p5-Template-Plugin-XML-Escape
SUBDIR += p5-Test-Perl-Critic
diff --git a/textproc/p5-Template-Plugin-HTML-SuperForm/Makefile b/textproc/p5-Template-Plugin-HTML-SuperForm/Makefile
new file mode 100644
index 000000000000..7f9ab3b68f86
--- /dev/null
+++ b/textproc/p5-Template-Plugin-HTML-SuperForm/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-Template-Plugin-HTML-SuperForm
+# Date created: 14 Jul 2009
+# Whom: Philip M. Goillucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Plugin-HTML-SuperForm
+PORTVERSION= 1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Interface Template Toolkit to Lingua::EN::Inflect module
+
+RUN_DEPENDS= p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit \
+ p5-HTML-SuperForm>0:${PORTSDIR}/textproc/p5-HTML-SuperForm
+
+PERL_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN3= Template::Plugin::HTML::SuperForm.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Template-Plugin-HTML-SuperForm/distinfo b/textproc/p5-Template-Plugin-HTML-SuperForm/distinfo
new file mode 100644
index 000000000000..d852b9cc787e
--- /dev/null
+++ b/textproc/p5-Template-Plugin-HTML-SuperForm/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Plugin-HTML-SuperForm-1.0.tar.gz) = 3ffea9b58ea965d612ba4c6536c3d009
+SHA256 (Template-Plugin-HTML-SuperForm-1.0.tar.gz) = b16d6159b7ea20f647f05979918be3204c01400caa038dc84cf7fbc8b1330af3
+SIZE (Template-Plugin-HTML-SuperForm-1.0.tar.gz) = 2157
diff --git a/textproc/p5-Template-Plugin-HTML-SuperForm/pkg-descr b/textproc/p5-Template-Plugin-HTML-SuperForm/pkg-descr
new file mode 100644
index 000000000000..951779d62390
--- /dev/null
+++ b/textproc/p5-Template-Plugin-HTML-SuperForm/pkg-descr
@@ -0,0 +1,7 @@
+This is an interface into HTML::SuperForm through the Template Toolkit. When
+created without arguments (i.e. [% USE form = HTML.SuperForm %]), the
+Template's stash is searched for an Apache object or a CGI object to pass to
+HTML::SuperForm's constructor.
+
+When created with arguments (i.e. [% USE form = HTML.SuperForm(arg) %]),
+the arguments are passed to HTML::SuperForm's constructor.
diff --git a/textproc/p5-Template-Plugin-HTML-SuperForm/pkg-plist b/textproc/p5-Template-Plugin-HTML-SuperForm/pkg-plist
new file mode 100644
index 000000000000..ebc0a468ed70
--- /dev/null
+++ b/textproc/p5-Template-Plugin-HTML-SuperForm/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Template/Plugin/HTML/SuperForm.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/HTML/SuperForm/.packlist
+@dirrmtry %%SITE_PERL%%/Template/Plugin/HTML
+@dirrmtry %%SITE_PERL%%/Template/Plugin
+@dirrmtry %%SITE_PERL%%/Template
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/HTML/SuperForm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin/HTML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Plugin