aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2011-11-29 00:22:31 +0800
committerscheidell <scheidell@FreeBSD.org>2011-11-29 00:22:31 +0800
commit0410d4d91a0bd58c13beedd0e04149c3182d8794 (patch)
tree694a55f1c6ebdca599876cd8e61a1a477151450a
parent960e8ee3b63d9870bb58e1f38c7826f081577954 (diff)
downloadfreebsd-ports-gnome-0410d4d91a0bd58c13beedd0e04149c3182d8794.tar.gz
freebsd-ports-gnome-0410d4d91a0bd58c13beedd0e04149c3182d8794.tar.zst
freebsd-ports-gnome-0410d4d91a0bd58c13beedd0e04149c3182d8794.zip
PR: 146145
Submitted by: fw@moov.de Reviewed by: scheidell Approved by: maintainer (fw@moov.de, timeout), gabor (mentor) Feature safe: yes
-rw-r--r--net-mgmt/flow-tools/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 0c51e39b49e0..18deacc6e5b7 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -14,6 +14,10 @@ MASTER_SITES= ftp://ftp.eng.oar.net/pub/flow-tools/
MAINTAINER= ports@FreeBSD.org
COMMENT= Suite of tools and library to work with netflow data
+OPTIONS= MYSQL "Enable MySQL support" off \
+ OPENSSL "Enable OpenSSL support" off \
+ PGSQL "Enable PostgreSQL support" off
+
CONFLICTS= flow-tools-ng-[0-9]*
USE_PYTHON_RUN= yes
@@ -45,6 +49,8 @@ FLOW_CAPTURE_UID= 174
FLOW_CAPTURE_GID= 174
FLOW_CAPTURE_PIDDIR= ${VARDIR}/run/flow-capture
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PGSQL)
CONFIGURE_ARGS+=--with-pgsql="${PREFIX}"
USE_PGSQL= yes
@@ -76,4 +82,4 @@ post-install:
@${SETENV} ${SCRIPTS_ENV} \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>