aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2003-01-24 05:03:14 +0800
committeranders <anders@FreeBSD.org>2003-01-24 05:03:14 +0800
commit04f952dd7fef918e16b4a1c520e7bbcf59144a88 (patch)
tree0f3b6abdcf27ecdb34160e09217c29ae9381505e
parente0cd1879d4a1bb71732baa553cc87e405b4b7f24 (diff)
downloadfreebsd-ports-gnome-04f952dd7fef918e16b4a1c520e7bbcf59144a88.tar.gz
freebsd-ports-gnome-04f952dd7fef918e16b4a1c520e7bbcf59144a88.tar.zst
freebsd-ports-gnome-04f952dd7fef918e16b4a1c520e7bbcf59144a88.zip
Use USE_REINPLACE & REINPLACE_CMD instead of PERL.
Requested by: Ulrich Spoerlein <q@uni.de>
-rw-r--r--ftp/oftpd/Makefile3
-rw-r--r--security/fpm/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/ftp/oftpd/Makefile b/ftp/oftpd/Makefile
index 11f302199b22..2e017c8fc7eb 100644
--- a/ftp/oftpd/Makefile
+++ b/ftp/oftpd/Makefile
@@ -15,6 +15,7 @@ MASTER_SITES= http://www.time-travellers.org/oftpd/ \
MAINTAINER= anders@FreeBSD.org
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
DOCFILES= README AUTHORS ChangeLog NEWS TODO BUGS
@@ -25,7 +26,7 @@ MAN8= oftpd.8
post-patch:
.if defined(MAX_NUM_CLIENTS)
- @${PERL} -pi -e "s,MAX_NUM_CLIENTS 300,MAX_NUM_CLIENTS ${MAX_NUM_CLIENTS}," ${WRKSRC}/src/oftpd.h
+ ${REINPLACE_CMD} -e "s@MAX_NUM_CLIENTS 300@MAX_NUM_CLIENTS ${MAX_NUM_CLIENTS}@" ${WRKSRC}/src/oftpd.h
.endif
do-install:
diff --git a/security/fpm/Makefile b/security/fpm/Makefile
index 19587bc78f15..6bd2b4c3ee69 100644
--- a/security/fpm/Makefile
+++ b/security/fpm/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= anders@FreeBSD.org
USE_GNOME= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
SOURCEFILES= main.c fpm.c support.c interface.c passfile.c callbacks.c \
blowfish.c fpm_crypt.c fpm_gpw.c md5.c fpm_clist.c fpm_pref.c
@@ -26,7 +27,7 @@ GNOME_LIBS?= `${GNOME_CONFIG} --libs gnomeui` \
CFLAGS+= -DHAVE_CONFIG_H -I. -I.. ${GNOME_CFLAGS}
pre-build:
- ${PERL} -pi -e "s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
+ ${REINPLACE_CMD} -E -e ""s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
do-build:
.for f in ${SOURCEFILES}