aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-14 18:16:23 +0800
committermaho <maho@FreeBSD.org>2007-07-14 18:16:23 +0800
commit05d88f2633adf633123f85f3fb8e7ec363e0e7a3 (patch)
tree0dce235e020a8333903d895cf0f91637b55d63b4
parent29749ee36b33d0e01549595fb08445ccfc765158 (diff)
downloadfreebsd-ports-gnome-05d88f2633adf633123f85f3fb8e7ec363e0e7a3.tar.gz
freebsd-ports-gnome-05d88f2633adf633123f85f3fb8e7ec363e0e7a3.tar.zst
freebsd-ports-gnome-05d88f2633adf633123f85f3fb8e7ec363e0e7a3.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
-rw-r--r--science/abinit/Makefile6
-rw-r--r--science/dft++/Makefile5
2 files changed, 2 insertions, 9 deletions
diff --git a/science/abinit/Makefile b/science/abinit/Makefile
index 7e95e9dc664d..204259e294a0 100644
--- a/science/abinit/Makefile
+++ b/science/abinit/Makefile
@@ -14,12 +14,8 @@ MASTER_SITES= ${MASTER_SITE_LOCAL:S|%SUBDIR%|maho/abinit|} \
MAINTAINER= maho@FreeBSD.org
COMMENT= Abinit calculates electronic structure of systems
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:259
diff --git a/science/dft++/Makefile b/science/dft++/Makefile
index ae12be000dda..6421944150ab 100644
--- a/science/dft++/Makefile
+++ b/science/dft++/Makefile
@@ -27,10 +27,7 @@ LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FORTRANLIBS= -lgfortranbegin -lgfortran
GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..