aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2008-05-20 06:50:40 +0800
committerflz <flz@FreeBSD.org>2008-05-20 06:50:40 +0800
commit07500ed5b00bd27d0c60b7ae13ef4ab0cadc8c90 (patch)
treeb55ea024a5a5d0cc258635088b553d62a1382d60
parent1fb5b345539d4fb4819fdafbd54abdbc01bc8787 (diff)
downloadfreebsd-ports-gnome-07500ed5b00bd27d0c60b7ae13ef4ab0cadc8c90.tar.gz
freebsd-ports-gnome-07500ed5b00bd27d0c60b7ae13ef4ab0cadc8c90.tar.zst
freebsd-ports-gnome-07500ed5b00bd27d0c60b7ae13ef4ab0cadc8c90.zip
Add GvGen, an easy python interface to generate dot files.
PR: ports/123776 Submitted by: Sofian Brabez <sbrabez@gmail.com>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-gvgen/Makefile32
-rw-r--r--graphics/py-gvgen/distinfo3
-rw-r--r--graphics/py-gvgen/pkg-descr4
-rw-r--r--graphics/py-gvgen/pkg-message13
-rw-r--r--graphics/py-gvgen/pkg-plist3
6 files changed, 56 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 880244a63ae8..046f7b9e032e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -630,6 +630,7 @@
SUBDIR += py-glewpy
SUBDIR += py-goocanvas
SUBDIR += py-graphviz
+ SUBDIR += py-gvgen
SUBDIR += py-imaging
SUBDIR += py-ming
SUBDIR += py-opengl
diff --git a/graphics/py-gvgen/Makefile b/graphics/py-gvgen/Makefile
new file mode 100644
index 000000000000..ed67225c5f0e
--- /dev/null
+++ b/graphics/py-gvgen/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-gvgen
+# Date created: 19 May 2008
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gvgen
+PORTVERSION= 0.9
+CATEGORIES= graphics python
+MASTER_SITES= http://software.inl.fr/releases/GvGen/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= An easy python interface to generate dot files
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS=easy-install
+PYDISTUTILS_PKGVERSION= 0.9
+PYDISTUTILS_EGGINFO= GvGen-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
+PORTDOCS= user-guide.tex.lyx
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gvgen/distinfo b/graphics/py-gvgen/distinfo
new file mode 100644
index 000000000000..ce12af655a19
--- /dev/null
+++ b/graphics/py-gvgen/distinfo
@@ -0,0 +1,3 @@
+MD5 (gvgen-0.9.tar.gz) = 70a5bd64e2de53988d7ffabc93aebf27
+SHA256 (gvgen-0.9.tar.gz) = cc9f21be92d68bae3c2df7749abc5cc0fc6f8ce76b04fa07c477a6f8862e56bb
+SIZE (gvgen-0.9.tar.gz) = 27292
diff --git a/graphics/py-gvgen/pkg-descr b/graphics/py-gvgen/pkg-descr
new file mode 100644
index 000000000000..cd46c9d3e645
--- /dev/null
+++ b/graphics/py-gvgen/pkg-descr
@@ -0,0 +1,4 @@
+GvGen is a python class to generate dot files for further use with
+graphviz.
+
+WWW: http://software.inl.fr/trac/wiki/GvGen
diff --git a/graphics/py-gvgen/pkg-message b/graphics/py-gvgen/pkg-message
new file mode 100644
index 000000000000..181d1e66c118
--- /dev/null
+++ b/graphics/py-gvgen/pkg-message
@@ -0,0 +1,13 @@
+-------------------------------------------------------------
+GvGen is installed.
+
+For a quick start:
+ - read the user_guide.tex.lyx
+ - create dot file ./yourgraph.py > gourgraph.dot
+ - generate graph dot -Tpng yourgraph.dot > yourgraph.png
+
+Generate your graph require the graphics/graphviz port to be
+installed.
+
+Review the ChangeLog document in the documentation directory.
+-------------------------------------------------------------
diff --git a/graphics/py-gvgen/pkg-plist b/graphics/py-gvgen/pkg-plist
new file mode 100644
index 000000000000..d4fa21beb8c2
--- /dev/null
+++ b/graphics/py-gvgen/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/gvgen.py
+%%PYTHON_SITELIBDIR%%/gvgen.pyc
+%%PYTHON_SITELIBDIR%%/gvgen.pyo