aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-06-21 19:48:01 +0800
committeredwin <edwin@FreeBSD.org>2006-06-21 19:48:01 +0800
commit084ae98201a78f1eddf0e919acfb286c1f519a5b (patch)
tree33742fd046efe8d327afee1b312a5e6fb45e2a5a
parent3dae3fdc551fc8a345652bab2420faf939874d5c (diff)
downloadfreebsd-ports-gnome-084ae98201a78f1eddf0e919acfb286c1f519a5b.tar.gz
freebsd-ports-gnome-084ae98201a78f1eddf0e919acfb286c1f519a5b.tar.zst
freebsd-ports-gnome-084ae98201a78f1eddf0e919acfb286c1f519a5b.zip
ports/aaccli fails to install on 6.x [patch]
The POST-INSTALL script of the binary package tries to execute MAKEDEV which is a no-op on 5.x, but nonsense on 6.x and above: PR: ports/99237 Submitted by: Helge Oldach <aacclijun06@oldach.net>
-rw-r--r--sysutils/aaccli/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/sysutils/aaccli/Makefile b/sysutils/aaccli/Makefile
index 792e4bcb2fab..66ec7b916952 100644
--- a/sysutils/aaccli/Makefile
+++ b/sysutils/aaccli/Makefile
@@ -28,13 +28,17 @@ MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
NO_BUILD= yes
NO_WRKSUBDIR= yes
-UNZIP= unzip
+.include <bsd.port.pre.mk>
do-extract:
${MKDIR} ${WRKSRC}
- cd ${WRKSRC} && ${UNZIP} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+ cd ${WRKSRC} && ${UNZIP_CMD} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+
+.if ${OSVERSION} >= 600000
+IGNORE_POST_INSTALL= I
+.endif
do-install:
- ${PKG_ADD} -R ${WRKSRC}/${PKGNAME}_${PORTREVISION}.tgz
+ ${PKG_ADD} -R${IGNORE_POST_INSTALL} ${WRKSRC}/${PKGNAME}_${PORTREVISION}.tgz
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>