aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-20 15:53:53 +0800
committerjhale <jhale@FreeBSD.org>2012-10-20 15:53:53 +0800
commit099d49dda1390383c4d77d0b6d26d9c1a0ef807c (patch)
tree3fe9c093413d1ee33b2b44f1a77db58d2e5c117e
parent0552830152284df363debb98ed553429303d6e32 (diff)
downloadfreebsd-ports-gnome-099d49dda1390383c4d77d0b6d26d9c1a0ef807c.tar.gz
freebsd-ports-gnome-099d49dda1390383c4d77d0b6d26d9c1a0ef807c.tar.zst
freebsd-ports-gnome-099d49dda1390383c4d77d0b6d26d9c1a0ef807c.zip
- Add upstream patch to fix CPU consumption and termination bug
http://code.google.com/p/munge/issues/detail?id=18 - Bump PORTREVISION since runtime behavior will change While here: - Trim Makefile header - Remove indefinite article from COMMENT PR: ports/172856 Submitted by: Loic Pefferkorn <loic-freebsd@loicp.eu> Approved by: maintainer makc, avilla (mentors, implicit) Feature safe: yes
-rw-r--r--security/munge/Makefile9
-rw-r--r--security/munge/files/patch-src-munged-xgetgrent.c11
2 files changed, 14 insertions, 6 deletions
diff --git a/security/munge/Makefile b/security/munge/Makefile
index ba970607f240..1c71e57d3815 100644
--- a/security/munge/Makefile
+++ b/security/munge/Makefile
@@ -1,17 +1,14 @@
-# New ports collection makefile for: munge
-# Date created: 2012-03-18
-# Whom: Muhammad Moinur Rahman <5u623l20@gmail.com>
-#
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
# $FreeBSD$
-#
PORTNAME= munge
PORTVERSION= 0.5.10
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GOOGLE_CODE
MAINTAINER= 5u623l20@gmail.com
-COMMENT= An authentication service for creating and validating credentials
+COMMENT= Authentication service for creating and validating credentials
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/security/munge/files/patch-src-munged-xgetgrent.c b/security/munge/files/patch-src-munged-xgetgrent.c
new file mode 100644
index 000000000000..f0c10632a828
--- /dev/null
+++ b/security/munge/files/patch-src-munged-xgetgrent.c
@@ -0,0 +1,11 @@
+--- src/munged/xgetgrent.c.orig 2012-10-18 16:42:46.000000000 +0200
++++ src/munged/xgetgrent.c 2012-10-18 16:43:17.000000000 +0200
+@@ -194,7 +194,7 @@
+
+ #if HAVE_GETGRENT_R_GNU
+ rv = getgrent_r (gr, buf, buflen, &gr_ptr);
+- if (rv == ENOENT) {
++ if (((rv == ENOENT) || (rv == 0)) && (gr_ptr == NULL)) {
+ got_eof = 1;
+ }
+ else if (rv != 0) {