aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-02 06:16:32 +0800
committermiwi <miwi@FreeBSD.org>2008-11-02 06:16:32 +0800
commit09a4563345430f5b3ae9daae8770b471fb7cdaec (patch)
treeafad40dd239d21aa06b908a7e089fe2b46b61825
parentc4e7910eb436b4f16ee9376a83446f17d975cc2d (diff)
downloadfreebsd-ports-gnome-09a4563345430f5b3ae9daae8770b471fb7cdaec.tar.gz
freebsd-ports-gnome-09a4563345430f5b3ae9daae8770b471fb7cdaec.tar.zst
freebsd-ports-gnome-09a4563345430f5b3ae9daae8770b471fb7cdaec.zip
The ruby-ole library provides a variety of functions primarily for
working with OLE2 structured storage files, such as those produced by Microsoft Office - eg *.doc, *.msg etc. WWW: http://rubyforge.org/projects/ruby-ole PR: ports/128471 Submitted by: Alexander Logvinov <ports at logvinov.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-ruby-ole/Makefile28
-rw-r--r--devel/rubygem-ruby-ole/distinfo3
-rw-r--r--devel/rubygem-ruby-ole/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e98e9b3e2569..e0a5f43d0e52 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2431,6 +2431,7 @@
SUBDIR += rubygem-rubigen
SUBDIR += rubygem-ruby-debug
SUBDIR += rubygem-ruby-debug-base
+ SUBDIR += rubygem-ruby-ole
SUBDIR += rubygem-ruby-prof
SUBDIR += rubygem-ruby2ruby
SUBDIR += rubygem-rubyforge
diff --git a/devel/rubygem-ruby-ole/Makefile b/devel/rubygem-ruby-ole/Makefile
new file mode 100644
index 000000000000..3b3588766a42
--- /dev/null
+++ b/devel/rubygem-ruby-ole/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rubygem-ruby-ole
+# Date created: 30 October 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ruby-ole
+PORTVERSION= 1.2.8.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A library for easy read/write access to OLE compound documents for Ruby
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+post-install:
+ @${ECHO} bin/oletool > ${TMPPLIST}
+ @${ECHO} ${GEM_CACHE} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruby-ole/distinfo b/devel/rubygem-ruby-ole/distinfo
new file mode 100644
index 000000000000..7b00707cf459
--- /dev/null
+++ b/devel/rubygem-ruby-ole/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/ruby-ole-1.2.8.1.gem) = 9ae82141c1f0e7b45d3275259546f5c4
+SHA256 (rubygem/ruby-ole-1.2.8.1.gem) = a06c2e6337d713f31f4223227837f3f6c29d0cee58c6d59d7652cf91098673b5
+SIZE (rubygem/ruby-ole-1.2.8.1.gem) = 56832
diff --git a/devel/rubygem-ruby-ole/pkg-descr b/devel/rubygem-ruby-ole/pkg-descr
new file mode 100644
index 000000000000..6912ed5fad10
--- /dev/null
+++ b/devel/rubygem-ruby-ole/pkg-descr
@@ -0,0 +1,5 @@
+The ruby-ole library provides a variety of functions primarily for
+working with OLE2 structured storage files, such as those produced by
+Microsoft Office - eg *.doc, *.msg etc.
+
+WWW: http://rubyforge.org/projects/ruby-ole