aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-07-22 21:47:14 +0800
committerkrion <krion@FreeBSD.org>2003-07-22 21:47:14 +0800
commit0aff51d0fb533e764cf13ae847acc457b7ad3afc (patch)
tree40a0dcc2cf32f40de320cec4224497abc8d9a498
parentc9550ebc9bb2cf77f6d9fe56a2ae5b5278cc565f (diff)
downloadfreebsd-ports-gnome-0aff51d0fb533e764cf13ae847acc457b7ad3afc.tar.gz
freebsd-ports-gnome-0aff51d0fb533e764cf13ae847acc457b7ad3afc.tar.zst
freebsd-ports-gnome-0aff51d0fb533e764cf13ae847acc457b7ad3afc.zip
New port databases/p5-Data-Page
When searching through large amounts of data, it is often the case that a result set is returned that is larger than we want to display on one page. This results in wanting to page through various pages of data. The maths behind this is unfortunately fiddly, hence this module. PR: 54720 Submitted by: Mathieu Arnold <m@absolight.net> Approved by: fjoe (mentor)
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Data-Page/Makefile24
-rw-r--r--databases/p5-Data-Page/distinfo1
-rw-r--r--databases/p5-Data-Page/pkg-descr11
-rw-r--r--databases/p5-Data-Page/pkg-plist4
5 files changed, 41 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 317604e5a984..56308899a5a0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -82,6 +82,7 @@
SUBDIR += p5-CDB_File-Generator
SUBDIR += p5-Class-DBI
SUBDIR += p5-Class-DBI-AbstractSearch
+ SUBDIR += p5-Data-Page
SUBDIR += p5-DBD-CSV
SUBDIR += p5-DBD-Excel
SUBDIR += p5-DBD-InterBase
diff --git a/databases/p5-Data-Page/Makefile b/databases/p5-Data-Page/Makefile
new file mode 100644
index 000000000000..5ab90598296a
--- /dev/null
+++ b/databases/p5-Data-Page/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Data-Page
+# Date created: 21 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Page
+PORTVERSION= 0.18
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Pager utility for Class::DBI
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Page.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Data-Page/distinfo b/databases/p5-Data-Page/distinfo
new file mode 100644
index 000000000000..a35bf40a5b29
--- /dev/null
+++ b/databases/p5-Data-Page/distinfo
@@ -0,0 +1 @@
+MD5 (Data-Page-0.18.tar.gz) = 5c96f57fdd52413dd2da4844c60ef756
diff --git a/databases/p5-Data-Page/pkg-descr b/databases/p5-Data-Page/pkg-descr
new file mode 100644
index 000000000000..772049b3695b
--- /dev/null
+++ b/databases/p5-Data-Page/pkg-descr
@@ -0,0 +1,11 @@
+When searching through large amounts of data, it is often the case that a
+result set is returned that is larger than we want to display on one page. This
+results in wanting to page through various pages of data. The maths behind this
+is unfortunately fiddly, hence this module.
+
+The main concept is that you pass in the number of total entries, the number of
+entries per page, and the current page number. You can then call methods to
+find out how many pages of information there are, and what number the first and
+last entries on the current page really are.
+
+WWW: http://search.cpan.org/dist/Data-Page/
diff --git a/databases/p5-Data-Page/pkg-plist b/databases/p5-Data-Page/pkg-plist
new file mode 100644
index 000000000000..5f82467766a0
--- /dev/null
+++ b/databases/p5-Data-Page/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Data/Page.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data-Page/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data-Page
+@unexec rmdir %D/%%SITE_PERL%%/Data 2>/dev/null || true