aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-10-19 03:13:07 +0800
committerak <ak@FreeBSD.org>2012-10-19 03:13:07 +0800
commit0b4864326dab5479c483e060eba2342f1b3af4e6 (patch)
treecec8b62f350d829f9f917b7fbb9bf826eec205d1
parente1a742059bc2f2c3dee1cfb34ef8047f5face2f1 (diff)
downloadfreebsd-ports-gnome-0b4864326dab5479c483e060eba2342f1b3af4e6.tar.gz
freebsd-ports-gnome-0b4864326dab5479c483e060eba2342f1b3af4e6.tar.zst
freebsd-ports-gnome-0b4864326dab5479c483e060eba2342f1b3af4e6.zip
- Convert Makefile headers to new style
- Stop overwriting configuration file during installation [1] - Remove support for 7-CURRENT - Use REINPLACE_CMD instead of patch file. - Reset to ports@ by request of maintainer - Bump PORTREVISION PR: ports/171638 (based on) [1] Submitted by: Andrey Simonenko <simon@comsys.ntu-kpi.kiev.ua> [1] Approved by: Patrick MARIE <mycroft@virgaria.org> (maintainer) Feature safe: yes
-rw-r--r--net/proxychains/Makefile24
-rw-r--r--net/proxychains/files/gethostbyaddr-proto-int12
-rw-r--r--net/proxychains/files/patch-proxychains-Makefile.in11
-rw-r--r--net/proxychains/pkg-plist4
4 files changed, 17 insertions, 34 deletions
diff --git a/net/proxychains/Makefile b/net/proxychains/Makefile
index 525439c720bf..1dd6f4d71721 100644
--- a/net/proxychains/Makefile
+++ b/net/proxychains/Makefile
@@ -1,27 +1,31 @@
-# New ports collection makefile for: proxychains
-# Date created: 14 jui 2003
-# Whom: Patrick MARIE <mycroft@virgaria.org>
+# Created by: Patrick MARIE <mycroft@virgaria.org>
# $FreeBSD$
PORTNAME= proxychains
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/version%20${PORTVERSION}
-MAINTAINER= mycroft@virgaria.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Redirect connection through proxy servers
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700017
-EXTRA_PATCHES= ${PATCHDIR}/gethostbyaddr-proto-int
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's!$$(srcdir)/proxychains.conf!$$(srcdir)/proxychains.conf.sample!' \
+ -e 's!libproxychains_la_LIBADD = -ldl!libproxychains_la_LIBADD =!' \
+ ${WRKSRC}/proxychains/Makefile.in
+ @${MV} ${WRKSRC}/proxychains/proxychains.conf \
+ ${WRKSRC}/proxychains/proxychains.conf.sample
post-configure:
@${ECHO_CMD} '#define PREFIX "${PREFIX}"' >> ${WRKSRC}/config.h
-.include <bsd.port.post.mk>
+post-install:
+ @[ -f ${PREFIX}/etc/proxychains.conf ] || ${CP} ${PREFIX}/etc/proxychains.conf.sample \
+ ${PREFIX}/etc/proxychains.conf
+
+.include <bsd.port.mk>
diff --git a/net/proxychains/files/gethostbyaddr-proto-int b/net/proxychains/files/gethostbyaddr-proto-int
deleted file mode 100644
index 1acdd8b89737..000000000000
--- a/net/proxychains/files/gethostbyaddr-proto-int
+++ /dev/null
@@ -1,12 +0,0 @@
---- proxychains/libproxychains.c Wed Mar 15 18:16:59 2006
-+++ proxychains/libproxychains.c Thu Dec 7 15:34:57 2006
-@@ -308,8 +308,7 @@
- PDEBUG("getnameinfo: %s %s\n", host, serv);
- return ret;
- }
--struct hostent *gethostbyaddr (const void *addr, socklen_t len,
-- int type)
-+struct hostent *gethostbyaddr (const void *addr, int len, int type)
- {
- PDEBUG("TODO: gethostbyaddr hook\n");
- if(!init_l)
diff --git a/net/proxychains/files/patch-proxychains-Makefile.in b/net/proxychains/files/patch-proxychains-Makefile.in
deleted file mode 100644
index 8e0977ff1059..000000000000
--- a/net/proxychains/files/patch-proxychains-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- proxychains/Makefile.in.old Sat Dec 9 23:46:05 2006
-+++ proxychains/Makefile.in Sat Dec 9 23:48:44 2006
-@@ -105,7 +105,7 @@
- #proxychains_LDFLAGS = $(all_libraries)
- lib_LTLIBRARIES = libproxychains.la
- libproxychains_la_LDFLAGS = -version-info 3:0:0 $(all_libraries)
--libproxychains_la_LIBADD = -ldl
-+libproxychains_la_LIBADD =
- noinst_HEADERS = core.h
- libproxychains_la_SOURCES = libproxychains.c core.c
- libproxychains_la_METASOURCES = USE_AUTOMOC
diff --git a/net/proxychains/pkg-plist b/net/proxychains/pkg-plist
index 77b2504635a2..b588e00f7931 100644
--- a/net/proxychains/pkg-plist
+++ b/net/proxychains/pkg-plist
@@ -1,6 +1,8 @@
bin/proxychains
bin/proxyresolv
-etc/proxychains.conf
+@unexec if cmp -s %D/etc/proxychains.conf %D/etc/proxychains.conf.sample; then rm -f %D/etc/proxychains.conf; fi
+etc/proxychains.conf.sample
+@exec [ -f %D/etc/proxychains.conf ] || cp %D/etc/proxychains.conf.sample %D/etc/proxychains.conf
lib/libproxychains.so.3
lib/libproxychains.so
lib/libproxychains.la