aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2011-11-03 08:38:47 +0800
committereadler <eadler@FreeBSD.org>2011-11-03 08:38:47 +0800
commit0c08d04419e99750482d6da3325eea7ad9895992 (patch)
tree2669028add45affcb408ace21d1b7157d0a513cf
parente4f439afd6a7cf8b604c0bcfbffcec6769999829 (diff)
downloadfreebsd-ports-gnome-0c08d04419e99750482d6da3325eea7ad9895992.tar.gz
freebsd-ports-gnome-0c08d04419e99750482d6da3325eea7ad9895992.tar.zst
freebsd-ports-gnome-0c08d04419e99750482d6da3325eea7ad9895992.zip
- fix explicit use of unzip in ports
PR: ports/153429 Submitted by: Alex Kozlov <spam@rm-rf.kiev.ua> Approved by: maintainers (hq, gabor, amdmi3) Approved by: maintainer timeout Approved by: bapt,sahil (mentors, implicit)
-rw-r--r--devel/ros-nxt/Makefile2
-rw-r--r--emulators/vmsbackup/Makefile2
-rw-r--r--games/sdb/Makefile2
-rw-r--r--games/uhexen/Makefile2
-rw-r--r--misc/mc/Makefile2
-rw-r--r--textproc/docbook-xml/Makefile2
-rw-r--r--textproc/sdocbook-xml/Makefile2
-rw-r--r--www/pebble/Makefile2
8 files changed, 8 insertions, 8 deletions
diff --git a/devel/ros-nxt/Makefile b/devel/ros-nxt/Makefile
index e2e21d6faf4d..1880176f3e1b 100644
--- a/devel/ros-nxt/Makefile
+++ b/devel/ros-nxt/Makefile
@@ -66,7 +66,7 @@ post-extract:
${CP} ${_DISTDIR}/nxt-python-1.1.2.zip ${WRKSRC}/nxt_python/build
# already extract and mark as such because we have to patch it
(cd ${WRKSRC}/nxt_python/build ; \
- ${LOCALBASE}/bin/unzip -q nxt-python-1.1.2.zip ; \
+ ${UNZIP_CMD} -q nxt-python-1.1.2.zip ; \
${TOUCH} nxt-python-1.1.2/unpacked)
# remove nxt_rviz_plugin, it is unbuildable right now
# and keeping it here breaks rospack
diff --git a/emulators/vmsbackup/Makefile b/emulators/vmsbackup/Makefile
index 80b946cb1b3f..e0164035d48e 100644
--- a/emulators/vmsbackup/Makefile
+++ b/emulators/vmsbackup/Makefile
@@ -26,7 +26,7 @@ MANCOMPRESSED= no
do-extract:
${MKDIR} ${WRKSRC}
- unzip ${DISTDIR}/${DISTNAME} -d ${WRKSRC}
+ ${UNZIP_CMD} ${DISTDIR}/${DISTNAME} -d ${WRKSRC}
post-patch:
@${REINPLACE_CMD} -e 's#gets(ans);#fgets(ans, 80, stdin);#' ${WRKSRC}/vmsbackup.c
diff --git a/games/sdb/Makefile b/games/sdb/Makefile
index 4178b569443d..64fd57d91083 100644
--- a/games/sdb/Makefile
+++ b/games/sdb/Makefile
@@ -43,7 +43,7 @@ post-extract:
${RM} ${WRKSRC}/models/*
@cd ${WRKSRC}/models && \
${RM} -f * && \
- unzip -qj ${DISTDIR}/shotgun-debugger-1.0.mac-ppc.zip \
+ ${UNZIP_CMD} -qj ${DISTDIR}/shotgun-debugger-1.0.mac-ppc.zip \
'sdb-1.0-macosx/models/*.md2b'
.endif
diff --git a/games/uhexen/Makefile b/games/uhexen/Makefile
index 5b8eb5a50ad6..f66400466b6c 100644
--- a/games/uhexen/Makefile
+++ b/games/uhexen/Makefile
@@ -43,7 +43,7 @@ PLIST_DIRS= %%DATADIR%%
post-extract:
.if !defined(WITHOUT_WAD)
- @${LOCALBASE}/bin/unzip -qo ${DISTDIR}/hexen.zip \
+ @${UNZIP_CMD} -qo ${DISTDIR}/hexen.zip \
-d ${WRKSRC}
.endif
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 35184f7a3050..da71619cf187 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -27,7 +27,7 @@ USE_GNOME= glib20
USE_PERL5= yes
USE_XZ= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= ZIP=${LOCALBASE}/bin/zip UNZIP=${LOCALBASE}/bin/unzip
+CONFIGURE_ENV= ZIP=${UNZIP_CMD} UNZIP=${UNZIP_CMD}
USE_AUTOTOOLS= libtool
OPTIONS= SLANG "Build with SLang library" on \
diff --git a/textproc/docbook-xml/Makefile b/textproc/docbook-xml/Makefile
index 5261a3d24cb7..fb2d1d2fa576 100644
--- a/textproc/docbook-xml/Makefile
+++ b/textproc/docbook-xml/Makefile
@@ -36,7 +36,7 @@ pre-su-install:
@[ -d ${DOCBOOKDIR}/ent ] || ${MKDIR} ${DOCBOOKDIR}/ent
do-install:
- for file in `unzip -l ${DISTDIR}/${DISTFILES}|${AWK} '/:[0-9].*[^\/]$$/{print $$4}'`; do \
+ for file in `${UNZIP_CMD} -l ${DISTDIR}/${DISTFILES}|${AWK} '/:[0-9].*[^\/]$$/{print $$4}'`; do \
${INSTALL_DATA} ${WRKSRC}/$$file ${DOCBOOKDIR}/$$file; \
done
diff --git a/textproc/sdocbook-xml/Makefile b/textproc/sdocbook-xml/Makefile
index 5039a5eb78ba..ad28ac86250d 100644
--- a/textproc/sdocbook-xml/Makefile
+++ b/textproc/sdocbook-xml/Makefile
@@ -37,7 +37,7 @@ FILES= sdbcent.mod sdbhier.mod sdbpool.mod sdocbook-custom.dtd \
do-extract:
${MKDIR} ${WRKDIR}; \
- (cd ${WRKDIR} && unzip -oq ${DISTDIR}/${DISTFILES})
+ (cd ${WRKDIR} && ${UNZIP_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${DISTFILES})
post-patch:
${SED} -e 's#@@DTDDIR@@#${SDOCBOOKDIR}#' < ${FILESDIR}/catalog.xml > ${WRKSRC}/catalog.xml
diff --git a/www/pebble/Makefile b/www/pebble/Makefile
index ca00043da181..a1e4513ccdd0 100644
--- a/www/pebble/Makefile
+++ b/www/pebble/Makefile
@@ -42,7 +42,7 @@ PLIST_FILES= ${WEBAPP_SUBDIR}/${PORTNAME}.war
PEBBLE_CONTEXT= WEB-INF/applicationContext-pebble.xml
do-patch:
- cd ${WRKSRC} && ${LOCALBASE}/bin/unzip -o pebble.war "${PEBBLE_CONTEXT}"
+ cd ${WRKSRC} && ${UNZIP_CMD} -o pebble.war "${PEBBLE_CONTEXT}"
${SED} -i.bak 's,/WEB-INF/pebble\.properties,file:${PEBBLE_PROPERTIES},' "${WRKSRC}/${PEBBLE_CONTEXT}"
cd ${WRKSRC} && ${LOCALBASE}/bin/zip -u pebble.war ${PEBBLE_CONTEXT}