aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-19 01:24:14 +0800
committerpgj <pgj@FreeBSD.org>2012-02-19 01:24:14 +0800
commit0caa5b6603048afa3631f12652adcd5fc941a83e (patch)
tree5788fda233b1c84c67bf0027ea8e2fbe8ab375bb
parentef3aee711c133bdf866b52a7038fccb281ff7a45 (diff)
downloadfreebsd-ports-gnome-0caa5b6603048afa3631f12652adcd5fc941a83e.tar.gz
freebsd-ports-gnome-0caa5b6603048afa3631f12652adcd5fc941a83e.tar.zst
freebsd-ports-gnome-0caa5b6603048afa3631f12652adcd5fc941a83e.zip
This library provides just the general interface and helper functions.
You must use a specific backend in order to make this useful. WWW: http://www.yesodweb.com/book/persistent Obtained from: FreeBSD Haskell
-rw-r--r--databases/Makefile1
-rw-r--r--databases/hs-persistent/Makefile22
-rw-r--r--databases/hs-persistent/distinfo2
-rw-r--r--databases/hs-persistent/pkg-descr4
-rw-r--r--lang/ghc/bsd.hackage.mk1
5 files changed, 30 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 90661e85f602..1deaabdf94fd 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -104,6 +104,7 @@
SUBDIR += hiredis
SUBDIR += hk_classes
SUBDIR += hs-mysql
+ SUBDIR += hs-persistent
SUBDIR += hsqldb
SUBDIR += hypertable
SUBDIR += innobackup
diff --git a/databases/hs-persistent/Makefile b/databases/hs-persistent/Makefile
new file mode 100644
index 000000000000..1c810a73bc8f
--- /dev/null
+++ b/databases/hs-persistent/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-persistent
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= persistent
+PORTVERSION= 0.6.4.4
+CATEGORIES= databases haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Type-safe, non-relational, multi-backend persistence
+
+LICENSE= BSD
+
+USE_CABAL= blaze-html>=0.4 data-object>=0.3.1.7 enumerator>=0.4.9 \
+ monad-control>=0.2 mtl>=2.0 path-pieces pool>=0.1 \
+ text>=0.8 transformers>=0.2.1 transformers-base
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/databases/hs-persistent/distinfo b/databases/hs-persistent/distinfo
new file mode 100644
index 000000000000..6b187add5fbe
--- /dev/null
+++ b/databases/hs-persistent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/persistent-0.6.4.4.tar.gz) = fb3de60b2ba4209dbbdc2feca776dbae89f9dcf17102f634bfe3568b32a09f58
+SIZE (cabal/persistent-0.6.4.4.tar.gz) = 17577
diff --git a/databases/hs-persistent/pkg-descr b/databases/hs-persistent/pkg-descr
new file mode 100644
index 000000000000..fe71a91f78e6
--- /dev/null
+++ b/databases/hs-persistent/pkg-descr
@@ -0,0 +1,4 @@
+This library provides just the general interface and helper functions.
+You must use a specific backend in order to make this useful.
+
+WWW: http://www.yesodweb.com/book/persistent
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index b3d7fa5052ad..dc7f3675c8b4 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -191,6 +191,7 @@ parsec_port= textproc/hs-parsec
path-pieces_port= www/hs-path-pieces
pcap_port= net/hs-pcap
pcre-light_port= devel/hs-pcre-light # lib_depends
+persistent_port= databases/hs-persistent
polyparse_port= textproc/hs-polyparse
pointed_port= math/hs-pointed
pool_port= devel/hs-pool