aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-07-08 04:45:27 +0800
committermm <mm@FreeBSD.org>2011-07-08 04:45:27 +0800
commit0cf5acad9b4dfdce315eb89b6c30ca4e4f43f57f (patch)
treef684dd5694f064681d455c3453e7d65918b20bcb
parent4eee9954ee3d0c8dd9a4fd2afd2c2f0ed5fb4a9d (diff)
downloadfreebsd-ports-gnome-0cf5acad9b4dfdce315eb89b6c30ca4e4f43f57f.tar.gz
freebsd-ports-gnome-0cf5acad9b4dfdce315eb89b6c30ca4e4f43f57f.tar.zst
freebsd-ports-gnome-0cf5acad9b4dfdce315eb89b6c30ca4e4f43f57f.zip
Update to the new horde4 framework.
Approved by: beech (maintainer, private chat)
-rw-r--r--devel/horde4-content/Makefile48
-rw-r--r--devel/horde4-content/distinfo4
-rw-r--r--devel/horde4-content/files/pkg-message.in7
-rw-r--r--devel/horde4-content/pkg-plist36
4 files changed, 19 insertions, 76 deletions
diff --git a/devel/horde4-content/Makefile b/devel/horde4-content/Makefile
index 854a9db6edd3..99ec0931887e 100644
--- a/devel/horde4-content/Makefile
+++ b/devel/horde4-content/Makefile
@@ -7,39 +7,25 @@
PORTNAME= content
PORTVERSION= 1.0.0
-DISTVERSIONPREFIX=
-DISTVERSIONSUFFIX=
-CATEGORIES= devel www
-MASTER_SITES= http://pear.horde.org/get/ \
- LOCAL/beech
-PKGNAMEPREFIX= horde4-
-DISTNAME= content-${PORTVERSION}
-EXTRACT_SUFX= .tgz
+CATEGORIES= devel www pear
+PKGNAMEPREFIX= horde-
-MAINTAINER= beech@FreeBSD.org
+MAINTAINER= mm@FreeBSD.org
COMMENT= Horde tagging application
-BROKEN= Rewrite in progress
-USE_HORDE= base
-USE_GETTEXT= yes
+CONFLICTS= horde-3*
-post-extract:
- @${MKDIR} ${WRKSRC}/config && ${TOUCH} ${WRKSRC}/config/placeholder.dist
+USE_PHP= gettext
+USE_HORDE_BUILD= Horde_Role
+USE_HORDE_RUN= Horde_Role \
+ Horde_Core \
+ Horde_Date \
+ Horde_Exception \
+ Horde_Db \
+ Horde_Injector \
+ Horde_Rdo \
+ Horde_Util
-do-install:
- @${INSTALL} -d ${HORDIR}/
-# @${CP} ${WRKSRC}/lib/Horde/content.php ${HORBAS}/
- @${CP} -Rp ${WRKSRC}/app/ ${HORDIR}/
- @${CP} -Rp ${WRKSRC}/config/ ${HORDIR}/
- @${CP} -Rp ${WRKSRC}/lib/ ${HORDIR}/
- @${CP} -Rp ${WRKSRC}/migration/ ${HORDIR}/
- @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
- @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
-
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-
-.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/horde4-content/distinfo b/devel/horde4-content/distinfo
index c7b63dbf4995..38bd021f2e55 100644
--- a/devel/horde4-content/distinfo
+++ b/devel/horde4-content/distinfo
@@ -1,2 +1,2 @@
-SHA256 (content-1.0.0.tgz) = b4ec6c971118a3274b85d8b6407576e3f7bba70b3fbbf3f823854839b61049d8
-SIZE (content-1.0.0.tgz) = 18025
+SHA256 (Horde/content-1.0.0.tgz) = b4ec6c971118a3274b85d8b6407576e3f7bba70b3fbbf3f823854839b61049d8
+SIZE (Horde/content-1.0.0.tgz) = 18025
diff --git a/devel/horde4-content/files/pkg-message.in b/devel/horde4-content/files/pkg-message.in
deleted file mode 100644
index f014ccc943f7..000000000000
--- a/devel/horde4-content/files/pkg-message.in
+++ /dev/null
@@ -1,7 +0,0 @@
-************************************************************************
-content has been installed in %%HORDIR%%/.
-
-Horde must be configured and the tables created; if not, see
-`pkg_info -Dx horde-base'.
-
-************************************************************************
diff --git a/devel/horde4-content/pkg-plist b/devel/horde4-content/pkg-plist
deleted file mode 100644
index 5a6c1a9a137e..000000000000
--- a/devel/horde4-content/pkg-plist
+++ /dev/null
@@ -1,36 +0,0 @@
-%%HORDIR%%/1_rampage_base_tables.php
-%%HORDIR%%/2_rampage_tag_tables.php
-%%HORDIR%%/Application.php
-%%HORDIR%%/Exception.php
-%%HORDIR%%/Index/Index.php
-%%HORDIR%%/Index/IndexMapper.php
-%%HORDIR%%/Linkbacks/Linkback.php
-%%HORDIR%%/Linkbacks/LinkbackMapper.php
-%%HORDIR%%/Objects/Manager.php
-%%HORDIR%%/Objects/Object.php
-%%HORDIR%%/Objects/ObjectMapper.php
-%%HORDIR%%/Relationships/Relationship.php
-%%HORDIR%%/Relationships/RelationshipMapper.php
-%%HORDIR%%/Tagger.php
-%%HORDIR%%/Tags/Tag.php
-%%HORDIR%%/Tags/TagMapper.php
-%%HORDIR%%/Types/Manager.php
-%%HORDIR%%/Users/Manager.php
-%%HORDIR%%/controllers/ApplicationController.php
-%%HORDIR%%/controllers/TagController.php
-%%HORDIR%%/placeholder.dist
-%%HORDIR%%/routes.php
-%%HORDIR%%/views/Tag/recentTags.html.php
-%%HORDIR%%/views/Tag/searchTags.html.php
-@dirrm %%HORDIR%%/views/Tag
-@dirrm %%HORDIR%%/views
-@dirrm %%HORDIR%%/controllers
-@dirrm %%HORDIR%%/Users
-@dirrm %%HORDIR%%/Types
-@dirrm %%HORDIR%%/Tags
-@dirrm %%HORDIR%%/Relationships
-@dirrm %%HORDIR%%/Objects
-@dirrm %%HORDIR%%/Linkbacks
-@dirrm %%HORDIR%%/Index
-@dirrmtry %%HORDIR%%
-@dirrmtry %%HORBAS%%