aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-11-04 18:45:06 +0800
committerbapt <bapt@FreeBSD.org>2013-11-04 18:45:06 +0800
commit0d0b67f2c78045cae99e48bc2d1be1aa1e8d3693 (patch)
treeb206f371ed78a1af92f9c307d4684f99509425f3
parentaec055220df1b263ebcd6629e31ac7b5855bf18f (diff)
downloadfreebsd-ports-gnome-0d0b67f2c78045cae99e48bc2d1be1aa1e8d3693.tar.gz
freebsd-ports-gnome-0d0b67f2c78045cae99e48bc2d1be1aa1e8d3693.tar.zst
freebsd-ports-gnome-0d0b67f2c78045cae99e48bc2d1be1aa1e8d3693.zip
Use tar to extract, while here, stagify
-rw-r--r--polish/hunspell/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/polish/hunspell/Makefile b/polish/hunspell/Makefile
index 1bf6574aba4a..0afd21877007 100644
--- a/polish/hunspell/Makefile
+++ b/polish/hunspell/Makefile
@@ -13,19 +13,19 @@ COMMENT= Polish hunspell dictionaries
LICENSE= LGPL21 GPLv2 MPL
LICENSE_COMB= dual
-USE_ZIP= yes
+EXTRACT_SUFX= .zip
NO_BUILD= yes
PLIST_FILES= %%DATADIR%%/pl_PL.aff \
%%DATADIR%%/pl_PL.dic
PLIST_DIRSTRY= %%DATADIR%%
-NO_STAGE= yes
post-extract:
- @${EXTRACT_CMD} ${WRKDIR}/pl_PL.zip -d ${WRKSRC}/
+ @${MKDIR} ${WRKSRC}
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/pl_PL.zip -C ${WRKSRC}/
do-install:
- ${MKDIR} ${DATADIR}/
- ${INSTALL_DATA} ${WRKSRC}/pl_PL.aff ${WRKSRC}/pl_PL.dic ${DATADIR}/
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/pl_PL.aff ${WRKSRC}/pl_PL.dic ${STAGEDIR}${DATADIR}/
.include <bsd.port.mk>