aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-03-15 06:32:49 +0800
committergerald <gerald@FreeBSD.org>2009-03-15 06:32:49 +0800
commit0fd14c51f33aee0774f26f881a565e20510aa48f (patch)
tree6cbc9faf9e8496aeeadc1d82cdfa3e774b761969
parenteb321f9c4009655c1bf984845675db9405ed45dd (diff)
downloadfreebsd-ports-gnome-0fd14c51f33aee0774f26f881a565e20510aa48f.tar.gz
freebsd-ports-gnome-0fd14c51f33aee0774f26f881a565e20510aa48f.tar.zst
freebsd-ports-gnome-0fd14c51f33aee0774f26f881a565e20510aa48f.zip
Remove gcc-testsuite from DISTFILES, along with the post-build and
check targets. This reduces disk and bandwidth consumptions for a feature (apparently) never used. Remove obsolete code to create (empty) man pages in case regular man pages cannot be created. Address build failure caused by Mk/bsd.port.mk changes mid 2008. [1] (I will go ahead and remove this port per the DEPRECATION note, but figured these backports from newer versions may be helpful in case someone wants to play with it nevertheless.) PR: 132379 [1] Submitted by: Rikiya YONEMOTO [1]
-rw-r--r--lang/gcc33/Makefile23
1 files changed, 5 insertions, 18 deletions
diff --git a/lang/gcc33/Makefile b/lang/gcc33/Makefile
index 66f1a87c0dbf..5fa114e26547 100644
--- a/lang/gcc33/Makefile
+++ b/lang/gcc33/Makefile
@@ -16,13 +16,12 @@ MASTER_SITE_SUBDIR= releases/gcc-${PORTVERSION}
DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
gcc-g++-${PORTVERSION}${EXTRACT_SUFX} \
gcc-g77-${PORTVERSION}${EXTRACT_SUFX} \
- gcc-objc-${PORTVERSION}${EXTRACT_SUFX} \
- gcc-testsuite-${PORTVERSION}${EXTRACT_SUFX}
+ gcc-objc-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 3.3
-DEPRECATED= fails to build on any version of FreeBSD, closed upstream for half a decade
+DEPRECATED= fails to build on FreeBSD 8 and above, not a single complaint when it failed to build for half a year, closed upstream for half a decade
EXPIRATION_DATE=2009-03-03
SUFFIX= 33
@@ -53,7 +52,8 @@ SRCDIR= ${WRKDIR}/gcc-${PORTVERSION}
WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --disable-nls \
+CONFIGURE_ARGS+=--host=${CONFIGURE_TARGET} --target=${CONFIGURE_TARGET} \
+ --disable-nls \
--with-system-zlib \
--program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
@@ -88,20 +88,7 @@ pre-configure:
@${RM} -f ${SRCDIR}/gcc/*/*.info*
@${MKDIR} ${CONFIGURE_WRKSRC}
-post-build:
- @${ECHO_MSG} "Consider running 'make check' before 'make install', especially"
- @${ECHO_MSG} "if you have not performed this build on -STABLE or -CURRENT."
- @${ECHO_MSG} "This assumes that you have the dejagnu port installed."
-
-check: build
- cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
-
post-install:
- # man pages can only be generated if Perl >= 5.6 is installed;
- # fake them otherwise.
- for mp in ${_MANPAGES}; do \
- ${TEST} -e $${mp} || ${TOUCH} ${TOUCH_FLAGS} $${mp}; \
- done
.for f in c++ g77 gcc g++ cpp gcov ${CONFIGURE_TARGET}-gcc ${CONFIGURE_TARGET}-g++
# gij and jv-convert, for example, are not built on all platforms.
if [ -e ${PREFIX}/man/man1/${f}.1 ]; then \
@@ -111,9 +98,9 @@ post-install:
.endfor
${MV} -f ${PREFIX}/bin/g77${SUFFIX} ${PREFIX}/bin/g77-${SUFFIX}
-${MV} -f ${PREFIX}/man/man1/g77${SUFFIX}.1 ${PREFIX}/man/man1/g77-${SUFFIX}.1
- ${RM} -f ${TARGLIB}/*.la
${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
+ ${RM} -f ${TARGLIB}/*.la
# Add target libraries and include files to packaging list.
${RM} -f ${WRKDIR}/PLIST.lib
.for d in ${TARGLIB:S/^${PREFIX}\///} include/gnu