aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-10 23:02:32 +0800
committertijl <tijl@FreeBSD.org>2014-07-10 23:02:32 +0800
commit11357ec83d622f6ba54ccf33f8fc5b63869a89e1 (patch)
tree92dcc36127123d31568363f04c80366e71fd19a2
parent4946cee25f29788c7b1e56bd472a6cd862eed580 (diff)
downloadfreebsd-ports-gnome-11357ec83d622f6ba54ccf33f8fc5b63869a89e1.tar.gz
freebsd-ports-gnome-11357ec83d622f6ba54ccf33f8fc5b63869a89e1.tar.zst
freebsd-ports-gnome-11357ec83d622f6ba54ccf33f8fc5b63869a89e1.zip
- Depend on net/libosip2 instead of net/libosip
- Add INSTALL_TARGET=install-strip - Use @sample
-rw-r--r--net/siproxd/Makefile23
-rw-r--r--net/siproxd/files/patch-src__dejitter.c11
-rw-r--r--net/siproxd/pkg-plist4
3 files changed, 23 insertions, 15 deletions
diff --git a/net/siproxd/Makefile b/net/siproxd/Makefile
index 832fbdf76614..e7da3d4350ac 100644
--- a/net/siproxd/Makefile
+++ b/net/siproxd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= siproxd
PORTVERSION= 0.7.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= SF
@@ -12,20 +12,20 @@ COMMENT= Proxy/masquerading daemon for the SIP protocol
LICENSE= GPLv2
-LIB_DEPENDS= libosip2.so:${PORTSDIR}/net/libosip
+LIB_DEPENDS= libosip2.so:${PORTSDIR}/net/libosip2
+# :keepla because port uses lt_dlopen
USES= libtool:keepla
USE_RC_SUBR= siproxd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-doc --disable-static --with-libosip-prefix=${PREFIX}
+INSTALL_TARGET= install-strip
PORTDOCS1= AUTHORS ChangeLog README RELNOTES
PORTDOCS2= FAQ KNOWN_BUGS RFC3261_compliance.txt \
sample_cfg_budgetone.txt sample_cfg_x-lite.txt
PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's,-lgnugetopt,,g ; 24600d ; 23998s,doc/Makefile ,,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
@@ -43,12 +43,9 @@ post-install:
.for docs in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
- ${CP} ${WRKSRC}/doc/siproxd.conf.example ${STAGEDIR}${PREFIX}/etc
- ${CP} ${WRKSRC}/doc/siproxd_passwd.cfg ${STAGEDIR}${PREFIX}/etc
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_defaulttarget.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_demo.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_fix_bogus_via.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_logcall.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_shortdial.so
-
-.include <bsd.port.post.mk>
+ ${INSTALL_DATA} ${WRKSRC}/doc/siproxd.conf.example \
+ ${STAGEDIR}${PREFIX}/etc/siproxd.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/doc/siproxd_passwd.cfg \
+ ${STAGEDIR}${PREFIX}/etc/siproxd_passwd.cfg.sample
+
+.include <bsd.port.mk>
diff --git a/net/siproxd/files/patch-src__dejitter.c b/net/siproxd/files/patch-src__dejitter.c
new file mode 100644
index 000000000000..fac55474ee77
--- /dev/null
+++ b/net/siproxd/files/patch-src__dejitter.c
@@ -0,0 +1,11 @@
+--- src/dejitter.c.orig 2014-07-10 16:37:54.000000000 +0200
++++ src/dejitter.c 2014-07-10 16:38:40.000000000 +0200
+@@ -24,6 +24,8 @@
+
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <sys/time.h>
++#include <string.h>
+ #include <netinet/in.h>
+
+ #include <osipparser2/osip_parser.h>
diff --git a/net/siproxd/pkg-plist b/net/siproxd/pkg-plist
index 3d85b0842e5b..18f574376a38 100644
--- a/net/siproxd/pkg-plist
+++ b/net/siproxd/pkg-plist
@@ -1,5 +1,5 @@
-etc/siproxd.conf.example
-etc/siproxd_passwd.cfg
+@sample etc/siproxd.conf.sample
+@sample etc/siproxd_passwd.cfg.sample
lib/siproxd/plugin_defaulttarget.la
lib/siproxd/plugin_defaulttarget.so
lib/siproxd/plugin_demo.la