aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-01-14 16:37:19 +0800
committerdinoex <dinoex@FreeBSD.org>2010-01-14 16:37:19 +0800
commit12e6d08b757ad6424121ef8ff359377b63e16008 (patch)
tree9d51e0d43cd25feb80199e091f53dc34f42e3e55
parent323f17ef7057d40dbc09dfe4f0b00caee399a62f (diff)
downloadfreebsd-ports-gnome-12e6d08b757ad6424121ef8ff359377b63e16008.tar.gz
freebsd-ports-gnome-12e6d08b757ad6424121ef8ff359377b63e16008.tar.zst
freebsd-ports-gnome-12e6d08b757ad6424121ef8ff359377b63e16008.zip
- fix rx filename
PR: 141670 Obtained from: http://ttssh2.sourceforge.jp/patch/lrzsz-rxfliename.patch
-rw-r--r--comms/lrzsz/Makefile2
-rw-r--r--comms/lrzsz/files/patch-lrz.c24
-rw-r--r--comms/lrzsz/files/patch-src::lrz.c15
3 files changed, 25 insertions, 16 deletions
diff --git a/comms/lrzsz/Makefile b/comms/lrzsz/Makefile
index f8b629853372..75d2b4174d1b 100644
--- a/comms/lrzsz/Makefile
+++ b/comms/lrzsz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lrzsz
PORTVERSION= 0.12.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
MASTER_SITES= http://www.netsw.org/net/modem/protocols/zmodem/lrzsz/ \
http://www.ohse.de/uwe/releases/
diff --git a/comms/lrzsz/files/patch-lrz.c b/comms/lrzsz/files/patch-lrz.c
new file mode 100644
index 000000000000..34655a309ee6
--- /dev/null
+++ b/comms/lrzsz/files/patch-lrz.c
@@ -0,0 +1,24 @@
+--- src/lrz.c.orig 1998-12-30 08:49:24.000000000 +0100
++++ src/lrz.c 2010-01-14 09:33:32.000000000 +0100
+@@ -494,6 +494,8 @@
+ usage(2,_("garbage on commandline"));
+ if (protocol!=ZM_XMODEM && npats)
+ usage(2, _("garbage on commandline"));
++ if (protocol==ZM_XMODEM && !npats)
++ usage(2, _("need a file name to receive"));
+ if (Restricted && allow_remote_commands) {
+ allow_remote_commands=FALSE;
+ }
+@@ -1159,9 +1161,9 @@
+
+ nameend = name + 1 + strlen(name);
+ if (*nameend) { /* file coming from Unix or DOS system */
+- long modtime;
+- long bytes_total;
+- int mode;
++ long modtime=0;
++ long bytes_total=DEFBYTL;
++ int mode=0;
+ sscanf(nameend, "%ld%lo%o", &bytes_total, &modtime, &mode);
+ zi->modtime=modtime;
+ zi->bytes_total=bytes_total;
diff --git a/comms/lrzsz/files/patch-src::lrz.c b/comms/lrzsz/files/patch-src::lrz.c
deleted file mode 100644
index 9a1af487d185..000000000000
--- a/comms/lrzsz/files/patch-src::lrz.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/lrz.c.orig Sun Sep 28 16:02:13 2003
-+++ src/lrz.c Sun Sep 28 16:02:34 2003
-@@ -1159,9 +1159,9 @@
-
- nameend = name + 1 + strlen(name);
- if (*nameend) { /* file coming from Unix or DOS system */
-- long modtime;
-- long bytes_total;
-- int mode;
-+ long modtime=0;
-+ long bytes_total=DEFBYTL;
-+ int mode=0;
- sscanf(nameend, "%ld%lo%o", &bytes_total, &modtime, &mode);
- zi->modtime=modtime;
- zi->bytes_total=bytes_total;