aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-12-10 21:39:21 +0800
committerantoine <antoine@FreeBSD.org>2016-12-10 21:39:21 +0800
commit1389afe549c73e346d2163c092d75d5e05f5ef1e (patch)
treef7797d3c7360ee39bc6dfdccfabe237a2654ceea
parentb711815b71e7fb16afcffda3951e675243a4a72d (diff)
downloadfreebsd-ports-gnome-1389afe549c73e346d2163c092d75d5e05f5ef1e.tar.gz
freebsd-ports-gnome-1389afe549c73e346d2163c092d75d5e05f5ef1e.tar.zst
freebsd-ports-gnome-1389afe549c73e346d2163c092d75d5e05f5ef1e.zip
Move py35-mysqlclient and py35-psycopg2 to match existing naming convention
-rw-r--r--MOVED6
-rw-r--r--databases/Makefile4
-rw-r--r--databases/py-mysqlclient/Makefile2
-rw-r--r--databases/py-psycopg2/Makefile2
-rw-r--r--databases/py3-mysqlclient/Makefile (renamed from databases/py35-mysqlclient/Makefile)2
-rw-r--r--databases/py3-psycopg2/Makefile (renamed from databases/py35-psycopg2/Makefile)2
6 files changed, 10 insertions, 8 deletions
diff --git a/MOVED b/MOVED
index 339e8703b7a0..7c324be872c3 100644
--- a/MOVED
+++ b/MOVED
@@ -8818,8 +8818,8 @@ java/jakarta-struts||2016-12-01|Has expired: Port is unmaintained and has known
www/rubygem-url-mount|www/rubygem-url_mount|2016-12-03|Rename to match our rubygems naming
editors/focuswriter-qt4|editors/focuswriter|2016-12-03|Qt4 support was dropped, use editors/focuswriter instead
graphics/gtkdps||2016-12-04|Has expired: No more upstream. Not used in the ports tree
-security/gsfv||2016-12-04|Has expired: No more upstream.
-misc/grun||2016-12-04|Has expired: No more upstream.
+security/gsfv||2016-12-04|Has expired: No more upstream
+misc/grun||2016-12-04|Has expired: No more upstream
devel/py-argparse||2016-12-04|Has expired: Part of Python standard library for Python >= 2.7 and >= 3.2
www/node7|www/node|2016-12-07|www/node is now www/node7
databases/py-sqlalchemy06|databases/py-sqlalchemy10|2016-12-08|Has expired: Upstream has declared this version EoL: please migrate to databases/py-sqlalchemy10
@@ -8829,3 +8829,5 @@ graphics/py-aafigure||2016-12-08|Has expired: Depends on broken and expired py-r
converters/py-pisa||2016-12-08|Has expired: Deprecated upstream, depends on broken and expired py-reportlab2
graphics/ocrfeeder||2016-12-08|Has expired: Depends on broken and expired py-reportlab2
devel/libcppformat|devel/libfmt|2016-12-08|Project was renamed
+databases/py35-mysqlclient|databases/py3-mysqlclient|2016-12-10|Moved to match existing naming convention
+databases/py35-psycopg2|databases/py3-psycopg2|2016-12-10|Moved to match existing naming convention
diff --git a/databases/Makefile b/databases/Makefile
index 21dffb7bd51e..4356faf308c8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -790,13 +790,13 @@
SUBDIR += py-unqlite
SUBDIR += py-whisper
SUBDIR += py3-bsddb3
+ SUBDIR += py3-mysqlclient
+ SUBDIR += py3-psycopg2
SUBDIR += py33-gdbm
SUBDIR += py33-sqlite3
SUBDIR += py34-gdbm
SUBDIR += py34-sqlite3
SUBDIR += py35-gdbm
- SUBDIR += py35-mysqlclient
- SUBDIR += py35-psycopg2
SUBDIR += py35-sqlite3
SUBDIR += pydbx
SUBDIR += pymongo
diff --git a/databases/py-mysqlclient/Makefile b/databases/py-mysqlclient/Makefile
index 5b984dd9dff7..777b8e70504c 100644
--- a/databases/py-mysqlclient/Makefile
+++ b/databases/py-mysqlclient/Makefile
@@ -8,7 +8,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= neel@neelc.org
COMMENT= MySQL database connector for Python
-USES= python mysql
+USES?= python mysql
USE_PYTHON= distutils autoplist
USE_GITHUB= yes
GH_ACCOUNT= pymysql
diff --git a/databases/py-psycopg2/Makefile b/databases/py-psycopg2/Makefile
index 1b10dbdef405..a3c7a1b4f474 100644
--- a/databases/py-psycopg2/Makefile
+++ b/databases/py-psycopg2/Makefile
@@ -16,7 +16,7 @@ LICENSE= LGPL3
OPTIONS_DEFINE= DOCS EXAMPLES
USE_PYTHON= autoplist concurrent distutils
-USES= pgsql python
+USES?= pgsql python
PORTDOCS= AUTHORS INSTALL NEWS PKG-INFO README.rst
PORTEXAMPLES= *
diff --git a/databases/py35-mysqlclient/Makefile b/databases/py3-mysqlclient/Makefile
index 8ae9f742c240..0bc5e5f2d68d 100644
--- a/databases/py35-mysqlclient/Makefile
+++ b/databases/py3-mysqlclient/Makefile
@@ -2,6 +2,6 @@
MASTERDIR= ${.CURDIR}/../py-mysqlclient
-PYTHON_VERSION= python3.5
+USES= python:3.3+ mysql
.include "${MASTERDIR}/Makefile"
diff --git a/databases/py35-psycopg2/Makefile b/databases/py3-psycopg2/Makefile
index d3b6c822b97c..49eb46b437bb 100644
--- a/databases/py35-psycopg2/Makefile
+++ b/databases/py3-psycopg2/Makefile
@@ -2,6 +2,6 @@
MASTERDIR= ${.CURDIR}/../py-psycopg2
-PYTHON_VERSION= python3.5
+USES= pgsql python:3.3+
.include "${MASTERDIR}/Makefile"