aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-09 22:36:01 +0800
committermiwi <miwi@FreeBSD.org>2009-02-09 22:36:01 +0800
commit14019dc8858396fe674a225f6150f096f2669c56 (patch)
tree7d97d74f4dde9205e2c0026665523d20874f94b4
parenta05d3e67f0b8089e1fb36cb141b1778ce179b3f4 (diff)
downloadfreebsd-ports-gnome-14019dc8858396fe674a225f6150f096f2669c56.tar.gz
freebsd-ports-gnome-14019dc8858396fe674a225f6150f096f2669c56.tar.zst
freebsd-ports-gnome-14019dc8858396fe674a225f6150f096f2669c56.zip
- Fix missing patches to fix the build
-rw-r--r--devel/kdesdk4/files/patch-kapptemplate__CMakeLists.txt11
-rw-r--r--misc/kdeedu4/files/patch-cmake__modules__FindBoostPython.cmake13
-rw-r--r--misc/kdeedu4/files/patch-cmake__modules__FindCFitsio.cmake25
-rw-r--r--misc/kdeedu4/files/patch-cmake__modules__FindopenBabel2.cmake68
-rw-r--r--misc/kdeedu4/files/patch-kalzium__src__CMakeLists.txt11
-rw-r--r--www/kdewebdev4/files/patch-klinkstatus__src__plugins__scripting__scripts__CMakeLists.txt19
-rw-r--r--x11/kde4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake29
-rw-r--r--x11/kdebase4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake29
8 files changed, 205 insertions, 0 deletions
diff --git a/devel/kdesdk4/files/patch-kapptemplate__CMakeLists.txt b/devel/kdesdk4/files/patch-kapptemplate__CMakeLists.txt
new file mode 100644
index 000000000000..8db2ab4dc4e2
--- /dev/null
+++ b/devel/kdesdk4/files/patch-kapptemplate__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ../kapptemplate/CMakeLists.txt.orig 2008-12-10 16:13:41.000000000 +0000
++++ ../kapptemplate/CMakeLists.txt 2008-12-30 20:15:18.000000000 +0000
+@@ -5,7 +5,7 @@
+ include(KAppTemplateMacro)
+
+ add_subdirectory(icons)
+-add_subdirectory(templates)
++# add_subdirectory(templates)
+ add_subdirectory(tests)
+
+ set(kapptemplate_SRCS
diff --git a/misc/kdeedu4/files/patch-cmake__modules__FindBoostPython.cmake b/misc/kdeedu4/files/patch-cmake__modules__FindBoostPython.cmake
new file mode 100644
index 000000000000..c0ecd68cc762
--- /dev/null
+++ b/misc/kdeedu4/files/patch-cmake__modules__FindBoostPython.cmake
@@ -0,0 +1,13 @@
+--- ../cmake/modules/FindBoostPython.cmake.orig 2008-11-04 17:12:46.000000000 +0000
++++ ../cmake/modules/FindBoostPython.cmake 2008-12-30 21:25:59.000000000 +0000
+@@ -21,8 +21,8 @@
+ include(CheckLibraryExists)
+
+ # reset vars
+-set(BOOST_PYTHON_INCLUDES)
+-set(BOOST_PYTHON_LIBS)
++# set(BOOST_PYTHON_INCLUDES)
++# set(BOOST_PYTHON_LIBS)
+
+ # handy arrays
+ set(PYTHON_VERSIONS "python;python2.6;python2.5;python2.4;python2.3;python2.2")
diff --git a/misc/kdeedu4/files/patch-cmake__modules__FindCFitsio.cmake b/misc/kdeedu4/files/patch-cmake__modules__FindCFitsio.cmake
new file mode 100644
index 000000000000..820f49eb159d
--- /dev/null
+++ b/misc/kdeedu4/files/patch-cmake__modules__FindCFitsio.cmake
@@ -0,0 +1,25 @@
+--- ../cmake/modules/FindCFitsio.cmake.orig 2008-12-21 20:20:00.000000000 +0000
++++ ../cmake/modules/FindCFitsio.cmake 2009-01-30 22:25:02.000000000 +0000
+@@ -23,19 +23,19 @@
+ IF (NOT WIN32)
+ find_package(PkgConfig)
+ IF (PKG_CONFIG_FOUND)
+- pkg_check_modules(CFITSIO cfitsio)
++ pkg_check_modules(PC_CFITSIO cfitsio)
+ ENDIF (PKG_CONFIG_FOUND)
+ ENDIF (NOT WIN32)
+
+ find_path(CFITSIO_INCLUDE_DIR fitsio.h
+- ${CFITSIO_INCLUDE_DIRS}
++ ${PC_CFITSIO_INCLUDE_DIRS}
+ ${_obIncDir}
+ ${GNUWIN32_DIR}/include
+ )
+
+ find_library(CFITSIO_LIBRARIES NAMES cfitsio libcfitsio
+ PATHS
+- ${CFITSIO_LIBRARY_DIRS}
++ ${PC_CFITSIO_LIBRARY_DIRS}
+ ${_obLinkDir}
+ ${GNUWIN32_DIR}/lib
+ )
diff --git a/misc/kdeedu4/files/patch-cmake__modules__FindopenBabel2.cmake b/misc/kdeedu4/files/patch-cmake__modules__FindopenBabel2.cmake
new file mode 100644
index 000000000000..546ac033793f
--- /dev/null
+++ b/misc/kdeedu4/files/patch-cmake__modules__FindopenBabel2.cmake
@@ -0,0 +1,68 @@
+diff -u ../cmake/modules/FindOpenBabel2.cmake ../cmake/modules/FindOpenBabel2.cmake
+--- ../cmake/modules/FindOpenBabel2.cmake 2009/01/25 12:06:30 916420
++++ ../cmake/modules/FindOpenBabel2.cmake 2009/01/26 22:11:35 917115
+@@ -4,6 +4,7 @@
+ # OPENBABEL2_FOUND - system has OpenBabel2
+ # OPENBABEL2_INCLUDE_DIR - the OpenBabel2 include directory
+ # OPENBABEL2_LIBRARIES - Link these to use OpenBabel2
++# Copyright (C) 2006, 2009 Pino Toscano, <pino@kde.org>
+ # Copyright (c) 2006, 2007 Carsten Niehaus, <cniehaus@gmx.de>
+ # Copyright (C) 2008 Marcus D. Hanwell <marcus@cryos.org>
+ # Redistribution and use is allowed according to the terms of the BSD license.
+@@ -18,13 +19,11 @@
+
+ # Use the newer PkgConfig stuff
+ find_package(PkgConfig REQUIRED)
+- pkg_check_modules(OPENBABEL2 openbabel-2.0>=2.2.0)
++ pkg_check_modules(PC_OPENBABEL2 openbabel-2.0>=2.2.0)
+
+- # Maintain backwards compatibility with previous version of module
+- if(OPENBABEL2_FOUND STREQUAL "1")
++ if(PC_OPENBABEL2_FOUND)
+ set(OPENBABEL2_VERSION_MET TRUE)
+- set(OPENBABEL2_INCLUDE_DIR ${OPENBABEL2_INCLUDE_DIRS})
+- endif(OPENBABEL2_FOUND STREQUAL "1")
++ endif(PC_OPENBABEL2_FOUND)
+
+ else(NOT WIN32)
+ set(OPENBABEL2_VERSION_MET TRUE)
+@@ -32,28 +31,19 @@
+
+ if(OPENBABEL2_VERSION_MET)
+
+- # find_path(OPENBABEL2_INCLUDE_DIR openbabel/obconversion.h
+- # PATHS
+- # ${_obIncDir}
+- # ${GNUWIN32_DIR}/include
+- # $ENV{OPENBABEL2_INCLUDE_DIR}
+- # )
+-
+- if(WIN32)
+- if(NOT OPENBABEL2_INCLUDE_DIR)
+- find_path(OPENBABEL2_INCLUDE_DIR openbabel/obconversion.h
+- PATHS
+- ${_obIncDir}
+- ${GNUWIN32_DIR}/include
+- $ENV{OPENBABEL2_INCLUDE_DIR}
+- PATH_SUFFIXES openbabel-2.0
+- )
+- endif(NOT OPENBABEL2_INCLUDE_DIR)
+- endif(WIN32)
++ find_path(OPENBABEL2_INCLUDE_DIR openbabel/obconversion.h
++ PATHS
++ ${PC_OPENBABEL2_INCLUDEDIR}
++ ${PC_OPENBABEL2_INCLUDE_DIRS}
++ ${GNUWIN32_DIR}/include
++ $ENV{OPENBABEL2_INCLUDE_DIR}
++ PATH_SUFFIXES openbabel-2.0
++ )
+
+- find_library(OPENBABEL2_LIBRARIES NAMES openbabel
++ find_library(OPENBABEL2_LIBRARIES NAMES openbabel openbabel-2
+ PATHS
+- ${_obLinkDir}
++ ${PC_OPENBABEL2_LIBDIR}
++ ${PC_OPENBABEL2_LIBRARY_DIRS}
+ ${GNUWIN32_DIR}/lib
+ $ENV{OPENBABEL2_LIBRARIES}
+ )
diff --git a/misc/kdeedu4/files/patch-kalzium__src__CMakeLists.txt b/misc/kdeedu4/files/patch-kalzium__src__CMakeLists.txt
new file mode 100644
index 000000000000..b8597576c2cd
--- /dev/null
+++ b/misc/kdeedu4/files/patch-kalzium__src__CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ../kalzium/src/CMakeLists.txt.orig 2008-08-20 19:53:43.000000000 +0000
++++ ../kalzium/src/CMakeLists.txt 2008-12-30 20:34:27.000000000 +0000
+@@ -138,7 +138,7 @@
+ set(kalzium_EXTRA_LIBS ${kalzium_EXTRA_LIBS} ${OCAML_NUMS_LIBRARY})
+ endif (OCAML_NUMS_LIBRARY)
+
+- target_link_libraries(kalzium ${kalzium_EXTRA_LIBS} m dl)
++ target_link_libraries(kalzium ${kalzium_EXTRA_LIBS} m)
+ endif(LIBFACILE_FOUND)
+
+ install(TARGETS kalzium ${INSTALL_TARGETS_DEFAULT_ARGS} )
diff --git a/www/kdewebdev4/files/patch-klinkstatus__src__plugins__scripting__scripts__CMakeLists.txt b/www/kdewebdev4/files/patch-klinkstatus__src__plugins__scripting__scripts__CMakeLists.txt
new file mode 100644
index 000000000000..35c041746874
--- /dev/null
+++ b/www/kdewebdev4/files/patch-klinkstatus__src__plugins__scripting__scripts__CMakeLists.txt
@@ -0,0 +1,19 @@
+--- ../klinkstatus/src/plugins/scripting/scripts/CMakeLists.txt.orig 2008-12-21 20:20:00.000000000 +0000
++++ ../klinkstatus/src/plugins/scripting/scripts/CMakeLists.txt 2009-01-27 22:15:16.000000000 +0000
+@@ -5,7 +5,7 @@
+ macro_optional_find_package(RUBY)
+ macro_log_feature(RUBY_FOUND "Ruby" "An Interpreted object-oriented scripting language" "http://www.ruby-lang.org" FALSE "" "For KLinkStatus example ruby scripts")
+
+-if(RUBY_FOUND)
++# if(RUBY_FOUND)
+
+ include_directories(${RUBY_INCLUDE_PATH})
+
+@@ -17,6 +17,6 @@
+ examples/statistics/statistics.rb
+ DESTINATION ${DATA_INSTALL_DIR}/klinkstatus/scripts)
+
+-endif(RUBY_FOUND)
++# endif(RUBY_FOUND)
+
+
diff --git a/x11/kde4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake b/x11/kde4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake
new file mode 100644
index 000000000000..a71e40083978
--- /dev/null
+++ b/x11/kde4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake
@@ -0,0 +1,29 @@
+--- ../cmake/modules/FindPulseAudio.cmake.orig 2008-09-03 11:24:24.000000000 +0000
++++ ../cmake/modules/FindPulseAudio.cmake 2008-12-27 14:20:09.000000000 +0000
+@@ -16,16 +16,16 @@
+ set(PULSEAUDIO_FIND_QUIETLY TRUE)
+ endif (PULSEAUDIO_INCLUDE_DIR AND PULSEAUDIO_LIBRARY)
+
+-if (NOT WIN32)
+- include(FindPkgConfig)
+- pkg_check_modules(PULSEAUDIO libpulse)
+- if(PULSEAUDIO_FOUND)
+- set(PULSEAUDIO_LIBRARY ${PULSEAUDIO_LIBRARIES} CACHE FILEPATH "Path to the PulseAudio library")
+- set(PULSEAUDIO_INCLUDE_DIR ${PULSEAUDIO_INCLUDEDIR} CACHE PATH "Path to the PulseAudio includes")
+- # PULSEAUDIO_DEFINITIONS - Compiler switches required for using PulseAudio
+- # set(PULSEAUDIO_DEFINITIONS ${PULSEAUDIO_CFLAGS})
+- endif(PULSEAUDIO_FOUND)
+-endif (NOT WIN32)
++# if (NOT WIN32)
++# include(FindPkgConfig)
++# pkg_check_modules(PULSEAUDIO libpulse)
++# if(PULSEAUDIO_FOUND)
++# set(PULSEAUDIO_LIBRARY ${PULSEAUDIO_LIBRARIES} CACHE FILEPATH "Path to the PulseAudio library")
++# set(PULSEAUDIO_INCLUDE_DIR ${PULSEAUDIO_INCLUDEDIR} CACHE PATH "Path to the PulseAudio includes")
++# # PULSEAUDIO_DEFINITIONS - Compiler switches required for using PulseAudio
++# # set(PULSEAUDIO_DEFINITIONS ${PULSEAUDIO_CFLAGS})
++# endif(PULSEAUDIO_FOUND)
++# endif (NOT WIN32)
+
+ if (NOT PULSEAUDIO_INCLUDE_DIR)
+ FIND_PATH(PULSEAUDIO_INCLUDE_DIR pulse/pulseaudio.h)
diff --git a/x11/kdebase4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake b/x11/kdebase4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake
new file mode 100644
index 000000000000..a71e40083978
--- /dev/null
+++ b/x11/kdebase4-runtime/files/patch-cmake_modules_FindPulseAudio.cmake
@@ -0,0 +1,29 @@
+--- ../cmake/modules/FindPulseAudio.cmake.orig 2008-09-03 11:24:24.000000000 +0000
++++ ../cmake/modules/FindPulseAudio.cmake 2008-12-27 14:20:09.000000000 +0000
+@@ -16,16 +16,16 @@
+ set(PULSEAUDIO_FIND_QUIETLY TRUE)
+ endif (PULSEAUDIO_INCLUDE_DIR AND PULSEAUDIO_LIBRARY)
+
+-if (NOT WIN32)
+- include(FindPkgConfig)
+- pkg_check_modules(PULSEAUDIO libpulse)
+- if(PULSEAUDIO_FOUND)
+- set(PULSEAUDIO_LIBRARY ${PULSEAUDIO_LIBRARIES} CACHE FILEPATH "Path to the PulseAudio library")
+- set(PULSEAUDIO_INCLUDE_DIR ${PULSEAUDIO_INCLUDEDIR} CACHE PATH "Path to the PulseAudio includes")
+- # PULSEAUDIO_DEFINITIONS - Compiler switches required for using PulseAudio
+- # set(PULSEAUDIO_DEFINITIONS ${PULSEAUDIO_CFLAGS})
+- endif(PULSEAUDIO_FOUND)
+-endif (NOT WIN32)
++# if (NOT WIN32)
++# include(FindPkgConfig)
++# pkg_check_modules(PULSEAUDIO libpulse)
++# if(PULSEAUDIO_FOUND)
++# set(PULSEAUDIO_LIBRARY ${PULSEAUDIO_LIBRARIES} CACHE FILEPATH "Path to the PulseAudio library")
++# set(PULSEAUDIO_INCLUDE_DIR ${PULSEAUDIO_INCLUDEDIR} CACHE PATH "Path to the PulseAudio includes")
++# # PULSEAUDIO_DEFINITIONS - Compiler switches required for using PulseAudio
++# # set(PULSEAUDIO_DEFINITIONS ${PULSEAUDIO_CFLAGS})
++# endif(PULSEAUDIO_FOUND)
++# endif (NOT WIN32)
+
+ if (NOT PULSEAUDIO_INCLUDE_DIR)
+ FIND_PATH(PULSEAUDIO_INCLUDE_DIR pulse/pulseaudio.h)